Bump vor abspielen von sounds

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
iwconfig
Beiträge: 103
Registriert: 17.08.2008 13:10:04

Bump vor abspielen von sounds

Beitrag von iwconfig » 11.09.2019 09:34:50

Hi,

nach dem update von stretch auf buster habe ich ein Sound-Problem: Der Sound funktioniert prinzipiell, aber es gibt immer erst einen lauten "bump" bevor der normale sound kommt. Wenn ich ein Lied abspielen will, macht es "bump", dann geht's los und läuft normal. Wenn z.B. in der Konsole, wenn man zB doppelt Tab drückt, der normale zugehörige Sound kommt, kommt davor auch ein "Bump". Wenn ich mehrfach Tab drücke, kommt nur vor dem ersten Sound das "Bump", danach nicht mehr; erst wenn ich eine kurze Pause mache und dann wieder versuche.

Ich kann gerne mehr infos geben, ich weiß nur nicht, wo ich ansetzen soll ...

/edit: Das hier klingt ähnlich: https://bugzilla.redhat.com/show_bug.cgi?id=1525104

Benutzeravatar
smutbert
Beiträge: 6809
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Bump vor abspielen von sounds

Beitrag von smutbert » 11.09.2019 11:36:05

Wie bei dem verlinkten Bugreport hätte ich auch als erstes den Stromsparmodus der Soundkarte bzw. des Onboardsounds in Verdacht. Um was für eine Hardware dreht es sich denn:

Code: Alles auswählen

# lsmod | grep "^snd"
Wenn die Hardware bekannt ist, könnten wir nach Moduloptionen suchen, die den Stromsparmodus deaktivieren.

Ohne Wissen um die Hardware könntest du nur versuchen ob es hilft pulseaudio das Freigeben der Audiogeräte abzugewöhnen. Dazu müsstest du in der »/etc/pulse/default.pa« relativ weit am Ende die Zeile

Code: Alles auswählen

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle
entfernen oder auskommentieren und Pulseaudio neu starten

Code: Alles auswählen

$ pulseaudio -k

iwconfig
Beiträge: 103
Registriert: 17.08.2008 13:10:04

Re: Bump vor abspielen von sounds

Beitrag von iwconfig » 11.09.2019 14:57:45

Danke!

Erstmal zur Hardware:

lspci

Code: Alles auswählen

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
	Subsystem: Hewlett-Packard Company 100 Series/C230 Series Chipset Family HD Audio Controller
	Flags: bus master, fast devsel, latency 64, IRQ 125
	Memory at e1044000 (64-bit, non-prefetchable) [size=16K]
	Memory at e1030000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [50] Power Management version 3
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
lsmod

Code: Alles auswählen

snd_hda_codec_hdmi     57344  1
snd_hda_codec_realtek   122880  1
snd_hda_codec_generic    86016  1 snd_hda_codec_realtek
snd_hda_intel          45056  4
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           94208  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               114688  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              36864  1 snd_pcm
snd                    94208  16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
Zu pulseaudio melde ich mich noch.

/edit: Der pulseaudio-Hinweis hat das Problem behoben. Vielen Dank für den Hinweis! Kann ich das einfach so lassen oder sollte ich nach einer besseren Lösung suchen?

Benutzeravatar
smutbert
Beiträge: 6809
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Bump vor abspielen von sounds

Beitrag von smutbert » 11.09.2019 15:27:18

Du kannst es natürlich so lassen.
Der einzige Nachteil gegenüber der Lösung mit der Moduloption ist, dass der nun bei dir stillgelegte idle-timeout von Pulseaudio dafür sorgt, dass Alsa-Programme, nach dem idle-timeout an Pulseaudio vorbei direkt über Alsa auf die Audiohardware zugreifen können. Wenn du darauf Wert legtest, wüsstest du es aber :wink:


Das mit den Moduloptionen wäre bei dir wohl die Option power_save von snd_hda_intel. Du könntest

Code: Alles auswählen

options snd_hda_intel power_save=0
in einer .conf-Datei in »/etc/modprobe.d« speichern und hinterher sicherheitshalber

Code: Alles auswählen

# update-initramfs -u
aufrufen, damit die Option nötigenfalls auch in der initrd landet. Damit wäre die Änderung an Pulseaudio wahrscheinlich überflüssig.


Zu etwas mehr Stromverbrauch führen beide Lösungen, aber das geht wohl nicht anders. Theoretisch könnte auch ein Update auf den Kernel aus den backports das Ploppen beseitigen ohne dass du die Stromsparmodi des Onboardsounds lahmlegst, aber das halte ich für unwahrscheinlich.

iwconfig
Beiträge: 103
Registriert: 17.08.2008 13:10:04

Re: Bump vor abspielen von sounds

Beitrag von iwconfig » 12.09.2019 09:55:16

Okay, danke -- dann lasse ich es bis auf weiteres so ... :)

Antworten