kein sound ab kernel 2.6.24

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
Benutzeravatar
fitheach
Beiträge: 551
Registriert: 22.11.2006 15:17:32
Wohnort: Bonn

kein sound ab kernel 2.6.24

Beitrag von fitheach » 15.07.2008 09:03:20

Hallo zusammen,

ich habe folgendes Problem, mit meinem alten Kernel 2.6.22-3 habe ich ohne Probleme Sound, aber wenn ich eine neuere Version nehme, fehlt dieser. Kmix, alsamixer können nicht starten, alsaconf bricht mit der Fehlermeldung "not such device" ab.

Ich hab das Forum hier nach möglichen Lösungen abgegrast, aber bin gerade etwas ratlos, wo und wie ich ansetzen soll...

VG
Fith.

Benutzeravatar
habakug
Moderator
Beiträge: 4179
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: kein sound ab kernel 2.6.24

Beitrag von habakug » 15.07.2008 11:59:07

Hallo!

Es würde helfen wenn du hier die von dir eingesetzte Sound-Hardware veröffentlichen würdest.
Hast du schon versucht dir ein zum Kernel passendes alsa zu kompilieren?

Gruß, habakug
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

Benutzeravatar
fitheach
Beiträge: 551
Registriert: 22.11.2006 15:17:32
Wohnort: Bonn

Re: kein sound ab kernel 2.6.24

Beitrag von fitheach » 15.07.2008 13:34:50

hallo habakug,

lspci gibt

Code: Alles auswählen

00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30 [CrystalClear                      SoundFusion Audio Accelerator] (rev 01)
aus.

Es handelt sich um ein T22 Laptop

Ich hab noch nicht versucht, ein passendes alsa zu kompilieren. Das ist der Standart-Debian-Kernel, daher dachte ich, es wäre nicht nötig.

Wie gesagt, unter der alten Kernelversion läuft alles problemlos!

Benutzeravatar
habakug
Moderator
Beiträge: 4179
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: kein sound ab kernel 2.6.24

Beitrag von habakug » 15.07.2008 13:59:36

Hallo!

Da fehlt wohl das Modul [1] (snd-cs46xx). Also doch alsa bauen...

Gruß, habakug

[1] http://lists.debian.org/debian-kernel/2 ... 00130.html
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

pluvo

Re: kein sound ab kernel 2.6.24

Beitrag von pluvo » 15.07.2008 15:59:10

Hallo fitheach,

ich habe es nicht überprüft, aber hilft vielleicht der 2.6.25 Kernel? Der ist nun in Lenny (testing) angekommen. (Außerdem ist der auch mit den etch-backports verfügbar.)

mfg pluvo :)

Benutzeravatar
habakug
Moderator
Beiträge: 4179
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: kein sound ab kernel 2.6.24

Beitrag von habakug » 15.07.2008 16:11:34

Hallo!

Ich glaube nicht. Das ist ein Lizenzproblem [1]:

Code: Alles auswählen

It has been found that CS46xx driver carries a firmware blob that does not have
license, what for our concerns turns it undistributable.
Gruß, habakug

[1] http://bugzilla.kernel.org/show_bug.cgi?id=10750
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

Benutzeravatar
fitheach
Beiträge: 551
Registriert: 22.11.2006 15:17:32
Wohnort: Bonn

Re: kein sound ab kernel 2.6.24

Beitrag von fitheach » 15.07.2008 20:16:45

:? so ein Mist, aber ich denke Habakug hat recht... denn der neue Kernel hatte das gleiche Problem...

aber *wie* bitte compiliere ich alsa, dass die module enthalten sind? Ich denke, die sind aus dem Kernel rausgeflogen?

VG
Fith.

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 22040
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: kein sound ab kernel 2.6.24

Beitrag von KBDCALLS » 15.07.2008 22:35:42

Ich habe mir mal die Debiansourcen 2.6.25 und 2.6.25.11 von Kernel.org vorgeknöpft. Debian hat zwar noch das Verzeichnis, aber das Modul läßt sich nicht hiermit kompilieren. Während es mit dem Kernel von Kernel.org anstandslos ginge. Da läuft wohl wieder einer der Debian Kernelmaintainer Amok.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Benutzeravatar
fitheach
Beiträge: 551
Registriert: 22.11.2006 15:17:32
Wohnort: Bonn

Re: kein sound ab kernel 2.6.24

Beitrag von fitheach » 16.07.2008 12:46:43

KBDCALLS hat geschrieben:Während es mit dem Kernel von Kernel.org anstandslos ginge. Da läuft wohl wieder einer der Debian Kernelmaintainer Amok.
Heißt das jetzt für mich, dass ich

- entweder so lange bei dem alten Kernel bleiben muss, bis sich die Debian Kernel-Maintainer erbarmen und die entfernten Module selber neu schreiben,

- oder keinen "original" Debiankernel einsetze?

Unabhängig von der Frage, ob man nicht die Module so lange im Kernel hätte lassen können, BIS man diese durch eigenen Code ersetzt hat, gibt es noch eine "Frickelvariante"???

VG Fith.

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 22040
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: kein sound ab kernel 2.6.24

Beitrag von KBDCALLS » 16.07.2008 13:27:05

Der bequemste Weg dürfte sein . Das Paket alsa-source herunterzuladen/installieren und mit

Code: Alles auswählen

make-kpkg
ein Deb zu schnüren . Vorher aber die alsamodule aus dem Kernel entfernen.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Benutzeravatar
fitheach
Beiträge: 551
Registriert: 22.11.2006 15:17:32
Wohnort: Bonn

Re: kein sound ab kernel 2.6.24

Beitrag von fitheach » 16.07.2008 14:41:16

Vielen Dank... nun weiß ich, in welche Richtung ich arbeiten muss.

ich habe bisher nur den Kernel selber kompiliert (was ja im www ausgesprochen gut dokumentiert ist)... grds. sollte das das Gleiche sein, aber mal sehen, worüber ich in meiner Unwissenheit stolpern werde...

VG
Fith.

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 22040
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: kein sound ab kernel 2.6.24

Beitrag von KBDCALLS » 18.07.2008 21:57:01

Falls es funktioniert oder auch nicht, teile uns das bitte mit.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Benutzeravatar
knittels
Beiträge: 241
Registriert: 10.04.2004 23:25:47
Kontaktdaten:

Re: kein sound ab kernel 2.6.24

Beitrag von knittels » 04.08.2008 21:39:01

Hallo,

ich hatte das selbe Problem auf meinem Laptop mit gleichem Soundchip. Ich habe mit den Debianquellen und make-kpkg nach Anleitung im Wiki einen neuen Kernel gebaut. Natürlich vorher das Modul in der Config aktivieren.
Im Standard-Debiankernel ist das Modul lediglich nicht mitkompiliert.

Gruß, Knittels

stockter
Beiträge: 2
Registriert: 07.08.2008 19:33:58

Re: kein sound ab kernel 2.6.24

Beitrag von stockter » 07.08.2008 19:41:23

Der Fehler wird unter http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464191 beschrieben. Der Kernel muss nicht rekompiliert werden.

wget ftp://ftp.alsa-project.org/pub/firmware ... 17.tar.bz2

tar xjvf alsa-firmware-1.0.17.tar.bz2

cd alsa-firmware-1.0.17

./configure && make && make install

Mit rmmod das entsprechende Modul entladen und mit mod neu laden.

Antworten