Xoscope mit Stretch

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
peter1969
Beiträge: 419
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Xoscope mit Stretch

Beitrag von peter1969 » 20.12.2017 20:28:33

Hallo, weiss jemand, wie man Xoscope auf Stretch zum Laufen bringt? Ich hab alles probiert, jedoch ohne Erfolg.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Benutzeravatar
niemand
Beiträge: 11532
Registriert: 18.07.2004 16:43:29

Re: Xoscope mit Stretch

Beitrag von niemand » 20.12.2017 20:40:52

Ich weiß nicht mal, was bei dir nicht funktioniert. Vielleicht möchtest du das verraten?
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

peter1969
Beiträge: 419
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Xoscope mit Stretch

Beitrag von peter1969 » 20.12.2017 21:56:11

Ich installiere und öffne Xoscope. Auf dem weißen Schirm in der Mitte ist nichts zu sehen. Es rührt sich nichts.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Benutzeravatar
smutbert
Beiträge: 6324
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Xoscope mit Stretch

Beitrag von smutbert » 20.12.2017 22:01:03

Wenn ich raten darf würde ich sagen, dass es daran liegt, dass xoscop meines Wissens lediglich das oss-Soundsystem unterstützt und weder Alsa noch Pulseaudio. Die Lösung könnte dementsprechend, je nachdem ob Pulseaudio zum Einsatz kommt oder nicht, im Starten von xoscope mit

Code: Alles auswählen

$ padsp xoscope
oder bei installiertem Debianalsa-oss

Code: Alles auswählen

$ aoss xoscope
liegen.

rendegast
Beiträge: 14844
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Xoscope mit Stretch

Beitrag von rendegast » 20.12.2017 22:02:59

Unvollständiges dist-upgrade?

Code: Alles auswählen

apt-cache policy | grep -v Translat

dpkg -l  |  egrep -v "^ii"
Fehler im X-System?
/var/log/Xorg.#.log ?
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

peter1969
Beiträge: 419
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Xoscope mit Stretch

Beitrag von peter1969 » 20.12.2017 22:20:14

padsp xoscope und aoss xoscope haben leider nichts gebracht (alsa-oss ist installiert). Und das System ist mit Synaptic voll aktualisiert, keine defekten Pakete. Und im Xoscope Fenster steht übrigens " No source ". Eigentlich sollte da "Soundcard" stehen. Bloss wie bekomme ich das hin?
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Benutzeravatar
smutbert
Beiträge: 6324
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Xoscope mit Stretch

Beitrag von smutbert » 20.12.2017 22:46:20

entweder habe ich das falsch in Erinnerung gehabt oder da hat sich etwas geändert seitdem ich xoscope ausprobiert habe. Jedenfalls erweckt xoscope sehr wohl den Eindruck alsa zu unterstützen, aber auch die Angabe eines Alsageräts hat bei mir nichts geholfen.
Eine andere Lösung, die ich im Netz gefunden habe ist die Installation von Debianpulseaudio-esound-compat (mit darauffolgendem Neustart von pulseaudio) und hat auch nichts bewirkt.

Momentan sind mir einmal die Ideen ausgegangen.

rendegast
Beiträge: 14844
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Xoscope mit Stretch

Beitrag von rendegast » 20.12.2017 22:50:57

peter1969 hat geschrieben: Und im Xoscope Fenster steht übrigens " No source ".
Nicht noch Channel 1-8 und ein quadratisches Oszilloskop-Display "100ys/div"?
(Nicht ganz dem screenshot https://packages.debian.org/stretch/xoscope entsprechend)


Ich habe noch

Code: Alles auswählen

modprobe -v comedi  comedi_num_legacy_minors=8
(die Option, da ohne entsprechendes Gerät keine devices angelegt werden)

und
usermod -a -G iocard benutzer
In xoscope kommt nach Verbindung mit Device>COMEDI dann natürlich "/dev/comedi0 Kein passendes Gerät gefunden".




Installiert sind alsa-oss und oss-compat.
Geladen ist snd_pcm_oss.
Hat das Problem wirklich was mit den Sound-Modulen zu tun?
Beim 'strace -e trace=file' zeigen sich lediglich /dev/urandom und /dev/comedi0.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

peter1969
Beiträge: 419
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Xoscope mit Stretch

Beitrag von peter1969 » 20.12.2017 23:09:58

Nicht noch Channel 1-8 und ein quadratisches Oszilloskop-Display "100ys/div"?
Doch, das steht auch noch im Fenster. pulseaudio-esound-compat hatte ich auch schon erfolglos probiert.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

mcmuffel
Beiträge: 1
Registriert: 31.12.2017 06:18:05

Re: Xoscope mit Stretch

Beitrag von mcmuffel » 31.12.2017 06:31:18

Ich hatte gestern auch dieses Problem. Wahrscheinlich haben es alle User, denn es scheint einfach keine ALSA-Unterstützung in das Programm einkompiliert worden zu sein. Also habe ich mir von http://xoscope.sourceforge.net den Quellcode heruntergeladen (immer noch Version 2.2) und Xoscope selber kompiliert. Darauf geachtet, dass ich alle im README-File geforderten Libraries in der "-dev"-Version installiert hatte und zuletzt auch zur ALSA-Unterstützung libasound2-dev. Das kompilierte Programm lässt sich nutzen und wählt sogar (bei mir) gleich beim Starten den richtigen Soundkarteneingang aus.
Wer auch immer Xoscope für Debian pflegt, hat wohl beim Kompilieren einen Fehler gemacht und es nicht bemerkt.

Anleitung (als normaler User)
./configure
make
./xoscope

Wenn configure meckert, muss man fehlende "-dev"-Libraries nachinstallieren.

peter1969
Beiträge: 419
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Xoscope mit Stretch

Beitrag von peter1969 » 31.12.2017 21:06:27

Danke für den Tipp. Bei mir gehts jetzt auch. Hab allerdings das Quellpaket aus den Debian-eigenen Quellen verwendet und ein .deb-Paket gebaut. :THX:

Hier war das ganz gut beschrieben: https://gambaru.de/blog/2011/06/11/wie- ... llen-baut/

Dem Pfleger des Paketes habe ich das Problem übrigens gemailt.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Antworten