[gelöst] trotz systemweitem "mute" gibt thunar noch Töne von sich

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
snowy
Beiträge: 62
Registriert: 12.12.2017 22:32:52

[gelöst] trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von snowy » 06.02.2018 23:06:53

Obwohl der Ton über PulseAudio auf "lautlos" (mute) gestellt wurde und das Icon dies auch signalisiert
gibt Thunar immer noch Geräusche von sich, wenn man ein Datei löscht.
Wie kann das sein?
ich dachte diese Mute-Option gilt systemweit. Wie kann ein Programm trotzdem noch Töne erzeugen?

Gehe ich über die Anwendung "Lautstärkeregler", dann kann ich dort auch die Systemklänge komplett auf Null stellen und/oder das Icon für stumm aktivieren. Trotzdem gibt Thunar beim Löschen immer noch ein Ton von sich :evil:

Das Problem tritt auf zwei Systemen auf, beide Debian 9

Wo ist eigentlich hinterlegt, welcher Sound für welche Systemaktion ertönen soll? Dort könnte ich ggfs. auch den Ton einfach löschen oder mit einem "leeren Sound" belegen. Ich will keinerlei Systemklänge.
Zuletzt geändert von snowy am 07.02.2018 22:54:08, insgesamt 1-mal geändert.

Benutzeravatar
smutbert
Beiträge: 6235
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von smutbert » 06.02.2018 23:20:24

Vermutlich könntest du einfach Debiansound-theme-freedesktop deinstallieren oder sicherstellen, dass weder Debianlibcanberra-pulse noch Debianlibcanberra-gstreamer installiert ist. (Ich hoffe, dass auch thunar diese Bibliotheken zur Ausgabe der "Systemklänge".)

Außerdem ist die Lautstärkeregelungslogik zumindest gewöhnungsbedürftig. Damit es etwas übersichtlicher wird, könntest du in »/etc/pulse/daemon.conf«

Code: Alles auswählen

flat-volumes = no
setzen.

Der dritte Ansatzpunkt, der mir einfällt ist eine dummy-Soundkarte zu erstellen und die Systemklänge darüber wiedergeben zu lassen - allerdings finde ich auf Anhieb keine Möglichkeit das einzustellen...

snowy
Beiträge: 62
Registriert: 12.12.2017 22:32:52

Re: trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von snowy » 06.02.2018 23:34:09

Danke für die schnelle Antwort, aber Lösungen klappen nicht

a) sound-theme-freedesktop ist gar nicht installiert
b) libcanberra-pulse schon, aber Synaptic will mir zig Anwendungen mit löschen, die das Paket als Abhängigkeit haben 8O

ist das eine Besonderheit von Debian ?
Ubuntu 14.04 hat auf dem gleichen Rechner das Problem nicht, da ist mute auch wirklich systemweit mute :oops:

Benutzeravatar
smutbert
Beiträge: 6235
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von smutbert » 06.02.2018 23:59:34

Vermutlich ist das eher ein Feature, das dich auch in aktuellen Ubuntuversionen erwarten würde :wink:

Ich habe unter Gnome auch recht hartnäckige Systemsounds, aber ich weiß wie ich sie deinstallieren könnte. Bei mir ist es zum Beispiel kein Problem ibcanberra-pulse zu deinstallieren. Deswegen würde mich die Ausgabe von

Code: Alles auswählen

# apt -s purge libcanberra-pulse
interessieren, um zu sehen was bei dir da deinstalliert würde.
Ob das überhaupt zu etwas führt, wenn sound-theme-freedesktop gar nicht installiert ist, kann ich allerdings nicht sagen.

Findest du vielleicht den nervigen Ton als Audiodatei irgendwo unter »/usr/share/sounds«?

Etwas habe ich im Netz aber noch gefunden: In den Einstellungen unter Erscheinungsbild gibt es wohl einen Eintrag, der so ähnlich wie "Ereignistöne" heißen soll (englisch: Settings Manager > Appearance > Settings > Event sounds).
Du kannst auch den xfce4-settings-editor starten und dir dort unter xsettings die Werte von
- /Net/EnableEventSounds
- /Net/EnableInputFeedbackSounds
- /Net/EnableEventSounds
ansehen.

snowy
Beiträge: 62
Registriert: 12.12.2017 22:32:52

Re: trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von snowy » 07.02.2018 00:20:03

Interessant, hätte den Unterschied von apt zu synaptic nicht erwartet. 8O
apt beschwert sich überhaupt nicht, also habe ich libcanberra-pulse deinstalliert --> keine Änderung

unter /usr/share/sounds sind fast keine Dateien und schon gar nicht der merkwürdige Sound, den Thunar beim Löschen abspielt

tja, und was soll ich sagen
die Ereignistöne unter "Erscheinungsbild" waren deaktiviert
und die /Net-Einstellung waren auch alle auf false
dort habe ich mal auch das SoundTheme von default auf ein leeren String gesetzt --> auch keine Änderung

NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von NAB » 07.02.2018 01:07:12

Hier (Debian 9) läuft grad KDE und nebenbei ist ein XFCE installiert. Ich hab mal Thunar gestartet und kann ihm absolut keine Töne entlocken (find ich auch ganz gut so). "System Sounds" ist auf 100% und Thunar wird mir bei PulseAudio auch nicht als eigene Tonquelle angezeigt.

Fazit: das wird wohl ein XFCE-internes Problem sein.

Wenn ich mir dann mal die XFCE-Pakete so angucke ... "xfce4" besteht darauf, "xfce4-pulseaudio-plugin" zu installieren. Wenn ich "xfce4-pulseaudio-plugin" entferne, muss aber kein einziges XFCE-Programm dran glauben, nur das Paket "xfce4". Und das ist leer. Ich vermute, das wäre die Holzhammermethode.
snowy hat geschrieben: ↑ zum Beitrag ↑
06.02.2018 23:06:53
Trotzdem gibt Thunar beim Löschen immer noch ein Ton von sich :evil:
Blöde Frage, aber ... kommt das Geräusch aus den Lautsprechern? Oder kann das der PC-Beeper im Gehäuse sein?
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

snowy
Beiträge: 62
Registriert: 12.12.2017 22:32:52

Re: trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von snowy » 07.02.2018 22:25:27

Mein größtes Problem, die ständigen Sounds beim Löschen von Dateien, scheint ein Thunar-Feature zu sein.
Andere Dateimanager, wie z.b. nemo, halten sich an den systemweiten mute
Auf den ersten Blick scheint nemo dem Thunar ebenbürtig, also ein Alternative ohne mein Problem :)

Andererseits ist es scheinbar nicht nur Thunar, der sich nicht an das systemweite Mute hält, so gibt es auch den gleichen Sound, wenn in einer Eingabe-Maske die Backspace-Taste an den linken Rand des Eingabe-Feldes stößt.
Aber das kommt nicht so häufig vor wie das Löschen von Dateien :wink:

NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von NAB » 07.02.2018 22:39:56

Das dürfte der System Beep oder System Bell sein.

https://unix.stackexchange.com/question ... is-pressed
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

snowy
Beiträge: 62
Registriert: 12.12.2017 22:32:52

[gelöst] trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von snowy » 07.02.2018 22:53:31

:THX:
Danke :hail:

So einfach ist die Lösung, wenn man weiß wie :lol:
und wonach man "richtig" suchen muß. :facepalm:

Trotz der Lösung finde ich es schon eigenartig, daß dieser "beep" sich nicht an das Mute hält
aber egal, jetzt ist es endlich ruhig

NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: [gelöst] trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von NAB » 07.02.2018 23:13:31

Du könntest noch verraten, welcher der Lösungsvorschläge bei dir denn nun konkret geklappt hat. Dann hat der Nächste auch was davon :)
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

snowy
Beiträge: 62
Registriert: 12.12.2017 22:32:52

Re: [gelöst] trotz systemweitem "mute" gibt thunar noch Töne von sich

Beitrag von snowy » 07.02.2018 23:17:17

upps, sorry, in meiner Begeisterung habe ich gemeint, dies wäre auch anderen bei dem Link klar :oops:
To disable the bell for all X applications:

Code: Alles auswählen

xset b off 
im Terminal eingegeben und Ruhe war am Lautsprecher :D

Antworten