(mit workaround gelöst) swami (sf editor) öffnet mit speicherzugriffsfehler

Sound, Digitalkameras, TV+Video und Spiele.
NAB
Beiträge: 5502
Registriert: 06.03.2011 16:02:23
Lizenz eigener Beiträge: MIT Lizenz

Re: (mit workaround gelöst) swami (sf editor) öffnet mit speicherzugriffsfehler

Beitrag von NAB » 10.02.2018 21:37:22

Code: Alles auswählen

mv /usr/lib/swami/fftune_gui.so /root/
Startet es dann?
Rückgängig mit:

Code: Alles auswählen

mv /root/fftune_gui.so /usr/lib/swami/
Wobei ich nicht sehe, wie dir das weiterhilft, außer für den Bugreport.

Das einzige richtige Plugin da scheint übrigens /usr/lib/swami/fluidsynth_plugin.so zu sein, aber das startet ja angeblich auch mit -p. Oder startet da /usr/lib/swami/fluidsynth_gui.so?
*ahnungslos guck*
Never change a broken system. It could be worse afterwards.

"No computer system can be absolutely secure." Intel Document Number: 336983-001

rendegast
Beiträge: 14844
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: (mit workaround gelöst) swami (sf editor) öffnet mit speicherzugriffsfehler

Beitrag von rendegast » 11.02.2018 09:24:09

segfault at 1708d04 ip 00007f96c8682d64 sp 00007ffc6f135878 error 4 in libgobject-2.0.so.0.5400.3[7f96c864e000+52000]
libgobject-2.0.so.0.5400.3 ist neuer als debian:
libgobject-2.0.so.0.5200.3 debian/sid
libgobject-2.0.so.0.5304.0 debian/experimental

--------------------------------------------------------------
EDIT obiges stimmt so nicht, die Dateilisten auf packages.debian.org sind da nicht aktuell. Entpackte Pakete:
$ find | sort | grep gobject
./libglib2.0-0_2.54.3-2_amd64/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.5400.3 debian/sid
./libglib2.0-0_2.55.1-1_amd64/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.5501.0 debian/experimental
--------------------------------------------------------------
Die version
swami_2.0.0+svn389-3_amd64.deb libswami0_2.0.0+svn389-3_amd64.deb
stürzt beim start nicht ab.
ist einheitlich <jessie> (Debianswami)
Zuletzt geändert von rendegast am 11.02.2018 13:57:10, insgesamt 2-mal geändert.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

michaa7
Beiträge: 3007
Registriert: 12.12.2004 00:46:49
Lizenz eigener Beiträge: MIT Lizenz

Re: (mit workaround gelöst) swami (sf editor) öffnet mit speicherzugriffsfehler

Beitrag von michaa7 » 11.02.2018 11:13:14

Danke.

In soweit erweißt sich niemands einwand vieleicht als richtig, ich bin jedoch noch am untersuchen. Dazu hier die frage: Wie finde ich zu einer datei (libgobject-2.0.) das archiv, welches sie installiert hat.

Und falls das in diesem fall libglib2.0-0 sein sollte (welches hier aus debian unstable stammt), wie komme ich hier weiter:
# dpkg -L libglib2.0-0
dpkg-query: Fehler: --listfiles benötigt einen gültigen Paketnamen. »libglib2.0-0« ist kein solcher; mehrdeutiger Paketname »libglib2.0-0« mit mehr als einer installierten Instanz
Und wenn nicht, wie finde ich das entsprechende paket?
gruß

michaa7

-------------------------------
Menschen ändern gelegentlich ihre Ansichten, aber nur selten ihre Motive. (Oskar Negt)
Forumsumfrage: Welche debianartige Distribution / SubDistri nutzt du?
Und wenn ihr textet das Abstimmen im Formular nicht vergessen ...

rendegast
Beiträge: 14844
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: (mit workaround gelöst) swami (sf editor) öffnet mit speicherzugriffsfehler

Beitrag von rendegast » 11.02.2018 12:27:13

michaa7 hat geschrieben: # dpkg -L libglib2.0-0
dpkg-query: Fehler: --listfiles benötigt einen gültigen Paketnamen. »libglib2.0-0« ist kein solcher; mehrdeutiger Paketname »libglib2.0-0« mit mehr als einer installierten Instanz

Code: Alles auswählen

dpkg -L libglib2.0-0:amd64
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

michaa7
Beiträge: 3007
Registriert: 12.12.2004 00:46:49
Lizenz eigener Beiträge: MIT Lizenz

Re: (mit workaround gelöst) swami (sf editor) öffnet mit speicherzugriffsfehler

Beitrag von michaa7 » 11.02.2018 12:45:49

rendegast hat geschrieben: ↑ zum Beitrag ↑
11.02.2018 09:24:09
segfault at 1708d04 ip 00007f96c8682d64 sp 00007ffc6f135878 error 4 in libgobject-2.0.so.0.5400.3[7f96c864e000+52000]
libgobject-2.0.so.0.5400.3 ist neuer als debian:
...
Entweder ist obige aussage falsch oder ich verstehe sie nicht:
# dpkg -L libglib2.0-0:amd64
/.
/lib
/lib/x86_64-linux-gnu
/lib/x86_64-linux-gnu/libglib-2.0.so.0.5400.3
/usr
/usr/lib
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/gio
/usr/lib/x86_64-linux-gnu/gio/modules
/usr/lib/x86_64-linux-gnu/glib-2.0
/usr/lib/x86_64-linux-gnu/glib-2.0/gio-querymodules
/usr/lib/x86_64-linux-gnu/glib-2.0/glib-compile-schemas
/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.5400.3
/usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0.5400.3
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.5400.3
...


# apt policy libglib2.0-0
libglib2.0-0:
Installiert: 2.54.3-2
Installationskandidat: 2.54.3-2
Versionstabelle:
2.55.1-1 1
1 http://http.debian.net/debian experimental/main amd64 Packages
*** 2.54.3-2 500
500 http://httpredir.debian.org/debian unstable/main amd64 Packages
500 http://http.debian.net/debian testing/main amd64 Packages
100 /var/lib/dpkg/status
2.50.3-2 500
500 http://http.debian.net/debian stretch/main amd64 Packages
root@neutower:~# apt policy libglib2.0-0:amd64
libglib2.0-0:
Installiert: 2.54.3-2
Installationskandidat: 2.54.3-2
Versionstabelle:
2.55.1-1 1
1 http://http.debian.net/debian experimental/main amd64 Packages
*** 2.54.3-2 500
500 http://httpredir.debian.org/debian unstable/main amd64 Packages

500 http://http.debian.net/debian testing/main amd64 Packages
100 /var/lib/dpkg/status
2.50.3-2 500
500 http://http.debian.net/debian stretch/main amd64 Packages
Für mich schaut das nach nativem debian unstable aus.
gruß

michaa7

-------------------------------
Menschen ändern gelegentlich ihre Ansichten, aber nur selten ihre Motive. (Oskar Negt)
Forumsumfrage: Welche debianartige Distribution / SubDistri nutzt du?
Und wenn ihr textet das Abstimmen im Formular nicht vergessen ...

rendegast
Beiträge: 14844
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: (mit workaround gelöst) swami (sf editor) öffnet mit speicherzugriffsfehler

Beitrag von rendegast » 11.02.2018 13:53:36

michaa7 hat geschrieben:
libgobject-2.0.so.0.5400.3 ist neuer als debian:
...
Entweder ist obige aussage falsch oder ich verstehe sie nicht:
Habe oben schon korrigiert,
die Dateilisten auf packages.debian.org sind da nicht aktuell. Entpackte Pakete:
$ find | sort | grep gobject
./libglib2.0-0_2.54.3-2_amd64/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.5400.3 debian/sid
./libglib2.0-0_2.55.1-1_amd64/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.5501.0 debian/experimental
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Antworten