HP255G7 kurze Akkulaufzeit

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
peter1969
Beiträge: 543
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

HP255G7 kurze Akkulaufzeit

Beitrag von peter1969 » 12.02.2020 20:30:58

Hallole, eigenntlich bin ich mit Buster aud dem HP255G7 soweit zufrieden. Nur eins stört: nach gefühlten 2 Stunden ist der Akku auf 10 % runter und das trotz TLP. Ist das normal? Kann man den Stromverbrauch nicht irgendwie deutlich senken?

tlp-stat ergibt

Code: Alles auswählen

peter@HP255G7:~$ sudo tlp-stat
--- TLP 1.2.2 --------------------------------------------

+++ Configured Settings: /etc/default/tlp
TLP_ENABLE=1
TLP_DEFAULT_MODE=AC
TLP_PERSISTENT_DEFAULT=0
DISK_IDLE_SECS_ON_AC=0
DISK_IDLE_SECS_ON_BAT=2
MAX_LOST_WORK_SECS_ON_AC=15
MAX_LOST_WORK_SECS_ON_BAT=60
CPU_HWP_ON_AC=balance_performance
CPU_HWP_ON_BAT=balance_power
SCHED_POWERSAVE_ON_AC=0
SCHED_POWERSAVE_ON_BAT=1
NMI_WATCHDOG=0
ENERGY_PERF_POLICY_ON_AC=performance
ENERGY_PERF_POLICY_ON_BAT=power
DISK_DEVICES="nvme0n1 sda"
DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="128 128"
SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
SATA_LINKPWR_ON_BAT="med_power_with_dipm min_power"
AHCI_RUNTIME_PM_TIMEOUT=15
RADEON_POWER_PROFILE_ON_AC=default
RADEON_POWER_PROFILE_ON_BAT=default
RADEON_DPM_STATE_ON_AC=performance
RADEON_DPM_STATE_ON_BAT=battery
RADEON_DPM_PERF_LEVEL_ON_AC=auto
RADEON_DPM_PERF_LEVEL_ON_BAT=auto
WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=on
WOL_DISABLE=Y
SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=1
SOUND_POWER_SAVE_CONTROLLER=Y
BAY_POWEROFF_ON_AC=0
BAY_POWEROFF_ON_BAT=1
BAY_DEVICE="sr0"
RUNTIME_PM_ON_AC=on
RUNTIME_PM_ON_BAT=auto
USB_AUTOSUSPEND=1
USB_BLACKLIST_BTUSB=0
USB_BLACKLIST_PHONE=0
USB_BLACKLIST_PRINTER=1
USB_BLACKLIST_WWAN=0
RESTORE_DEVICE_STATE_ON_STARTUP=0
NATACPI_ENABLE=1
TPACPI_ENABLE=1
TPSMAPI_ENABLE=1

+++ System Info
System         = HP Type1ProductConfigId HP 255 G7 Notebook PC
BIOS           = F.20
Release        = Debian GNU/Linux 10 (buster)
Kernel         = 5.4.0-0.bpo.2-amd64 #1 SMP Debian 5.4.8-1~bpo10+1 (2020-01-07) x86_64
/proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-5.4.0-0.bpo.2-amd64 root=UUID=9c967c44-0267-4eb5-b864-f3710956763c ro quiet
Init system    = systemd v241 (241)
Boot mode      = UEFI

+++ TLP Status
State          = enabled
RDW state      = enabled
Last run       = 20:17:24,    687 sec(s) ago
Mode           = battery
Power source   = battery

+++ Processor
CPU model      = AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx

/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = ondemand
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = ondemand performance schedutil 
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =  1600000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  2500000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies = 2500000 1700000 1600000 [kHz]

/sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = ondemand
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = ondemand performance schedutil 
/sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =  1600000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  2500000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_frequencies = 2500000 1700000 1600000 [kHz]

/sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = ondemand
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = ondemand performance schedutil 
/sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =  1600000 [kHz]
/sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  2500000 [kHz]
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_frequencies = 2500000 1700000 1600000 [kHz]

/sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = ondemand
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = ondemand performance schedutil 
/sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =  1600000 [kHz]
/sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  2500000 [kHz]
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_frequencies = 2500000 1700000 1600000 [kHz]

/sys/devices/system/cpu/cpufreq/boost                  = 1

x86_energy_perf_policy: unsupported CPU.

/sys/module/workqueue/parameters/power_efficient       = N
/proc/sys/kernel/nmi_watchdog                          = 0

+++ Undervolting
PHC kernel not available.

+++ Temperatures
Fan speed              = (not available)

+++ File System
/proc/sys/vm/laptop_mode               =     2
/proc/sys/vm/dirty_writeback_centisecs =  6000
/proc/sys/vm/dirty_expire_centisecs    =  6000
/proc/sys/vm/dirty_ratio               =    20
/proc/sys/vm/dirty_background_ratio    =    10

+++ Storage Devices
Devices = nvme0n1 sda

/dev/nvme0n1:
  Type      = NVMe
  Model     = SK hynix BC501 HFM256GDJTNG-8310A       
  Firmware  = 80002C00
  Scheduler = [none] mq-deadline (multi queue)

  Runtime PM: control = auto, autosuspend_delay_ms = (not available)

/dev/sda: not present.

+++ AHCI Link Power Management (ALPM)
/sys/class/scsi_host/host0/link_power_management_policy  = med_power_with_dipm

+++ AHCI Host Controller Runtime Power Management
/sys/bus/pci/devices/0000:06:00.0/ata1/power/control = on

+++ Wireless
bluetooth = none (no device)
wifi      = on
wwan      = none (no device)

wlo1(rtl8821ce)               : wifi, connected, power management = on

+++ Audio
/sys/module/snd_hda_intel/parameters/power_save            = 1
/sys/module/snd_hda_intel/parameters/power_save_controller = Y

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = default (using bios preferences)

+++ Runtime Power Management
Device blacklist = (not configured)
Driver blacklist = amdgpu mei_me nouveau nvidia pcieport radeon (default)

/sys/bus/pci/devices/0000:00:00.0/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:00.2/power/control = auto (0x080600, IOMMU, no driver)
/sys/bus/pci/devices/0000:00:01.0/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:01.1/power/control = on   (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:01.2/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:01.3/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:01.5/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:08.0/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:08.1/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:08.2/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:14.0/power/control = auto (0x0c0500, SMBus, piix4_smbus)
/sys/bus/pci/devices/0000:00:14.3/power/control = auto (0x060100, ISA bridge, no driver)
/sys/bus/pci/devices/0000:00:18.0/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:18.1/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:18.2/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:18.3/power/control = auto (0x060000, Host bridge, k10temp)
/sys/bus/pci/devices/0000:00:18.4/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:18.5/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:18.6/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:18.7/power/control = auto (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:02:00.0/power/control = auto (0x020000, Ethernet controller, r8169)
/sys/bus/pci/devices/0000:03:00.0/power/control = auto (0x028000, Network controller, rtl8821ce)
/sys/bus/pci/devices/0000:04:00.0/power/control = auto (0x010802, Non-Volatile memory controller, nvme)
/sys/bus/pci/devices/0000:05:00.0/power/control = on   (0x030000, VGA compatible controller, amdgpu)
/sys/bus/pci/devices/0000:05:00.1/power/control = auto (0x040300, Audio device, snd_hda_intel)
/sys/bus/pci/devices/0000:05:00.2/power/control = auto (0x108000, Encryption controller, no driver)
/sys/bus/pci/devices/0000:05:00.3/power/control = auto (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:05:00.4/power/control = auto (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:05:00.5/power/control = auto (0x048000, Multimedia controller, no driver)
/sys/bus/pci/devices/0000:05:00.6/power/control = auto (0x040300, Audio device, snd_hda_intel)
/sys/bus/pci/devices/0000:06:00.0/power/control = auto (0x010601, SATA controller, ahci)

+++ USB
Autosuspend         = enabled
Device whitelist    = (not configured)
Device blacklist    = (not configured)
Bluetooth blacklist = disabled
Phone blacklist     = disabled
WWAN blacklist      = disabled

Bus 004 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 3.0 root hub (hub)
Bus 003 Device 004 ID 04ca:707d control = auto, autosuspend_delay_ms = 2000 -- Lite-On Technology Corp.  (uvcvideo)
Bus 003 Device 003 ID 05e3:0608 control = auto, autosuspend_delay_ms =    0 -- Genesys Logic, Inc. Hub (hub)
Bus 003 Device 002 ID 174c:1351 control = auto, autosuspend_delay_ms = 2000 -- ASMedia Technology Inc.  (usb-storage)
Bus 003 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 2.0 root hub (hub)
Bus 002 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 3.0 root hub (hub)
Bus 001 Device 002 ID 045e:0084 control = on,   autosuspend_delay_ms = 2000 -- Microsoft Corp. Basic Optical Mouse (usbhid)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 2.0 root hub (hub)

+++ Battery Features: Charge Thresholds and Recalibrate
natacpi    = inactive (no kernel support)
tpacpi-bat = inactive (laptop not supported)
tp-smapi   = inactive (laptop not supported)

+++ Battery Status: BAT1
/sys/class/power_supply/BAT1/manufacturer                   = Hewlett-Packard
/sys/class/power_supply/BAT1/model_name                     = PABAS0241231
/sys/class/power_supply/BAT1/cycle_count                    = (not supported)
/sys/class/power_supply/BAT1/charge_full_design             =   3630 [mAh]
/sys/class/power_supply/BAT1/charge_full                    =   3463 [mAh]
/sys/class/power_supply/BAT1/charge_now                     =   2479 [mAh]
/sys/class/power_supply/BAT1/current_now                    = (not available) 
/sys/class/power_supply/BAT1/status                         = Discharging


Charge                                                      =   71.6 [%]
Capacity                                                    =   95.4 [%]

+++ Recommendations
* Install smartmontools for disk drive health info

Grüße, Peter
Debian 10 Buster (64 bit) mit Xfce auf HP 255 G7 (Ryzen 3 2200U mit Radeon Vega Grafik)

dingsvomdach
Beiträge: 14
Registriert: 06.10.2019 08:27:38

Re: HP255G7 kurze Akkulaufzeit

Beitrag von dingsvomdach » 28.02.2020 21:46:34

Scheint ja relativ "moderne" Hardware zu sein. Probier doch mal den Backports-Kernel (derzeit 5.4.0). Lesestoff: https://backports.debian.org/Instructions/#index2h2

peter1969
Beiträge: 543
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: HP255G7 kurze Akkulaufzeit

Beitrag von peter1969 » 28.02.2020 21:51:15

Den Backports-Kernel 5.4.0 hatte ich schon drauf, der hat nichts gebracht. Auch TLP aus den Backports brachte nichts.
Grüße, Peter
Debian 10 Buster (64 bit) mit Xfce auf HP 255 G7 (Ryzen 3 2200U mit Radeon Vega Grafik)

dingsvomdach
Beiträge: 14
Registriert: 06.10.2019 08:27:38

Re: HP255G7 kurze Akkulaufzeit

Beitrag von dingsvomdach » 28.02.2020 22:20:50

Installiere doch testweise mal Windows 10 (als Testversion, Produktschlüsseleingabe überspringen) plus die entsprechenden Treiber von der Herstellerseite (wenn angeboten). Dann hast du mal einen Vergleich. Eventuell gibt der Akku einfach nicht mehr her.

https://www.microsoft.com/de-de/softwar ... ndows10ISO

Antworten