Ladezeit UEFI

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
Ozelot
Beiträge: 1343
Registriert: 18.11.2007 09:52:58

Ladezeit UEFI

Beitrag von Ozelot » 20.05.2020 04:42:12

Auf meinem Lenovo Thinkpad X1 (5th gen, denke ich) dauert es 30 Sekunden nach dem kleinen Spash Screen beim Einschalten bis Grub gestartet wird. Am Anfang lief das noch ratzfatz durch, wurde dann aber in mehreren Schritten immer länger, immer nachdem ich ein update-grub gemacht habe. Auf der Platte befinden sich 4 Debian-Installationen.

Ein Bios/Efi update (wie nennt man das?) wäre wohl vernünftig, aber ich traue mich nicht so recht, da mir der Rechner momentan absolut nicht absterben darf (und soweit ich weiß kann das passieren, wenn beim Update was schief geht). Wo könnte ich ganz vorsichtig mit der Fehlersuche beginnen?

Benutzeravatar
niemand
Beiträge: 13520
Registriert: 18.07.2004 16:43:29

Re: Ladezeit UEFI

Beitrag von niemand » 20.05.2020 07:13:02

Ozelot hat geschrieben: ↑ zum Beitrag ↑
20.05.2020 04:42:12
Am Anfang lief das noch ratzfatz durch, wurde dann aber in mehreren Schritten immer länger, immer nachdem ich ein update-grub gemacht habe. Auf der Platte befinden sich 4 Debian-Installationen.
Dann würde ich mal auf die EFI-Partition gucken, wie’s dort aussieht. Fehlkonfiguration könnte dafür sorgen, dass einige deiner Installationen wechselseitig am Bootloader rumschrauben, was zu den seltstamsten Ergebnissen führen kann. Ein Firmware-Update ist zwar meist eine gute Idee, wird ein Problem auf Bootloaderseite jedoch nicht beheben können – dafür ist die Firmware nicht zuständig.

Du könntest auch schauen, dass du den Splash-Screen der Firmware loswirst, so dass dort Informationen angezeigt werden. Möglicherweise kann man damit einfacher erkennen, was falsch ist.
non serviam.

Ozelot
Beiträge: 1343
Registriert: 18.11.2007 09:52:58

Re: Ladezeit UEFI

Beitrag von Ozelot » 20.05.2020 17:49:54

Ja, da liegt wahrscheinlich der Hase im Pfeffer.

Jedenfalls sehe ich auf der EFI Partition Relikte einer vorigen Installation, die gar nicht mehr auf der Platte ist. Leider verstehe ich nicht, wie das EFI System funktioniert und wie man es konfguriert (hat jemand einen guten Link dafür?). Viel zu lesen finde ich nicht - die grub.cfg ist sehr kurz; ansonsten gibt es eine Hand voll binäre .efi Dateien. Kann ich die ganze Partition irgendwie sauber neu schreiben lassen?

OrangeJuice
Beiträge: 234
Registriert: 12.06.2017 15:12:40

Re: Ladezeit UEFI

Beitrag von OrangeJuice » 20.05.2020 19:16:08

Wenn du SystemD am laufen hast kannst du damit mal nachschauen, zeigt die in etwa an, was den Start verzögert.

Code: Alles auswählen

su -
systemd-analyze critical-chain
systemd-analyze blame
systemd-analyze blame | head
Die Einträge der Efi-Partition kannst du dir damit anschauen. Überflüssige Einträge unter "/boot/efi/EFI" können mit "rm -rf Name-der-Distribution" entfernt werden.
Einträge die du bei "efibootmgr -v" nicht benötigst, kannst du mit "efibootmgr -b (Startnummer z.B. 0001) -B" entfernen.

Code: Alles auswählen

su -
efibootmgr -v
cd /boot/efi/EFI
ls -la
Um zu schauen, ob irgendwas anderes vorliegt kann das hilfreich sein:

Code: Alles auswählen

dmesg -x -l crit,err,warn
journalctl -p err..alert
Du kannst auch mal zeigen was du in Grub geändert hast. Wenn du "quiet splash" drin hast, kannst du das mal herausnehmen, dann siehst du mehr beim Startvorgang.

Code: Alles auswählen

nano /etc/default/grub
...
GRUB_CMDLINE_LINUX_DEFAULT=""

Antworten