Touchpad funktioniert nicht so, wie es sein sollte

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
dirk11
Beiträge: 2568
Registriert: 02.07.2013 11:47:01

Touchpad funktioniert nicht so, wie es sein sollte

Beitrag von dirk11 » 09.09.2020 18:39:26

Hi Leute,

ich habe eines meiner Debian von einem alten Thinkpad T60p auf ein neues Fujitsi Siemens U904 kopiert. Das funktioniert soweit tadellos, es gab nur unwesentliche Fehlermeldungen.
Danach erst habe ich es von Stretch auf Buster (also von oldstable auf stable) upgegradet. Das hat soweit (wie auf allen anderen Rechnern vorher auch) prima funktioniert, bis auf wenige Kleinigkeiten, für die ich noch keine Ursache, geschweige denn eine Fehlerbehebung gefunden habe, unter anderem diese Fehler hier mit dem Touchpad:

hwinfo:

Code: Alles auswählen

50: PS/2 00.0: 10500 PS/2 Mouse
  [Created at input.249]
  Unique ID: AH6Q.Y_f5kDtfqz2
  Hardware Class: mouse
  Model: "SynPS/2 Synaptics TouchPad"
  Vendor: 0x0002 
  Device: 0x0007 "SynPS/2 Synaptics TouchPad"
  Compatible to: int 0x0210 0x0001
  Device File: /dev/input/mice (/dev/input/mouse1)
  Device Files: /dev/input/mice, /dev/input/mouse1, /dev/input/event8, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/input/by-path/platform-i8042-serio-4-mouse
  Device Number: char 13:63 (char 13:33)
  Driver Info #0:
    Buttons: 1
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown
Ohne Eintrag in der xorg.conf funktioniert das Touchpad überhaupt nicht. Mit dem folgenden Eintrag funktioniert es "so leidlich":

Code: Alles auswählen

Section "InputDevice"
        Identifier      "Buildin Touchpad"
        Option          "CorePointer"
        Option          "SendCoreEvents"        "true"
        Option          "MatchIsTouchpad"       "yes"   # required
        Driver          "synaptics"                     # required
        Option          "TapButton1"            "1"
        Option          "TapButton2"            "2"     # multitouch
        Option          "TapButton3"            "3"     # multitouch
        Option          "VertTwoFingerScroll"   "1"     # multitouch
        Option          "HorizTwoFingerScroll"  "1"     # multitouch
EndSection
Section "ServerFlags"
        Option          "DontZap"       "false"
        Option          "DontZoom"      "false"
EndSection
Section "ServerLayout"
        Identifier      "Default Layout"
        Option          "DefaultServerLayout"
        InputDevice     "Buildin Touchpad"      "CorePointer"
EndSection
So leidlich heißt hier:
Das Touchpad hat unten zwei abgetrennte Bereich, die wohl als Maustastenersatz gedacht sind. Außerdem kann man es richtig drücken. Ein Druck bewirkt überhaupt nichts, die angedeuteten Maustasten auch nicht. Stattdessen muss ich mit dem Zeigefinger tippen:
einmal tippen ist linker Einfachklick, tippen-halten ist Shift-Linke_Maustaste, mit zwei Fingern tippen habe ich vergessen, mit drei Fingern tippen ist rechte Maustaste.

Geht das irgendwie besser? Also z.B. so, daß man unten die angedeuteten Bereiche nutzt?

schwedenmann
Beiträge: 4675
Registriert: 30.12.2004 15:31:07
Wohnort: Wegberg

Re: Touchpad funktioniert nicht so, wie es sein sollte

Beitrag von schwedenmann » 13.09.2020 17:57:53

Hallo

ich würde erstmal googlen, ob das touchpad (also Hersteller und Modell) überhaupt und inwieweit von Xorg unterstützt, bzw. von dessen Treiber für touchpads uneterstützt wird.

mfg
schwedenmann

debianoli
Beiträge: 3819
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: Touchpad funktioniert nicht so, wie es sein sollte

Beitrag von debianoli » 14.09.2020 06:27:52

Ich installiere inzwischen lieber neu anstatt das alte System einfach auf einen anderen Laptop zu klatschen. Dann mit Debianapt-clone die Programme des alten auf den neuen Rechner installieren.

Hat den Vorteil, dass Verbesserungen nicht durch alte Configs verschwinden

dirk11
Beiträge: 2568
Registriert: 02.07.2013 11:47:01

Re: Touchpad funktioniert nicht so, wie es sein sollte

Beitrag von dirk11 » 14.09.2020 10:28:09

Das wird mir in diesem Fall nichts bringen, da es keine "alte" Config gab, wie ich ja erwähnte.

Mal ganz davon abgesehen, das meine Erfahrung eben die ist, daß meine Methode immer noch weniger zeitaufwendig ist, da zumindest keine "merkwürdigen" Zustände auftreten, weil alte Spezial-Settings auf einmal fehlen.

alboran
Beiträge: 61
Registriert: 15.09.2009 14:24:48

Re: Touchpad funktioniert nicht so, wie es sein sollte

Beitrag von alboran » 14.09.2020 21:03:17

Hi,
das gleiche Problem hatte ich gerade mit meinem T540p.
Nachdem ich die Treiber
xserver-org-input-evdev
xserver-org-input-synaptic
xserver-org-input-libinput
xserver-org-input-mouse

installiert hatte flutschte nach einem Neustart alles bestens.
Dafür gabs hier einen Workaround https://www.maketecheasier.com/fix-touc ... ing-linux/

Gruß alboran
ThinkPad T540p mit Debian DebianStableDebianMateDebianFluxbox

dirk11
Beiträge: 2568
Registriert: 02.07.2013 11:47:01

Re: Touchpad funktioniert nicht so, wie es sein sollte

Beitrag von dirk11 » 14.09.2020 21:35:55

Danke, die waren alle schon vorher installiert.
Es geht ja auch nicht darum, dass es nicht funktioniert, sondern darum, daß es eben nicht so funktioniert, wie es vom Hersteller mal vorgesehen war.

Antworten