Broadcom BCM4313 mit Buster

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
peter1969
Beiträge: 593
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Broadcom BCM4313 mit Buster

Beitrag von peter1969 » 27.03.2021 15:36:56

Hallole, ich hab mir ein gebrauchtes Notebook HP Pavilion Dv6 gekauft und Buster installiert. Es funktioniert alles, nur mit dem WLAN-Modul bcm4316 gibt es Probleme:
  • WLAN lässt sich zwar mit der f12-Taste an- und ausschalten, die LED leuchtet jedoch immer orange, egal ob das WLAN an oder ausgeschaltet ist.
  • Es stehen nur Kanal 1 - 11 zur Verfügung. Dies lässt sich auch mit dem Befehl "iw reg set DE" nicht ändern
  • WLAN ist viel zu langsam
Zuletzt geändert von peter1969 am 20.04.2021 10:10:11, insgesamt 4-mal geändert.
Grüße, Peter
Debian 10 Buster mit Xfce auf HP Pavilion dv6

Benutzeravatar
Emess
Beiträge: 3457
Registriert: 07.11.2006 15:02:26
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Im schönen Odenwald
Kontaktdaten:

Re: WLAN LED leuchtet immer orange

Beitrag von Emess » 27.03.2021 20:28:04

Wenn das Wlan geht. Dann hat es ne orange LED. Aber so genau geht das aus deiner Beschreibung nicht hervor
Debian Testing (bleibt es auch)
Debian Buster KDE Plasma 5x Kernel 4.19.0.6-amd64
Notebook HP ZBook 17 G2

http://www.emess62.de

peter1969
Beiträge: 593
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: WLAN LED leuchtet immer orange

Beitrag von peter1969 » 28.03.2021 08:30:38

Richtig wäre es so:

WLAN an = LED leuchtet bläulich-weiß
WLAN aus = LED leuchtet orange

Aber die LED leuchtet immer orange, auch wenn das WLAN an ist.
Zuletzt geändert von peter1969 am 19.04.2021 11:55:37, insgesamt 1-mal geändert.
Grüße, Peter
Debian 10 Buster mit Xfce auf HP Pavilion dv6

pferdefreund
Beiträge: 3706
Registriert: 26.02.2009 14:35:56

Re: WLAN LED leuchtet immer orange

Beitrag von pferdefreund » 28.03.2021 14:57:32

Eventuell Hardware. Mal mit Knoppix oder ähnlichem testen.

peter1969
Beiträge: 593
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: WLAN LED leuchtet immer orange

Beitrag von peter1969 » 28.03.2021 22:11:04

Unter diesem Link ist vermerkt, dass die BCM4313 nicht voll vom Treiber brcmsmac unterstützt wird: https://wireless.wiki.kernel.org/en/use ... /brcm80211. Zitat: "Please note: at least BCM4313 is not fully supported. Some models appears to work (users reported success), but some don't, and there's no indication that this is going to change."

Ich habe daher den Treiber "brcmsmac" durch den proprietären Treiber "wr" ersetzt ( siehe https://wiki.debian.org/wl ). Damit ist die Geschwindigkeit ok und es stehen alle 13 WLAN-Kanäle zur Verfügung. Jetzt gibt es nur noch ein Problem:
  • WLAN lässt sich zwar mit der f12-Taste an- und ausschalten, die LED leuchtet jedoch immer bläulich-weiß, egal ob das WLAN an oder ausgeschaltet ist.
Hat jemand dafür eine Lösung parat?
Zuletzt geändert von peter1969 am 19.04.2021 11:55:56, insgesamt 2-mal geändert.
Grüße, Peter
Debian 10 Buster mit Xfce auf HP Pavilion dv6

Benutzeravatar
smutbert
Moderator
Beiträge: 7785
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: WLAN BCM4313 mit Buster

Beitrag von smutbert » 31.03.2021 23:17:49

Keine Ahnung wie das mit diesen LEDs läuft, aber wenn unter /sys/class/leds gibt es für jede LED, die Debian als solche kennt und steuern kann ein eigenes Verzeichnis.
Zum Beispiel gibt es meistens so etwas wie input0::capslock für die LED der Caps-Lock-Taste auf der Tastatur. In diesen Verzeichnissen gibt es die Datei trigger, mit der man festlegen kann, wie die LED gesteuert wird.

Ich weiß allerdings nicht wie so eine zum WLAN gehörende LED heißen könnte. Du könntest nun eventuell in Frage kommende LEDs einzeln zum Blinken zu brigen um sie zu identifizieren. Zuerst das Laden des Kernelmoduls, mit dem man LEDs blinken lassen kann

Code: Alles auswählen

# modprobe ledtrig-heartbeat
und sagen wir du hättest ein Verzeichnis »/sys/class/leds/phy0-led« gefunden. Dann kannst du mit

Code: Alles auswählen

# echo heartbeat > /sys/class/leds/phy0-led/trigger
die LED zum Blinken bringen. Du kannst dasselbe mit mehreren LEDs nacheinander machen – nach einem Neustart des Systems ist der Spuk mit dem Blinken wieder vorbei.

Findest du so diese LED, dann könnte man die LED auf ähnliche Art vielleicht auch dazu bringen, in Übereinstimmung mit dem Status des WLAN zu leuchten oder nicht leuchten.

Wenn du die LED auf diese Art nicht findest, hilft dir mein Beitrag allerdings gar nichts.

peter1969
Beiträge: 593
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: WLAN BCM4313 mit Buster

Beitrag von peter1969 » 01.04.2021 10:34:59

Hallo, nein, es gibt keinen Eintrag für die WLAN LED. Beim HP-Laptop meiner Frau allerdings auch nicht, und da geht die WLAN LED korrekt.
Grüße, Peter
Debian 10 Buster mit Xfce auf HP Pavilion dv6

fischig
Beiträge: 1440
Registriert: 24.12.2019 12:25:08
Lizenz eigener Beiträge: MIT Lizenz

Re: WLAN BCM4313 mit Buster

Beitrag von fischig » 09.04.2021 20:07:40

Ich habe die WLAN-Karte auf einem Pavilion dm1 auch erst nach der Lektüre deines Links https://wiki.debian.org/wl konfiguriert bekommen. Danke dafür!
modprobe-Kram war hier unnötig, irgendwer oder irgendwas (vermutlich dkms) hat die störenden Module selbsttätig blackgelistet und wl in /etc/modules eingetragen. Eigentlich wollte ich dkms samt Abhängigkeiten wieder runterwerfen, weil ich das auf dieser Maschine fortan nicht zu benötigen glaubte. Aber jetzt wird jeder neue Eigenbaukern wohl dkms (und kernel-headers!) benötigen, um das Modul zu bauen - richtig?

Die LED leuchtet, nun ja, als blau würde ich das nicht bezeichnen, eher weiß, jedenfalls nicht mehr rot. :wink:

peter1969
Beiträge: 593
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: WLAN BCM4313 mit Buster

Beitrag von peter1969 » 09.04.2021 20:38:42

Um ehrlich zu sein, so tief ist mein Wissen über DKMS nicht. Aber ich glaube, dass Du recht hast. DKMS passt meines Wissens nach den Treiber bei geändertem Kernel neu an.
Grüße, Peter
Debian 10 Buster mit Xfce auf HP Pavilion dv6

fischig
Beiträge: 1440
Registriert: 24.12.2019 12:25:08
Lizenz eigener Beiträge: MIT Lizenz

Re: WLAN BCM4313 mit Buster

Beitrag von fischig » 09.04.2021 20:46:10

Naja, das entscheidende für unser WLAN-Schätzchen dürfte das Paket Debianbroadcom-sta-dkms sein. Ohne das wird dkms das Modul wl nicht bauen können. Aber jedesmal neu gebaut werden wird das wohl müssen. Hat jemand bessere Kenntnisse?

Benutzeravatar
towo
Beiträge: 3833
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: WLAN BCM4313 mit Buster

Beitrag von towo » 09.04.2021 22:18:53

Das mudul muss für jeden neu installierten Kernel gebaut werden und dafür sorgt dann halt dkms. Was ist daran nicht zu verstehen?

fischig
Beiträge: 1440
Registriert: 24.12.2019 12:25:08
Lizenz eigener Beiträge: MIT Lizenz

Re: WLAN BCM4313 mit Buster

Beitrag von fischig » 09.04.2021 22:29:59

Danke für die Bestätigung.

Wo habe ich in diesem Thread geschrieben, dass ich etwas nicht verstehe?

fischig
Beiträge: 1440
Registriert: 24.12.2019 12:25:08
Lizenz eigener Beiträge: MIT Lizenz

Re: Broadcom BCM4313 mit Buster

Beitrag von fischig » 06.05.2021 18:51:37

Um die LED mit dem freien Treiber richtig leuchten zu lassen, muss wohl das Modul bcma_driver_gpio in den Kern einkompileirt werden. Im Buster-Standard-Kern-4.19 ist es nicht vorhanden. Ob's funktioniert, weiß ich noch nicht, bin gerade dabei, einen eigenen 4.19er für das HP-Pavilion zu bauen und dabei darüber gestolpert. :wink:

peter1969
Beiträge: 593
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Broadcom BCM4313 mit Buster

Beitrag von peter1969 » 06.05.2021 21:25:43

Dann wäre zwar das Problem mit der LED gelöst, aber was ist mit der miserablen Geschwindigkeit mit dem freien Treiber? Probiere es aus und berichte. Ich hab das übrigens auch mal mit Knoppix 9.1 getestet. Das lädt auch den freien Treiber und geht dann auch nur lausig. Eigentlich gar nicht. Und läuft instabil, sobald ich versuche, WLAN zu benutzen.
Grüße, Peter
Debian 10 Buster mit Xfce auf HP Pavilion dv6

fischig
Beiträge: 1440
Registriert: 24.12.2019 12:25:08
Lizenz eigener Beiträge: MIT Lizenz

Re: Broadcom BCM4313 mit Buster

Beitrag von fischig » 07.05.2021 09:55:10

Probiere es aus und berichte.
Wenn überhaupt, werde ich das erst dann tun, wenn der Klapprechner als Router voll fungiert, wozu für mich ein Eigenbau-Kern gehört. Das klappt noch nicht. (Keinerlei Erfahrung mit AMD-CPUs). Im übrigen wollte der freie Treiber für den BCM4313 unabhängig von der LED-Geschichte hier auch nicht richtig funktionieren, wl war als AP nicht zu gebrauchen, weswegen ich erstmal auf ASUS USB N13 (Realtek :twisted: rtl8192cu) umgestiegen bin.

Antworten