externes DVD-Laufwerk (2)

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
Benutzeravatar
Luxuslurch
Moderator
Beiträge: 1787
Registriert: 14.09.2008 09:41:54

externes DVD-Laufwerk (2)

Beitrag von Luxuslurch » 12.04.2010 12:33:18

Hallo,

vor kurzer Zeit hatte ich mal kurz angefragt, ob ihr denn glaubt, dass dieses Gerät hier

http://cgi.ebay.de/USB-2-0-Gehaeuse-Kit ... 3efa59d87d

meinen DVD-Brenner beherbergen und sich unter Lenny betreiben ließe. Nun ja, jetzt bin ich einen Schritt weiter und kann nur zu 50% Vollzug melden, d.h. ich kann von DVDs in diesem Laufwerk lesen > keine Probleme.

Aaaber kein Brennprogramm erkennt meinen Brenner! Weder Xfburn noch das extra dafür installierte K3b können das Laufwerk korrekt zuordnen.

Also Troubleshooting:

1. Lege ich eine DVD in das Laufwerk, so ploppt Thunar auf (mit aktiviertem Hal und thunar-volman nichts ungewöhnliches). Über 'mount' erfahre ich, dass er das Gerät an /dev/sr0 eingebunden hat. So weit, so gut.

2. Bei k3b kriege ich eine Menge Fehlermeldungen, wenn ich über das Terminal starte: siehe http://debianforum.de/forum/pastebin.ph ... ew&s=34516

Hier merkt man, dass k3b durchaus in der Lage ist, das Laufwerk zu identifizieren (es ist tatsächlich ein Ricoh MP5240A), aber irgendwie kann er nix damit anfangen.

3. Schalte ich das Gerät ein, spuckt 'dmesg' folgendes aus:
[ 1258.652054] usb 3-2: new high speed USB device using ehci_hcd and address 6
[ 1258.785651] usb 3-2: configuration #1 chosen from 1 choice
[ 1258.786486] scsi3 : SCSI emulation for USB Mass Storage devices
[ 1258.786818] usb 3-2: New USB device found, idVendor=05e3, idProduct=0701
[ 1258.786824] usb 3-2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[ 1258.786828] usb 3-2: Product: USB Storage
[ 1258.786856] usb-storage: device found at 6
[ 1258.786859] usb-storage: waiting for device to settle before scanning
[ 1263.784351] usb-storage: device scan complete
[ 1263.876879] scsi 3:0:0:0: CD-ROM RICOH DVD+RW MP5240 1.11 PQ: 0 ANSI: 0
[ 1264.252716] sr0: scsi-1 drive
[ 1264.252873] sr 3:0:0:0: Attached scsi CD-ROM sr0
[ 1264.252952] sr 3:0:0:0: Attached scsi generic sg0 type 5
[ 1268.186451] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 1268.371754] ISO 9660 Extensions: RRIP_1991A
Sieht für mich als Laie auch normal aus. Sobald ich k3b starte, kommen noch folgende Zeilen hinzu:
[ 1351.068100] sr 3:0:0:0: Device offlined - not ready after error recovery
[ 1351.068126] sr 3:0:0:0: rejecting I/O to offline device
[ 1351.068316] sr 3:0:0:0: rejecting I/O to offline device
[ 1351.071973] VFS: busy inodes on changed media.
[ 1351.121585] usb 3-2: USB disconnect, address 6
[ 1351.193254] scsi 3:0:0:0: rejecting I/O to dead device
Und das Ergebnis ist, dass das Gerät ausgehängt wird (nicht mehr unter /dev/sr0 gemountet ist).

4. Ein neuer Kernel (der neueste aus den Backports, 2.6.32) brachte keinerlei Veränderung zu den oben genannten Punkten.

5. Das Ausführen von k3b oder Xfburn als root brachte ebenfalls keine Veränderung mit sich.

==> Was sind eure Vermutungen? Anscheinend sind doch die Brennprogramme schuld. Das muss doch irgendwie funktionieren. Aber wie?

Danke im voraus für eure Ideen,

Lurchi
Debian Stable.
Der Mod spricht grün

rendegast
Beiträge: 15036
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: externes DVD-Laufwerk (2)

Beitrag von rendegast » 12.04.2010 14:19:19

Schade wegen der "99%" :?

Kannst Du es mal mit wodim direkt versuchen?

Code: Alles auswählen

wodim -v dev=/dev/sr0 -pad irgendein.iso
ohne daß k3b / hal schon darauf zugegriffen haben?
Eventuell im 'init 1' mit gekilltem hal?
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Benutzeravatar
Luxuslurch
Moderator
Beiträge: 1787
Registriert: 14.09.2008 09:41:54

Re: externes DVD-Laufwerk (2)

Beitrag von Luxuslurch » 12.04.2010 18:07:06

Hmm... es wird langsam mysteriös.

Also: Unter init 1 hat das nicht funktioniert. Ich kriege nur die Fehlermeldung 'Cannot open SCSI driver'. SCSI? Wieso SCSI??

Ich habe dann neu gestartet in den 2.6.26er-Kernel. Da die eingelegte DVD automatisch gemountet wird, habe ich sie einfach mit 'umount /dev/sr0' ausgehangen. Anschließend konnte ich mit dem oben genannten Befehl eine Iso-Datei auf die DVD brennen! Ich kann allerdings nicht formatieren und löschen (blank=all), aber das ist grad nicht so entscheidend.

Was die Sache merkwürdig macht: Starte ich Xfburn, so erkennt dieses jetzt meinen DVD-Brenner. Starte ich k3b, so ist das NICHT der Fall. Merkwürdiger noch: Vor dem Start von k3b gibt 'wodim --devices' dies aus:
wodim: Overview of accessible drives (2 found) :
-------------------------------------------------------------------------
0 dev='/dev/scd0' rwrw-- : 'RICOH' 'DVD+RW MP5240'
1 dev='/dev/hdc' rwrw-- : 'TOSHIBA' 'DVD-ROM SD-R2412'
-------------------------------------------------------------------------
Nach dem Start (und Beenden) von k3b nur noch:
wodim: Overview of accessible drives (1 found) :
-------------------------------------------------------------------------
0 dev='/dev/hdc' rwrw-- : 'TOSHIBA' 'DVD-ROM SD-R2412'
-------------------------------------------------------------------------
Jetzt kann ich k3b aber nicht beibringen, ein Gerät unter /dev/scd0 zu suchen. Dies dürfte aber noch andere Ursachen haben, denn jetzt kann ich noch nicht einmal die DVD mit dem kleinen Knopf auswerfen (auch nicht mit 'eject')! Das Gerät verschwindet einfach von der Bildfläche. >> Aus- und wieder anschalten bringt es wieder zurück, allerdings nicht für wodim, sondern nur für Thunar.

Okay, das Gerät wird also als SCSI Gerät erkannt und nicht unter /dev/sr0 sondern unter /dev/scd0 angesprochen. Obwohl auch das nicht ganz richtig ist, denn wenn ich frisch hochfahre, muss ich das Medium im Laufwerk mit 'umount /dev/sr0' aushängen, nicht mit .../scd0. .... :?:

>>> Da will mich das Gerät wohl veralbern??
Debian Stable.
Der Mod spricht grün

rendegast
Beiträge: 15036
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: externes DVD-Laufwerk (2)

Beitrag von rendegast » 17.04.2010 20:47:34

Hat lange gedauert, ich weiß immer noch nichts zum Problem, leider.


Nur hierzu:
Also: Unter init 1 hat das nicht funktioniert. Ich kriege nur die Fehlermeldung 'Cannot open SCSI driver'. SCSI? Wieso SCSI??
Früher gab es scsi sdx und ide hdx,
Dann kam libata und das neue Treibermodell, mit stufenweiser Umstellung der ide-Treiber auf libata,
das jeweilige device wurde von hdx zu sdx.
Beim 2.6.32-4 schlägt debian nochmal richtig zu, Auszug:

Code: Alles auswählen

$ diff -y config-2.6.32-3-686-bigmem config-2.6.32-4-686-bigmem | egrep -i "PCI IDE|_PATA_ACPI" -A40
# PCI IDE chipsets support                                      # PCI IDE chipsets support
#                                                               #
CONFIG_BLK_DEV_IDEPCI=y                                         CONFIG_BLK_DEV_IDEPCI=y
# CONFIG_BLK_DEV_OFFBOARD is not set                            # CONFIG_BLK_DEV_OFFBOARD is not set
CONFIG_BLK_DEV_GENERIC=m                                      | # CONFIG_BLK_DEV_GENERIC is not set
CONFIG_BLK_DEV_OPTI621=m                                        CONFIG_BLK_DEV_OPTI621=m
CONFIG_BLK_DEV_RZ1000=m                                       | # CONFIG_BLK_DEV_RZ1000 is not set
CONFIG_BLK_DEV_IDEDMA_PCI=y                                     CONFIG_BLK_DEV_IDEDMA_PCI=y
CONFIG_BLK_DEV_AEC62XX=m                                      | # CONFIG_BLK_DEV_AEC62XX is not set
CONFIG_BLK_DEV_ALI15X3=m                                      | # CONFIG_BLK_DEV_ALI15X3 is not set
CONFIG_BLK_DEV_AMD74XX=m                                      | # CONFIG_BLK_DEV_AMD74XX is not set
CONFIG_BLK_DEV_ATIIXP=m                                       | # CONFIG_BLK_DEV_ATIIXP is not set
CONFIG_BLK_DEV_CMD64X=m                                       | # CONFIG_BLK_DEV_CMD64X is not set
CONFIG_BLK_DEV_TRIFLEX=m                                      | # CONFIG_BLK_DEV_TRIFLEX is not set
CONFIG_BLK_DEV_CS5520=m                                       | # CONFIG_BLK_DEV_CS5520 is not set
CONFIG_BLK_DEV_CS5530=m                                       | # CONFIG_BLK_DEV_CS5530 is not set
CONFIG_BLK_DEV_CS5535=m                                         CONFIG_BLK_DEV_CS5535=m
CONFIG_BLK_DEV_CS5536=m                                       | # CONFIG_BLK_DEV_CS5536 is not set
CONFIG_BLK_DEV_HPT366=m                                         CONFIG_BLK_DEV_HPT366=m
# CONFIG_BLK_DEV_JMICRON is not set                             # CONFIG_BLK_DEV_JMICRON is not set
CONFIG_BLK_DEV_SC1200=m                                       | # CONFIG_BLK_DEV_SC1200 is not set
CONFIG_BLK_DEV_PIIX=m                                           CONFIG_BLK_DEV_PIIX=m
CONFIG_BLK_DEV_IT8172=m                                         CONFIG_BLK_DEV_IT8172=m
CONFIG_BLK_DEV_IT8213=m                                         CONFIG_BLK_DEV_IT8213=m
CONFIG_BLK_DEV_IT821X=m                                       | # CONFIG_BLK_DEV_IT821X is not set
CONFIG_BLK_DEV_NS87415=m                                      | # CONFIG_BLK_DEV_NS87415 is not set
CONFIG_BLK_DEV_PDC202XX_OLD=m                                 | # CONFIG_BLK_DEV_PDC202XX_OLD is not set
CONFIG_BLK_DEV_PDC202XX_NEW=m                                 | # CONFIG_BLK_DEV_PDC202XX_NEW is not set
CONFIG_BLK_DEV_SVWKS=m                                        | # CONFIG_BLK_DEV_SVWKS is not set
CONFIG_BLK_DEV_SIIMAGE=m                                      | # CONFIG_BLK_DEV_SIIMAGE is not set
CONFIG_BLK_DEV_SIS5513=m                                      | # CONFIG_BLK_DEV_SIS5513 is not set
CONFIG_BLK_DEV_SLC90E66=m                                     | # CONFIG_BLK_DEV_SLC90E66 is not set
CONFIG_BLK_DEV_TRM290=m                                         CONFIG_BLK_DEV_TRM290=m
CONFIG_BLK_DEV_VIA82CXXX=m                                    | # CONFIG_BLK_DEV_VIA82CXXX is not set
CONFIG_BLK_DEV_TC86C001=m                                       CONFIG_BLK_DEV_TC86C001=m

#                                                               #
# Other IDE chipsets support                                    # Other IDE chipsets support
#                                                               #

#                                                               #
--
# CONFIG_PATA_ACPI is not set                                   # CONFIG_PATA_ACPI is not set
# CONFIG_PATA_ALI is not set                                  | CONFIG_PATA_ALI=m
# CONFIG_PATA_AMD is not set                                  | CONFIG_PATA_AMD=m
CONFIG_PATA_ARTOP=m                                             CONFIG_PATA_ARTOP=m
CONFIG_PATA_ATP867X=m                                           CONFIG_PATA_ATP867X=m
# CONFIG_PATA_ATIIXP is not set                               | CONFIG_PATA_ATIIXP=m
# CONFIG_PATA_CMD640_PCI is not set                             # CONFIG_PATA_CMD640_PCI is not set
# CONFIG_PATA_CMD64X is not set                               | CONFIG_PATA_CMD64X=m
# CONFIG_PATA_CS5520 is not set                               | CONFIG_PATA_CS5520=m
# CONFIG_PATA_CS5530 is not set                               | CONFIG_PATA_CS5530=m
# CONFIG_PATA_CS5535 is not set                                 # CONFIG_PATA_CS5535 is not set
# CONFIG_PATA_CS5536 is not set                               | CONFIG_PATA_CS5536=m
# CONFIG_PATA_CYPRESS is not set                                # CONFIG_PATA_CYPRESS is not set
# CONFIG_PATA_EFAR is not set                                 | CONFIG_PATA_EFAR=m
CONFIG_ATA_GENERIC=m                                            CONFIG_ATA_GENERIC=m
# CONFIG_PATA_HPT366 is not set                                 # CONFIG_PATA_HPT366 is not set
# CONFIG_PATA_HPT37X is not set                                 # CONFIG_PATA_HPT37X is not set
# CONFIG_PATA_HPT3X2N is not set                                # CONFIG_PATA_HPT3X2N is not set
# CONFIG_PATA_HPT3X3 is not set                                 # CONFIG_PATA_HPT3X3 is not set
# CONFIG_PATA_ISAPNP is not set                                 # CONFIG_PATA_ISAPNP is not set
# CONFIG_PATA_IT821X is not set                               | CONFIG_PATA_IT821X=m
# CONFIG_PATA_IT8213 is not set                                 # CONFIG_PATA_IT8213 is not set
CONFIG_PATA_JMICRON=m                                           CONFIG_PATA_JMICRON=m
# CONFIG_PATA_LEGACY is not set                                 # CONFIG_PATA_LEGACY is not set
# CONFIG_PATA_TRIFLEX is not set                              | CONFIG_PATA_TRIFLEX=m
CONFIG_PATA_MARVELL=m                                           CONFIG_PATA_MARVELL=m
# CONFIG_PATA_MPIIX is not set                                | CONFIG_PATA_MPIIX=m
# CONFIG_PATA_OLDPIIX is not set                              | CONFIG_PATA_OLDPIIX=m
# CONFIG_PATA_NETCELL is not set                              | CONFIG_PATA_NETCELL=m
# CONFIG_PATA_NINJA32 is not set                                # CONFIG_PATA_NINJA32 is not set
# CONFIG_PATA_NS87410 is not set                              | CONFIG_PATA_NS87410=m
# CONFIG_PATA_NS87415 is not set                              | CONFIG_PATA_NS87415=m
# CONFIG_PATA_OPTI is not set                                   # CONFIG_PATA_OPTI is not set
# CONFIG_PATA_OPTIDMA is not set                                # CONFIG_PATA_OPTIDMA is not set
# CONFIG_PATA_PCMCIA is not set                                 # CONFIG_PATA_PCMCIA is not set
# CONFIG_PATA_PDC_OLD is not set                              | CONFIG_PATA_PDC_OLD=m
# CONFIG_PATA_QDI is not set                                    # CONFIG_PATA_QDI is not set
# CONFIG_PATA_RADISYS is not set                                # CONFIG_PATA_RADISYS is not set
CONFIG_PATA_RDC=m                                               CONFIG_PATA_RDC=m
# CONFIG_PATA_RZ1000 is not set                               | CONFIG_PATA_RZ1000=m
# CONFIG_PATA_SC1200 is not set                               | CONFIG_PATA_SC1200=m
Also nichts weiter als eine Migration.
Und bei Verwendung von LABEL / UUID auch schnurzpiepegal (wenn es funktioniert).

Wobei das aber nicht nur die IDE-chipsätze betrifft, sondern jegliches blockdevice,
also auch die über USB oder firewire angeschlossenen Geräte.

Im Normalfall solltest Du das Laufwerk als sr0, scd0, dvd oder cdrw oder sonstwas ansprechen können,
sind (fast) alles nur von udev erstellte Links, siehe zBsp.
/lib/udev/rules.d/75-cd-aliases-generator.rules
/etc/udev/rules.d/70-persistent-cd.rules

Daß das Gerät einfach so verschwindet ist nicht normal, die Kabelverbindung ist stabil?
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

guennid
Beiträge: 12412
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: externes DVD-Laufwerk (2)

Beitrag von guennid » 18.04.2010 13:15:51

Luxuslurch hat geschrieben:Starte ich Xfburn, so erkennt dieses jetzt meinen DVD-Brenner. Starte ich k3b, so ist das NICHT der Fall.
xfburn benutzt, soweit ich weiß, kein wodim (=verschlimmbessertes cdrecord).

Grüße, Günther

Benutzeravatar
Luxuslurch
Moderator
Beiträge: 1787
Registriert: 14.09.2008 09:41:54

Re: externes DVD-Laufwerk (2)

Beitrag von Luxuslurch » 21.04.2010 21:07:51

Danke für eure Antworten!

Ich habe jetzt das Gerät unter Windows getestet - keine Probleme. Ein Hardwarefehler (lockeres Kabel o.ä.) lässt sich also ausschließen.

Dann habe ich k3b und xfburn mal gelöscht, um mögliche Fehlerquellen auszuschließen. Nur wodim ließ ich installiert. Folgender Ablauf nun:

- ohne eine eingelegte Scheibe erkennt wodim --devices das Gerät richtig unter /dev/scd0
- ein wodim dev=/dev/scd0 -checkdrive bestätigt das Vorhandensein eines Treibers. Zumindest sieht die Ausgabe gut aus:
cornel@toshiba:~/Downloads$ wodim dev=/dev/scd0 -checkdrive
Device type : Removable CD-ROM
Version : 0
Response Format: 2
Capabilities :
Vendor_info : 'RICOH '
Identification : 'DVD+RW MP5240 '
Revision : '1.11'
Device seems to be: Generic mmc2 DVD-ROM.
Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
Driver flags : MMC-3 SWABAUDIO BURNFREE FORCESPEED
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R96R
- sobald ich eine Scheibe einlege, erscheint es bei Thunar auf dem Radar (vermutlich wegen Hal).
- und dann mag wodim nicht mehr, z.B. die CD löschen (Device or ressource busy)
- jetzt wird das Gerät NICHT mehr von wodim --devices erkannt.
- Aushängen des Datenträgers hilft, danach ist es wieder wie vorher, und
- ich konnte eine CD löschen.
- Ich konnte die CD danach auch erfolgreich wieder beschreiben.
Ich werde wohl weiterhin ausprobieren, wie ich wann das Gerät ansprechen darf. Definitiv scheint Hal dazwischen zu funken, was sich aber immerhin händisch umgehen lässt. Vermutlich lässt sich das o.g. Prozedere auch auf k3b anwenden, aber das interessiert mich eigentlich gerade weniger.

Ich bin weiterhin offen für Anregungen, wie sich Hal besser einstellen lässt.

Grüße,
Lurchi
Debian Stable.
Der Mod spricht grün

guennid
Beiträge: 12412
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: externes DVD-Laufwerk (2)

Beitrag von guennid » 21.04.2010 21:27:08

Tja, wenn du von wodim nicht lassen kannst ...? Man kann auch das Original (cdrecord) installieren. Ist aber etwas aufwendig und tricky. Solltest mal SuFu benutzen.

Grüße, Günther

Benutzeravatar
Luxuslurch
Moderator
Beiträge: 1787
Registriert: 14.09.2008 09:41:54

Re: externes DVD-Laufwerk (2)

Beitrag von Luxuslurch » 21.04.2010 22:08:34

öhm, cdrecord verhält sich da ganz genauso wie wodim? Zumindest das Paket aus den Lenny-Repos. Allerdings denke ich, dass beim Aufruf von cdrecord gleich wodim benutzt wird.

Aber meinst du wirklich, dass es daran liegt? Ich wäre auch bereit, cdrecord anderweitig zu installieren (selber kompilieren denke ich mal). Aber ob es nicht doch eher an Hal liegt?
Debian Stable.
Der Mod spricht grün

guennid
Beiträge: 12412
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: externes DVD-Laufwerk (2)

Beitrag von guennid » 22.04.2010 07:52:33

Aus den debian-repositories kriegst du kein cdrecord. Es gibt zu diesem Problemkreis (wodim/cdrecord) hier einige recht interessante und teils aggressive Beiträge. Deswegen mein Hinweis auf die Such-Funktion.
wodim ist ein fork von cdrecord, von dem der Entwickler (von cdrecord) auch hier im forum (unter dem Nick schily) ziemlich heftig behauptet, dass er enorm fehlerhaft sei und nicht gewartet werde. Was da dran ist, vermag ich nicht zu beurteilen, habe aber mitgelesen, dass Mitlieder dieses Forums, die ich für ziemlich kompetent halte, tatsächlich wodim durch das Original austauschen.

Auf meinem Schlepptop hatte ich Schwierigkeiten mit xcdroast (das benutzt bei debian wodim). Deswegen hatte ich mich ebenfalls an einem Austausch versucht, den ich aber nicht hingekriegt habe. Und weil xcdroast auch ziemlich tot ist, habe ich mich letztlich für xfburn auf dem Schleppi entschieden (ohne kde hole ich mir kein k3b auf die Platte) und das benötigt, wie schon gesagt, kein wodim/cdrecord. Auf einem anderen Rechner mit kde arbeitet k3b mit wodim seit langem ohne irgend einen Fehler.

Grüße, Günther

debianoli
Beiträge: 3130
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: externes DVD-Laufwerk (2)

Beitrag von debianoli » 22.04.2010 10:30:08

guennid hat geschrieben:Auf meinem Schlepptop hatte ich Schwierigkeiten mit xcdroast (das benutzt bei debian wodim). Deswegen hatte ich mich ebenfalls an einem Austausch versucht, den ich aber nicht hingekriegt habe.
Ich habe bei mir auch das originale cdrecord auf meinen Rechnern installiert, das es um Welten besser ist als das Zeug aus den Debian-Reps. Mit cdrecord kann man nämlich z.B. problemlos CD-RW löschen, wodim kriegt das nicht hin. Die Installation per checkinstall -D aus den Quellen läuft bei mir ohne Probleme durch, einfach mal probieren: http://cdrecord.berlios.de/private/cdrecord.html
------------
Dieses verdammte Linux holt mir nicht mal ein Bier aus dem Kühlschrank!

guennid
Beiträge: 12412
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: externes DVD-Laufwerk (2)

Beitrag von guennid » 22.04.2010 15:31:35

Das Problem besteht wahrscheinlich weniger darin cdrecord rein-, als das vorhandene wodim rauszukriegen. :mrgreen:

Benutzeravatar
Jerry
Beiträge: 665
Registriert: 01.09.2006 08:36:45
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: /home

Re: externes DVD-Laufwerk (2)

Beitrag von Jerry » 22.04.2010 15:46:39

Hi,
debianoli hat geschrieben: Ich habe bei mir auch das originale cdrecord auf meinen Rechnern installiert, das es um Welten besser ist als das Zeug aus den Debian-Reps. Mit cdrecord kann man nämlich z.B. problemlos CD-RW löschen, wodim kriegt das nicht hin. Die Installation per checkinstall -D aus den Quellen läuft bei mir ohne Probleme durch, einfach mal probieren: http://cdrecord.berlios.de/private/cdrecord.html
Unter Squeeze habe ich null Probleme mit wodim und ich lösche jeden Morgen 2 CD-RWs und bespiele sie wieder mit Musik für die Fahrt zur Arbeit. Auch unter Lenny hab ich solch Problem noch nicht festgestellt. Aber dafür findet K3b das parallel installierte cdrecord nicht mehr :(
Selbst beim manuellen Erweitern des PATH um /opt/schily/bin wird es nicht gefunden.

Gruß
Wolf
Selbst der längste Weg beginnt mit dem ersten Schritt Lao Tse (~ 600-400 v. Chr.)

debianoli
Beiträge: 3130
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: externes DVD-Laufwerk (2)

Beitrag von debianoli » 22.04.2010 16:00:19

guennid hat geschrieben:Das Problem besteht wahrscheinlich weniger darin cdrecord rein-, als das vorhandene wodim rauszukriegen. :mrgreen:
Versteh ich nicht:

Code: Alles auswählen

apt-get remove wodim -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  mybashburn wodim
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Remv mybashburn [1.0.2-1]
Remv wodim [9:1.1.9-1]
Klappt also auf anhieb.
Jerry hat geschrieben:Aber dafür findet K3b das parallel installierte cdrecord nicht mehr :(
Selbst beim manuellen Erweitern des PATH um /opt/schily/bin wird es nicht gefunden.
Seltsam, hier am KDE3.5-Rechner erkennt K3b das sofort von sich aus und wählt auch /opt/schily/bin als Standard aus.
------------
Dieses verdammte Linux holt mir nicht mal ein Bier aus dem Kühlschrank!

guennid
Beiträge: 12412
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: externes DVD-Laufwerk (2)

Beitrag von guennid » 22.04.2010 17:02:17

debianoli hat geschrieben:
guennid hat geschrieben:Das Problem besteht wahrscheinlich weniger darin cdrecord rein-, als das vorhandene wodim rauszukriegen. :mrgreen:
Versteh ich nicht:
Dann lies doch einfach mal hier ein paar andere Erfahrungsberichte.

Antworten