Maus an USB-Anschluss friert gelegentlich ein

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
gnu
Beiträge: 96
Registriert: 04.03.2015 15:11:42

Re: gelöst - Maus an USB-Anschluss friert gelegentlich ein

Beitrag von gnu » 13.01.2016 05:54:40

falls das zur Klärung des Problems beiträgt:

Es gibt auch noch eine Variante des Mausproblems:
Ich hatte auf einem Notebook Debian installiert, wenn man es ausgeschaltet hat und die Maus angesteckt lies, stürzte es beim wieder Einschalten während des Bootvorgangs ab.

Steckte man die Maus ab, startete der Bootvorgang ganz normal u. man konnte die Maus wieder anstecken.

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: gelöst - Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 13.01.2016 10:21:02

Hallo rendegast. Natürlich sollte ein BIOS Update nicht Grub massakrieren. Aber ich habe ein EFI Update gemacht. Das greift doch weiter um sich als ein simples BIOS, siehe:

https://de.wikipedia.org/wiki/Unified_E ... _Interface

Tatsache ist, dass das Notebook nach dem Update beim Hochfahren kein Betriebssystem mehr fand. Auch ein Zurücksetzen auf Default-Werte und das Abschalten der Legacy-Funktion brachte nichts. Letztlich musste ich grub-efi mit folgender Anleitung neu installieren/konfigurieren:

https://wiki.debian.org/GrubEFIReinstall
Zuletzt geändert von peter1969 am 12.11.2016 08:49:12, insgesamt 1-mal geändert.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Alternativende
Beiträge: 1997
Registriert: 07.07.2006 18:32:05

Re: gelöst - Maus an USB-Anschluss friert gelegentlich ein

Beitrag von Alternativende » 14.01.2016 13:52:27

Inwiefern ist das Problem denn jetzt gelöst? Habe ich etwas übersehen?

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: gelöst - Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 14.01.2016 20:48:15

Tja, wie gesagt, Ich habe die Logitech RX1000 inzwischen zum Teufel gejagt und benutze gerade eine Logitech RX1500. Bis jetzt kam das Problem nicht wieder. Ich denke, die RX1000 war schlicht und einfach doch defekt.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Alternativende
Beiträge: 1997
Registriert: 07.07.2006 18:32:05

Re: gelöst - Maus an USB-Anschluss friert gelegentlich ein

Beitrag von Alternativende » 14.04.2016 15:46:47

Ich habe nun mit Stretch schon eine ganze Weile überhaupt keine Probleme mehr.

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 05.09.2016 16:09:58

So, das Problem taucht wieder auf. Ich habe eine Logitech RX250. Mein System schaltet die Maus, d.h. den USB-Port, an dem dieselbe angeschlossen ist, gelegentlich ab (die Maus geht am Windows-PC in meiner Firma einwandfrei). Möglicherweise ist das eine Stromsparfunktion des Notebooks, die hier greift. Mit einer testweise angeschlossenen Microsoft-Maus gibt es das Problem übrigens nicht. Kann man marodierende USB-Stromsparfunktionen einfach abschalten?
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Benutzeravatar
niemand
Beiträge: 9655
Registriert: 18.07.2004 16:43:29

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von niemand » 05.09.2016 16:30:20

Gibt es Logeinträge? Auch wenn nur welche vom Einstecken/Erkennen der Maus vorhanden sind, würden die u.U. weiterhelfen können.
••• Hinweis: Von diesem User werden auch Sarkasmus und Ironie verarbeitet. Spuren davon können daher in diesem Beitrag enthalten sein •••
T2IgaWNoIHdhcyB6dSB2ZXJiZXJnZW4gaGFiZT8gTmF0w7xybGljaCBoYWJlIGljaCB3YXMgenUgdmVyYmVyZ2VuIOKAkyBpY2ggYmluIHNjaGxpZcOfbGljaCBlaW4gTWVuc2NoISAK

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 05.09.2016 18:29:07

Hier ist die Ausgabe von dmesg nach dem Einstecken der Logitech-Maus

[ 54.746296] usb 1-1.3: new low-speed USB device number 5 using ehci-pci
[ 54.844942] usb 1-1.3: New USB device found, idVendor=046d, idProduct=c050
[ 54.844945] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 54.844948] usb 1-1.3: Product: USB-PS/2 Optical Mouse
[ 54.844949] usb 1-1.3: Manufacturer: Logitech
[ 54.933370] hidraw: raw HID events driver (C) Jiri Kosina
[ 54.959975] usbcore: registered new interface driver usbhid
[ 54.959979] usbhid: USB HID core driver
[ 54.965245] input: Logitech USB-PS/2 Optical Mouse as /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.0/0003:046D:C050.0001/input/input18
[ 54.965352] hid-generic 0003:046D:C050.0001: input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:1d.0-1.3/input0

und hier nach dem Einstecken der Microsoft-Maus.

[ 264.350522] usb 2-2: new low-speed USB device number 2 using xhci_hcd
[ 264.482602] usb 2-2: New USB device found, idVendor=045e, idProduct=0084
[ 264.482607] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 264.482609] usb 2-2: Product: Microsoft Basic Optical Mouse
[ 264.482611] usb 2-2: Manufacturer: Microsoft
[ 264.482827] usb 2-2: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
[ 264.485969] input: Microsoft Microsoft Basic Optical Mouse as /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/0003:045E:0084.0002/input/input19
[ 264.486081] hid-generic 0003:045E:0084.0002: input,hidraw1: USB HID v1.11 Mouse [Microsoft Microsoft Basic Optical Mouse ] on usb-0000:00:14.0-2/input0
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Benutzeravatar
niemand
Beiträge: 9655
Registriert: 18.07.2004 16:43:29

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von niemand » 05.09.2016 19:19:25

Hmm … zumindest ich sehe da nichts, wo ich mit dem Finger drauf zeigen und „daran liegt’s” sagen könnte. Vielleicht hilft es, die betreffende Maus zu blacklisten?
Arch-Wiki hat geschrieben:
Alternatively, to blacklist devices that are not working with USB autosuspend and enable it for all other devices:

/etc/udev/rules.d/50-usb_power_save.rules

Code: Alles auswählen

# blacklist for usb autosuspend
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="046d", ATTR{idProduct}=="c050", GOTO="power_usb_rules_end"

ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control", ATTR{power/control}="auto"
LABEL="power_usb_rules_end"
(IDs bereits angepasst)
••• Hinweis: Von diesem User werden auch Sarkasmus und Ironie verarbeitet. Spuren davon können daher in diesem Beitrag enthalten sein •••
T2IgaWNoIHdhcyB6dSB2ZXJiZXJnZW4gaGFiZT8gTmF0w7xybGljaCBoYWJlIGljaCB3YXMgenUgdmVyYmVyZ2VuIOKAkyBpY2ggYmluIHNjaGxpZcOfbGljaCBlaW4gTWVuc2NoISAK

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 05.09.2016 21:24:07

ok, danke. Ich checke das mal und melde mich des Resultates wegen. Kann aber etwas dauern.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 19.09.2016 22:29:52

Also, der neueste GAG: die USB-Schnittstellen werden beim Starten des PC erst gar nicht aktiviert. Mit der Logitech-Maus, kann ich sie nicht aufwecken, wohl aber mit der "neueren" Microsoft Maus.

Ich habe nun den Tipp von niemand mit dem blacklisten der Maus für das Energiesparsystem ausgeführt (vielen Dank an niemand). Bis jetzt scheint es zu gehen. Ich teste das noch eine Weile und geb dann Bescheid.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 22.09.2016 00:18:37

OK, niemands Lösung scheint zu gehen (zwischenzeitlich habe ich es übrigens auch mit laptop-mode-tools und der entsprechenden Konfiguration versucht, aber das ging gar nicht).

Noch besser gefällt mir allerdings diese Lösung (gefunden bei http://hamwaves.com/usb.autosuspend/en/):

Eine Datei /etc/udev/rules.d/50-usb_power_save.rules erzeugen mit folgendem Inhalt:
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="046d", ATTR{idProduct}=="c050", TEST=="power/control", ATTR{power/control}="on"

Hierdurch wird die Maus autosuspendmäßig von "auto" (Standardwert) auf "on" umgestellt und bleibt damit immer an.

Kontrolle:

peter@peter:~$ cat /sys/bus/usb/devices/usb1/1-1/1-1.3/power/control
on
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 28.12.2016 14:45:56

Noch ein Zusatz. Das Abschalten des USB-Anschlusses trat immer noch - allerdings extrem selten - wieder auf. Ich habe mir nun einfach eine neue Maus gekauft (Logitech B100). Die alte RX250 werde ich im Januar in der Arbeit an meinem Windows 10 Rechner testen. Schaun wir mal, ob sie nicht einen Defekt hat. Ich werde das Ergebnis Mitte Januar posten.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

peter1969
Beiträge: 305
Registriert: 17.10.2006 08:57:58
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Stuttgart

Re: Maus an USB-Anschluss friert gelegentlich ein

Beitrag von peter1969 » 03.02.2017 22:06:28

Hallo, hier wie versprochen die Testresultate: die Logitech B100 geht an meinem Notebook einwandfrei und die RX250 geht an meinem Bürorechner mit Windows 10 auch einwandfrei. Die RX250 scheint also einen echten Konflikt mit meinem Notebook und dessen Debian 8 System zu haben.

Nachtrag: Mittlerweile zickt auch mein Bürorecher mit der Maus. Sie scheint also doch eine Macke zu haben und landet jetzt im Schrott.
Grüße, Peter
Debian 9 Stretch (64 bit) mit Xfce auf HP 350 G2 (Pentium 3805U/Broadwell)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste