[Sid] Bug in libinput?

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
dillo
Beiträge: 313
Registriert: 28.05.2005 19:53:56

[Sid] Bug in libinput?

Beitrag von dillo » 12.03.2018 06:09:46

[Sid] Bug in libinput?

MoinMoin,

seit einem dist-upgrade am letzten Donnerstag habe ich Probleme mit den Touchpads unserer Thinkpads (T410 und T430s).

I.d.R. bediene ich das Touchpad mit nur einem Finger (auch beim Scrollen). Hin und wieder kommt es aber natürlich vor, dass ein zweiter Finger auf das Touchpad 'fällt'. Seit besagtem dist-upgrade raucht mir dann der X-Server ab:

Code: Alles auswählen

Mar 11 09:25:42 lappi org.a11y.Bus[7155]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Mar 11 09:25:42 lappi org.a11y.Bus[7155]:       after 1245 requests (1245 known processed) with 0 events remaining.
Mar 11 09:25:42 lappi org.kde.kuiserver[734]: The X11 connection broke (error 1). Did the X11 server die?
Zuerst dachte ich an einen Hardwaredefekt, weil meiner Frau der Lappi am gleichen Tag runtergefallen war. Ein Test mit dem zweiten Laptop zeigte aber dann dasselbe Verhalten.

DE bzw WM scheinen keinen Einfluss zu haben, getestet habe ich mit Cinnamon, Enlightenment KDE und Mate.

Bei Durchsicht der upgegradeten Pakete bin ich auf libinput gestoßen:
libinput (1.10.2-1) unstable; urgency=medium

* New upstream release.
- touchpad fixes (LP: #1751190)

-- Timo Aaltonen <tjaalton@debian.org> Wed, 07 Mar 2018 17:51:58 +0200

Ein Downgrade auf das Paket von Buster (1.10.1-1) hat das Problem dann erst mal behoben.

Um endlich auf den Punkt zu kommen: Hat hier noch jemand einen Lappi mit Sid am Laufen und kann das von mir beobachtete Verhalten bestätigen? Dann sollte man ja wohl einen Bug Report an die libinput-Entwickler loslassen.

bullgard
Beiträge: 1363
Registriert: 14.09.2012 23:03:01

Re: [Sid] Bug in libinput?

Beitrag von bullgard » 13.03.2018 23:36:25

Auf meiner siductionbox Thinkpad X201 wurde libinput-bin/unstable durch dist-upgrade aktualisiert auf 1.10.2-1 amd64 ohne Probleme, und ich habe keine Besonderheiten mit meinem Touchpad anschließend bemerkt. [Xfce4.12]
Zuletzt geändert von bullgard am 13.03.2018 23:40:49, insgesamt 1-mal geändert.

Benutzeravatar
towo
Beiträge: 3164
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: [Sid] Bug in libinput?

Beitrag von towo » 13.03.2018 23:40:18

Auf meinem T420 kann ich das Problem bestätigen, auch hier hat ein Downgrade auf die Testing Version geholfen.

Benutzeravatar
hikaru
Beiträge: 9902
Registriert: 09.04.2008 12:48:59

Re: [Sid] Bug in libinput?

Beitrag von hikaru » 14.03.2018 00:00:25

Möglicherweise die gleiche Ursache:
Debian Bugreport892714

dillo
Beiträge: 313
Registriert: 28.05.2005 19:53:56

Re: [Sid] Bug in libinput?

Beitrag von dillo » 14.03.2018 19:57:20

Vielen Dank fürs Feedback!

Die Devs von libinput sind wohl schnell mit dem Fixen von Bugs. Mit Version 1.10.3 von heute, die auch schon für Sid verfügbar ist, tritt zumindest bei unseren ThinkPads das Problem nicht mehr auf.

Antworten