Debian Stretch GRUB Menu deaktivieren

Warum Debian? Was muss ich vorher wissen? Wo geht's nach der Installation weiter?
Antworten
Benutzeravatar
jmar83
Beiträge: 365
Registriert: 20.06.2013 20:20:15

Debian Stretch GRUB Menu deaktivieren

Beitrag von jmar83 » 07.10.2019 16:06:58

Folgende Einträge zur Datei `/etc/default/grub` hinzugefügt:

Code: Alles auswählen

GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
...anschliessend `update-grub` ausgeführt.


Resultat: Nichts passiert, alles immer noch beim Alten. Das Startmenü erscheint, wie gehabt, für 5 Sekunden...
Freundliche Grüsse, Jan

Benutzeravatar
jmar83
Beiträge: 365
Registriert: 20.06.2013 20:20:15

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von jmar83 » 07.10.2019 16:07:47

Habe ich hier gelesen: https://forums.linuxmint.com/viewtopic.php?t=225525, aber für Debian scheint das nicht zu gelten...

Und hier steht das auch: https://askubuntu.com/questions/111085/ ... ng-of-boot
Freundliche Grüsse, Jan

Benutzeravatar
jmar83
Beiträge: 365
Registriert: 20.06.2013 20:20:15

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von jmar83 » 07.10.2019 16:11:00

"GRUB_DISABLE_OS_PROBER=true" -> Bringt ebenfalls nix!

...und ich will nix "hidden" haben (dann müssen die x Sekunden auch abgewartet werden), ich will das GAR KEIN Startmenü (also 0 Sekunden) erscheint.


Nachtrag: Auch das bringt nix: `GRUB_CMDLINE_LINUX_DEFAULT=“quiet”`


Hehe, wieder mal try-and-error-Tag offenbar heute... :THX:
Freundliche Grüsse, Jan

Benutzeravatar
jmar83
Beiträge: 365
Registriert: 20.06.2013 20:20:15

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von jmar83 » 07.10.2019 16:18:17

Ebenfalls nix: `GRUB_TIMEOUT=0`...

..wäre aber auch extrem unsauber, Menü ist "enabled", dafür der Timeout auf "0", ne lieber nicht!! ;-)
Freundliche Grüsse, Jan

Benutzeravatar
jmar83
Beiträge: 365
Registriert: 20.06.2013 20:20:15

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von jmar83 » 07.10.2019 16:23:56

"Ebenfalls nix: `GRUB_TIMEOUT=0`..."
...muss mich korrigieren, der Standardwert von 5s war hard-codiert in der Konfig-Datei drin. Nun hat's geklappt.

Aber eben: Statt den timeout auf 0 zu tun, besser das ganze Menü verhindern. Wie könnte man sowas bewerkstelligen?
Freundliche Grüsse, Jan

Benutzeravatar
Livingston
Beiträge: 289
Registriert: 04.02.2007 22:52:25
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: 127.0.0.1

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von Livingston » 07.10.2019 21:24:04

Ich hab grad keine Zeit, selbst was zu testen, aber wenn Du Debianinfo installiert hast, dann schau mal unter

Code: Alles auswählen

info grub
nach. Scheint mehr herzugeben als die tausend einzelnen man pages zu den grub-Einzelteilen.

cronoik
Beiträge: 1818
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von cronoik » 08.10.2019 16:22:35

jmar83 hat geschrieben: ↑ zum Beitrag ↑
07.10.2019 16:23:56
...muss mich korrigieren, der Standardwert von 5s war hard-codiert in der Konfig-Datei drin.
Dann stimmt aber etwas nicht. Der Wert aus /etc/default/grub sollte den Wert in /boot/grub/grub.cfg ueberschreiben. Falls du jetzt in /boot/grub/grub.cfg den timeout Wert haendisch geaendert hast, dann wird dieser beim nachsten Aktualisieren dieser Datei ueberschrieben. Hast du in /etc/default/grub.d/ vielleicht noch andere Dateien die ein Ueberschreiben verursachen koennte? Das wuerde auch erklaeren warum die anderen Optionen wirkungslos waren.

P.S.: Ein grundsaetzlicher und persoenlicher Hinweis zur Forenhygiene: Falls noch niemand geantwortet hat, kannst du gern deinen ersten Beitrag um weitere Informationen ergaenzen, anstatt weitere Beitraege zu erzeugen. Ich schaue beispielsweise in Threads mit vielen Beitraegen nicht mehr rein, weil ich davon ausgehe das bereits jemand hilft.
Hilf mit unser Wiki zu verbessern!

Benutzeravatar
jmar83
Beiträge: 365
Registriert: 20.06.2013 20:20:15

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von jmar83 » 09.10.2019 08:53:09

"P.S.: Ein grundsaetzlicher und persoenlicher Hinweis zur Forenhygiene: Falls noch niemand geantwortet hat, kannst du gern deinen ersten Beitrag um weitere Informationen ergaenzen, anstatt weitere Beitraege zu erzeugen. Ich schaue beispielsweise in Threads mit vielen Beitraegen nicht mehr rein, weil ich davon ausgehe das bereits jemand hilft."
Danke für den Hinweis, daran habe ich gar nichtr gedacht. Werde schauen, dass ich das in Zukunft anders mache.

Zum grub-Thema: nach der Änderung habe ich noch `update-grub` ausgeführt..
Freundliche Grüsse, Jan

Benutzeravatar
smutbert
Beiträge: 6737
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von smutbert » 09.10.2019 10:01:07

Ich denke das setzen des „versteckten timeouts“ auf 0 deaktiviert selbigen, was du zwar willst, aber standarmäßig ist der versteckte Timeout ja sowieso deaktiviert.

Code: Alles auswählen

GRUB_TIMEOUT=0
wäre laut Dokumentation, diversen Foren- und Wikieinträgen und meiner Erfahrung genau das richtige → kein Countdown und das Menü wird nicht angezeigt, stattdessen startet der direkt der Default-Menüeintrag. Debians grub verhält sich in allen mir bekannten Punkten auch genau gleich wie der von Ubuntu, Mint,...
(Kein Coundown und kein Bootmenü ist aber wirklich lästig, wenn einmal bei einem Kernelupdate etwas schief geht oder ähnliches!)

Die anderen Zeilen, die du hinzugefügt hast, würde ich wieder löschen.
Hast du vielleicht irgendetwas debian-fremdes installiert, das etwas mit grub zu tun hat, zum Beispiel den grub-customizer, der war hier vom Forum schon mindestens zwei Mal für merkwürdiges Verhalten verantwortlich.

Code: Alles auswählen

GRUB_CMDLINE_LINUX_DEFAULT=“quiet”
übergibt lediglich dem Kernel die Option quiet, der dann beim Booten weniger gesprächig ist, wirkt sich sonst aber überhaupt nicht auf grub aus.

cronoik
Beiträge: 1818
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von cronoik » 09.10.2019 10:38:13

Noch als Ergaenzung zu smutbert erneut meine Frage:
cronoik hat geschrieben: ↑ zum Beitrag ↑
08.10.2019 16:22:35
Hast du in /etc/default/grub.d/ vielleicht noch andere Dateien die ein Ueberschreiben verursachen koennte? Das wuerde auch erklaeren warum die anderen Optionen wirkungslos waren.
Hilf mit unser Wiki zu verbessern!

Benutzeravatar
jmar83
Beiträge: 365
Registriert: 20.06.2013 20:20:15

Re: Debian Stretch GRUB Menu deaktivieren

Beitrag von jmar83 » 09.10.2019 11:02:57

"Hast du vielleicht irgendetwas debian-fremdes installiert"

Was ich installiert habe ist der backports-kernel, der ist zwar nicht direkt fremd, aber eigentlich auch kein "normaler" Bestandteil von Stretch.
Freundliche Grüsse, Jan

Antworten