Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Warum Debian? Was muss ich vorher wissen? Wo geht's nach der Installation weiter?
simonf
Beiträge: 17
Registriert: 07.11.2019 19:50:21

Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von simonf » 07.11.2019 20:41:26

Guten Abend,

vor kurzem habe ich mir das erste mal Debian als Betriebssystem installiert, da ich eine Windows-Alternative gesucht habe. Die Installation von Debian 10 Buster ist weitgehend ohne Probleme verlaufen und konnte das System vorerst auch fehlerfrei nutzen.

Um mein Problem zu verstehen ist es wichtig zu wissen, dass mein PC zwei interne Festplatten hat. Auf der einen ist Windows 10 Professional und auf der anderen, wie oben bereits beschrieben, Debian 10 Buster installiert.

Da ich ein Programm benötigte, welches nur für Windows erhältlich ist, startete ich einfach über den Manager nicht Debian, sondern Windows. Als ich den PC jedoch das nächste mal versuchte mit Debian zu starten, wurde ich nicht aus dem schwarzen Ladescreen zum Betriebssystem (also zum "Log-In Feld") weitergeleitet.

Ich habe den PC fast eine Woche lang angelassen, allerdings hat sich bis auf zwei Ausgaben nicht viel getan. Ich habe nun schnell mit meinem Handy ein Foto von der ersten Zeile und von den letzten zwei Ausgaben gemacht, bevor ich meinen PC "hart" ausgeschalten habe. Ich weiß, dass es nicht sehr "gesund" für den PC ist, hatte in dem Moment aber leider keine andere Wahl. Beide Fotos folgen jetzt:

Oberer Zeile des Startprozesses:
Bild

Unterste Zeile:
Bild

Bitte entschuldigen Sie die schlechte Bildqualität, aber es musste wirklich schnell gehen.

Ich bin wirklich verzweifelt, da ich bereits wichtige Dateien auf diesem PC gesichert habe. Es wäre ideal, wenn ich den Fehler irgendwie beheben könnte oder zumindest die Dateien sichern kann. Von Windows kann man ja nicht auf Linux zugreifen. Leider fehlt mir selbst noch die Erfahrung und das Wissen, um das Problem selbst zu lösen und hoffe wirklich inständig auf Ihre Unterstützung. Ich bin wirklich dankbar für jede Antwort.
Mit freundlichen Grüßen
Simon F.

TomL
Beiträge: 4532
Registriert: 24.07.2014 10:56:59

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von TomL » 07.11.2019 21:35:33

Das ist jetzt kein ganz so triviales Problem... wir wollen ja auch nicht noch mehr kaputt machen. Und ich weiss auch nicht, ob mein Vorgehen erfolgreich, aber es ist ein Anfang. Mach jetzt bitte folgendes.... (und bitte aufmerksam lesen und die Schritte exakt ausführen):
  1. Der Rechner sollte vor dem nächsten Start zuerst mit einem Patchkabel idealerweise direkt mit dem Router verbunden sein
  2. Wenn der Start nach einem Reboot wieder bei den Logmeldungen hängt, drückst Du nach kurzer Wartezeit -wenn sich wirklich nix mehr rührt- als gleichzeitige Tasten-Kombination "strg-alt-f2"
  3. Du solltest nun einen schwarzen Anmeldebildschirm bekommen. Wenn nix passiert, versuch einmal "strg-alt-f3", wenn wieder nix kommt, sorry, dann wars das schon für mich... dann bleibt es nur auf eine Live-Version zurückzugreifen
  4. Wenn ein schwarzer Anmeldebildschirm kommt, gibt Du als Anmeldename "root" ein und nach Enter das Passwort und erneut Enter. Bei der Password-Eingabe erfolgt keine Ausgabe.
  5. Wenn die Anmeldung erfolgreich war, gibts Du nacheinander die beiden folgenden Befehle ein... und achtest auf Fehlermeldungen. Passieren gravierende Fehlermeldungen, dann einmal abfotografieren, hier posten und erst mal abbrechen.
Ohne Fehlermeldungen;

Code: Alles auswählen

apt update
apt full-uprade
Als letztes gibst Du die beiden folgenden Befehle ein:

Code: Alles auswählen

journalctl -b -p err
journalctl -b | grep -i firmware
Mach von jeder Ausgabe der letzten 2 Befehle jeweils ein Foto und wieder hier posten.... möglicherweise kommen wir damit in die Lage, das Problem lösen zu können.
vg, Thomas

Benutzeravatar
hikaru
Beiträge: 10723
Registriert: 09.04.2008 12:48:59

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von hikaru » 07.11.2019 22:05:33

In der ersten Zeile des ersten Bildes wird vergeblich versucht, die Firmware i915/glk_dmc_ver1_04.bin zu laden. Diese wird auf Gemini-Lake-CPUs benötigt um die Grafik (mit Beschleunigung?) zu nutzen. Als Ergebnis des fehlgeschlagenen Ladeversuchs wird zwar noch der Displaymanager (Debiangdm3 laut drittletzter Zeile des zweiten Bildes) gestartet aber er kann ohne die Firmware kein Bild anzeigen. Gnome (und möglicherweie schon GDM) braucht zwingend Grafikbeschleunigung.

Die Firmware befindet sich im Paket Debianfirmware-misc-nonfree. Nachdem du dich nach TomLs Anleitung auf einer Textkonsole angemeldet hast, übrerprüfe bitte, ob das Paket installiert ist:

Code: Alles auswählen

$ dpkg -l | grep firmware-linux
ii  firmware-linux-free                   3.4                               all          Binary firmware for various drivers in the Linux kernel
Ich brauche das Paket nicht, daher fehlt es in meiner Ausgabe und nur Debianfirmware-linux-free ist hier zu sehen, weil dieses auf meinem System installiert ist. Bei dir sollte zusätzlich noch eine Zeile für das nonfree-Paket zu sehen sein.
Ist das nicht der Fall, dann installiere es bitte und reboote den Rechner:

Code: Alles auswählen

# apt install firmware-linux-nonfree
Sollte das Paket bereits installiert sein aber deine Grafik trotzdem nicht gehen, dann brauchen wir genauere Infos zur Hardware (genaues CPU-Modell, möglicherweise auch Rechnermodell, falls es sich z.B. um ein Notebook handelt).
Seltsam ist, dass laut deiner Aussage, die Grafik unter Debian offenbar schon mal ging:
simonf hat geschrieben: ↑ zum Beitrag ↑
07.11.2019 20:41:26
Die Installation von Debian 10 Buster ist weitgehend ohne Probleme verlaufen und konnte das System vorerst auch fehlerfrei nutzen.
Die sonstigen Meldungen (auch die Markierten) stehen einem erfolgreichen Rechnerstart nicht im Wege, sondern könnten höchstens später beim Thema Netzwerk interessant werden.

simonf
Beiträge: 17
Registriert: 07.11.2019 19:50:21

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von simonf » 08.11.2019 18:35:15

Danke für Ihre Unterstützung. Bin gerade dabei, Ihre Anweisungen zu befolgen. Ich melde mich mit den Screenshots wieder, falls es Probleme geben sollte.
Mit freundlichen Grüßen
Simon F.

simonf
Beiträge: 17
Registriert: 07.11.2019 19:50:21

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von simonf » 08.11.2019 19:34:06

hikaru hat geschrieben: ↑ zum Beitrag ↑
07.11.2019 22:05:33
In der ersten Zeile des ersten Bildes wird vergeblich versucht, die Firmware i915/glk_dmc_ver1_04.bin zu laden. Diese wird auf Gemini-Lake-CPUs benötigt um die Grafik (mit Beschleunigung?) zu nutzen. Als Ergebnis des fehlgeschlagenen Ladeversuchs wird zwar noch der Displaymanager (Debiangdm3 laut drittletzter Zeile des zweiten Bildes) gestartet aber er kann ohne die Firmware kein Bild anzeigen. Gnome (und möglicherweie schon GDM) braucht zwingend Grafikbeschleunigung.

Die Firmware befindet sich im Paket Debianfirmware-misc-nonfree. Nachdem du dich nach TomLs Anleitung auf einer Textkonsole angemeldet hast, übrerprüfe bitte, ob das Paket installiert ist:

Code: Alles auswählen

$ dpkg -l | grep firmware-linux
ii  firmware-linux-free                   3.4                               all          Binary firmware for various drivers in the Linux kernel
Ich brauche das Paket nicht, daher fehlt es in meiner Ausgabe und nur Debianfirmware-linux-free ist hier zu sehen, weil dieses auf meinem System installiert ist. Bei dir sollte zusätzlich noch eine Zeile für das nonfree-Paket zu sehen sein.
Ist das nicht der Fall, dann installiere es bitte und reboote den Rechner:

Code: Alles auswählen

# apt install firmware-linux-nonfree
Sollte das Paket bereits installiert sein aber deine Grafik trotzdem nicht gehen, dann brauchen wir genauere Infos zur Hardware (genaues CPU-Modell, möglicherweise auch Rechnermodell, falls es sich z.B. um ein Notebook handelt).
Seltsam ist, dass laut deiner Aussage, die Grafik unter Debian offenbar schon mal ging:
simonf hat geschrieben: ↑ zum Beitrag ↑
07.11.2019 20:41:26
Die Installation von Debian 10 Buster ist weitgehend ohne Probleme verlaufen und konnte das System vorerst auch fehlerfrei nutzen.
Die sonstigen Meldungen (auch die Markierten) stehen einem erfolgreichen Rechnerstart nicht im Wege, sondern könnten höchstens später beim Thema Netzwerk interessant werden.
--------------------------------------------------------------------------

Erstmals noch kurz zur Erklärung: Gemeinsam mit einem Freund habe ich erst Debian 9 installiert und direkt im Anschluss direkt ein Upgrade zu Debian 10 gemacht. Der Fehler ist wie gesagt komischerweise erst dann aufgetreten, nachdem ich einmal Windows gestartet habe.

Nun zu den Screenshots:

Zuerst traten bei dem Update, sowie dem Upgrade Befehl einige Fehler auf, die vielleicht für die Situation keine Bedeutung haben:
Bild
Bild

Danach führte ich den "journalct1 -b -p err" Befehl aus:
Bild

Anschließend den "journalctl | grep -i firmware" Befehl:
Bild

Und zuletzt den "dpkg -l | grep firmware-linux" Befehl:
Bild

Zudem habe ich noch diese beiden Ausgaben (journalctl -b | grep -i firmware????) //bin mir nicht mehr sicher, welcher Befehl das war:
Bild
Bild
Zuletzt geändert von simonf am 08.11.2019 19:59:17, insgesamt 1-mal geändert.
Mit freundlichen Grüßen
Simon F.

TomL
Beiträge: 4532
Registriert: 24.07.2014 10:56:59

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von TomL » 08.11.2019 19:40:25

War der Rechner über ein Patchkabel mit dem Router verbunden? Ist überhaupt eine Internetverbindung vorhanden? Wie ist die Ausgabe der beiden folgenden Befehle in der Konsole:

Code: Alles auswählen

cat /etc/apt/sources.list
ip a
vg, Thomas

simonf
Beiträge: 17
Registriert: 07.11.2019 19:50:21

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von simonf » 08.11.2019 19:44:03

Eine Internetverbindung sollte stehen. Ist mit einem Patchkabel ein LAN-Kabel gemeint?
Screenshots folgen sofort.
Mit freundlichen Grüßen
Simon F.

dingsvomdach
Beiträge: 6
Registriert: 06.10.2019 08:27:38

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von dingsvomdach » 08.11.2019 19:51:10

Starte von einem Live-System (freie Auswahl unter https://cdimage.debian.org/debian-cd/cu ... so-hybrid/). Damit kannst du dann deine wichtigsten Daten auf einen USB-Stick kopieren (eigentlich können die ja gar nicht wichtig sein, sonst hättest du eine Sicherung...).

Danach kannst du per chroot-Methode ins installierte System wechseln und wie bereits vorgeschlagen fehlende Firmware-Pakete nachinstallieren.

Chroot-Anleitung: https://wiki.ubuntuusers.de/chroot/Live-CD/

Benutzeravatar
willy4711
Beiträge: 2326
Registriert: 08.09.2018 16:51:16

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von willy4711 » 08.11.2019 19:54:25

Den Ausgaben zufolge (die ersten beiden), hattest du keine Internetverbindung.
gib mal zuallererst nach Eingabe des Root- PW

Code: Alles auswählen

dhclient 
ein.
Im Rettungsmodus oder worin auch immer du dich befindest, wird meist erstmal keine Verbindung hergestellt.
Wenn das System irgendeine funktionierende Netzwerkhardware erkannt hat, stellt es dann die Verbindung her.

simonf
Beiträge: 17
Registriert: 07.11.2019 19:50:21

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von simonf » 08.11.2019 19:56:10

TomL hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 19:40:25
War der Rechner über ein Patchkabel mit dem Router verbunden? Ist überhaupt eine Internetverbindung vorhanden? Wie ist die Ausgabe der beiden folgenden Befehle in der Konsole:

Code: Alles auswählen

cat /etc/apt/sources.list
ip a
----------------------------------------------------------------------------

Danke für Eure Unterstützung,

der Grund, dass ich für die Dateien kein Backup habe ist, dass diese eine Größe von fast 400GB haben :? . Das sind bereits sämtliche Schul,- Backup, und- Videodateien.

Hier noch die geforderten Screenshots:
Bild
Bild
Zuletzt geändert von simonf am 08.11.2019 20:00:03, insgesamt 1-mal geändert.
Mit freundlichen Grüßen
Simon F.

simonf
Beiträge: 17
Registriert: 07.11.2019 19:50:21

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von simonf » 08.11.2019 19:58:14

willy4711 hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 19:54:25
Den Ausgaben zufolge (die ersten beiden), hattest du keine Internetverbindung.
gib mal zuallererst nach Eingabe des Root- PW

Code: Alles auswählen

dhclient 
ein.
Im Rettungsmodus oder worin auch immer du dich befindest, wird meist erstmal keine Verbindung hergestellt.
Wenn das System irgendeine funktionierende Netzwerkhardware erkannt hat, stellt es dann die Verbindung her.
Also da steht: wlo1: link is not ready (bei IPv6)

Heißt das, dass ich keine Verbindung habe?
Mit freundlichen Grüßen
Simon F.

Benutzeravatar
willy4711
Beiträge: 2326
Registriert: 08.09.2018 16:51:16

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von willy4711 » 08.11.2019 20:04:06

Ich finde es nicht produktiv, einem Neuling irgend etwas von chroot zu erzählen.
Wie die anderen schon sagten:
Besorge dir eine LIVE-CD von hier.
http://cdimage.debian.org/cdimage/unoff ... so-hybrid/
Vorher kannst du ja erstmal versuchen , was empfohlen wurde und die Firmware installieren.

Dann hast du Zugriff auf deine Debian - Partitionen und kannst das Benötigte sichern.
Und dann noch mal von vorne mit der Live-CD.

Benutzeravatar
willy4711
Beiträge: 2326
Registriert: 08.09.2018 16:51:16

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von willy4711 » 08.11.2019 20:04:50

simonf hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 19:58:14
Also da steht: wlo1: link is not ready (bei IPv6)

Heißt das, dass ich keine Verbindung habe?
Jupp, stand aber schon in dem ersten Bildchen. (Fehlschlag beim holen....)

simonf
Beiträge: 17
Registriert: 07.11.2019 19:50:21

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von simonf » 08.11.2019 20:11:02

willy4711 hat geschrieben: ↑ zum Beitrag ↑
08.11.2019 20:04:06
Ich finde es nicht produktiv, einem Neuling irgend etwas von chroot zu erzählen.
Wie die anderen schon sagten:
Besorge dir eine LIVE-CD von hier.
http://cdimage.debian.org/cdimage/unoff ... so-hybrid/
Vorher kannst du ja erstmal versuchen , was empfohlen wurde und die Firmware installieren.

Dann hast du Zugriff auf deine Debian - Partitionen und kannst das Benötigte sichern.
Und dann noch mal von vorne mit der Live-CD.
Bin schon dabei, die ISO zu downloaden. Wäre trotzdem schön, wenn sich das Problem lösen ließe. Bin ja auch bestrebt, etwas Neues zu lernen.
Mit freundlichen Grüßen
Simon F.

Benutzeravatar
willy4711
Beiträge: 2326
Registriert: 08.09.2018 16:51:16

Re: Debian 10 startet nicht mehr / bleibt im Startprozess hängen

Beitrag von willy4711 » 08.11.2019 20:15:21

hab doch gesagt.
nach Root-PW

Code: Alles auswählen

dhclient
und dann erstmal

Code: Alles auswählen

apt update && apt full-upgrade
Neustart
wenn er wieder auf der Konsole landet
die Firmware installieren, wie von hikaru vorgeschlagen.
Wenn es klappt ---> freu :D
Wenn nicht---> melden

Edit:

Sollte dann so aussehen (dhclient):
2355

Antworten