pvcreate: Kommando nicht gefunden.

Warum Debian? Was muss ich vorher wissen? Wo geht's nach der Installation weiter?
Antworten
Benutzeravatar
TilmannW
Beiträge: 43
Registriert: 04.02.2020 23:05:02

pvcreate: Kommando nicht gefunden.

Beitrag von TilmannW » 26.02.2020 15:14:22

Hallo,
ich möchte gern XEN in Buster installieren, dazu heißt es, man solle LVM2 installieren und dann ein virtuelles Laufwerk erzeugen mit "pvcreate /dev/sda4". Leider bekomme ich danach die Fehlermeldung "pvcreate: Kommando nicht gefunden."
pvcreate scheint ja wohl ein LVM2-Befehl zu sein, also habe ich überprüft, ob LVM2 auch installiert ist mit "dpkg-query -s lvm2".

In der Ausgabe hieß es u.a.:
"Package: lvm2
Status: install ok installed"

Jetzt weiß ich nicht weiter. Bin halt Debian-Anfänger ...

Benutzeravatar
hikaru
Beiträge: 10959
Registriert: 09.04.2008 12:48:59

Re: pvcreate: Kommando nicht gefunden.

Beitrag von hikaru » 26.02.2020 15:18:46

Meine Glaskugel sagt mir, dass du so zu root geworden bist: Hilfreicher ist es, wenn du es so machst:

Benutzeravatar
TilmannW
Beiträge: 43
Registriert: 04.02.2020 23:05:02

Re: pvcreate: Kommando nicht gefunden.

Beitrag von TilmannW » 26.02.2020 21:21:13

Warum, und wo ist der Unterschied ?

Benutzeravatar
TilmannW
Beiträge: 43
Registriert: 04.02.2020 23:05:02

Re: pvcreate: Kommando nicht gefunden.

Beitrag von TilmannW » 26.02.2020 21:31:55

Übrigens bekomme ich jetzt eine andere Fehlermeldung zu "pvcreate /dev/sda4":
Nicht mehr "pvcreate: Kommando nicht gefunden." sondern "Device /dev/sda4 not found."

Wobei ich nicht verstehe was er von mir will, ich dachte er soll unter "/dev" das virtuelle Laufwerk "sda4" anlegen.

Xen ist wohl eine Nummer zu hoch für Anfänger.

Benutzeravatar
smutbert
Beiträge: 6923
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: pvcreate: Kommando nicht gefunden.

Beitrag von smutbert » 26.02.2020 21:49:02

Zum ersten Problem (Kommando nicht gefunden.):
su (ohne Option und ohne Bindestrich) fügt zu $PATH nicht (/usr)/sbin hinzu. Priogramme, die typischerweise vor allem für den Systemverwalter/root interessant liegen aber dort und werden dann nicht gefunden, wenn man nicht explizit den Pfad angibt (/sbin/pvcreate). Das ist erst seit buster so und was genau sich geändert hat, wie man wieder das Verhalten zurückbekommt und viele weitere Interessante Details findest du in dutzenden Thread hier im Forum und auch in der Dokumentation von Debian.


Darüber hinaus und das ist das neue Problem (Device /dev/sda4 not found.) dürfte hier ein Mißverständnis vorliegen worin der Zweck von pvreate besteht.
Mit pvcreate schreibst du Metainformationen auf ein Blockgeräte, typischerweise eine Partition wie eben zum Beispiel /dev/sda4, damit dieses Blockgerät dann im Logical Volume Management als „physical Volume“ zur Verfügung steht. Existiert /dev/sda4 kannst du aber natürlich auch nichts damit machen und es gibt nur die Fehlermeldung dass das Gerät nicht existiert.

ren22
Beiträge: 599
Registriert: 26.11.2006 09:05:14

Re: pvcreate: Kommando nicht gefunden.

Beitrag von ren22 » 02.03.2020 19:13:53

TilmannW hat geschrieben: ↑ zum Beitrag ↑
26.02.2020 21:31:55
Übrigens bekomme ich jetzt eine andere Fehlermeldung zu "pvcreate /dev/sda4":
Nicht mehr "pvcreate: Kommando nicht gefunden." sondern "Device /dev/sda4 not found."

Wobei ich nicht verstehe was er von mir will, ich dachte er soll unter "/dev" das virtuelle Laufwerk "sda4" anlegen.

Xen ist wohl eine Nummer zu hoch für Anfänger.
Naja,, sagen wir mal so: XEN kann man eigentlich gut als "Deckel" betrachten, also was oben drauf liegt und alles andere darunter ist die Basis. Ich meine damit das XEN nur LVM benutzt, wenn Du lvm benutzen möchtest, also das Problem liegt dann bei LVM nicht bei XEN, alternativ kannst Du auch mit Festplatten-Images arbeiten, so hatte ich damals mit XEN begonnen zu arbeiten, läuft eigentlich ganz perfomant mit images, mit lvm holt man natürlich das letzte ein Perfomance dann noch vom Dateisystem bzw, Hardware heraus oder alternativ mit echten partitionen. Ich pers. kann XEN nur empfehlen, wenn man sich mal eingearbeitet hat möchte man eigentlich nichts anderes mehr benutzen für Virtualisierung. Empfehlen kann ich dir das Anleitung für LVM. weitere XEN Anleitungen (engl.)

Grüsse

Antworten