Debian 9 problem mit "nsd" Dienst

Warum Debian? Was muss ich vorher wissen? Wo geht's nach der Installation weiter?
Antworten
mazlum23
Beiträge: 5
Registriert: 03.03.2020 14:13:57

Debian 9 problem mit "nsd" Dienst

Beitrag von mazlum23 » 03.03.2020 14:30:51

Hallo zusammen,

ich hab momentan leider folgendes Problem.
Ich habe 3 Debian 9 VM, auf denen ich in letzter Zeit immer mehr Performance Probleme hatte.
Jetzt habe ich festgestellt, dass der "nsd" Dienst bei allen läuft und am meisten Ressourcen beansprucht.
Ich hab aber nie nsd-pakete installiert. Wenn ich versuche das nsd zu löschen, kriege ich nur die Antwort kann nicht gelöscht werden, da keine Pakete installiert sind.
Ich bin echt am verzweifeln, wie ich das Ding wegbekommen kann. Der Dienst startet sich auch nach dem abschießen nach einer Weile wieder neu..

Danke + Viele Grüße
Mazlum

MSfree
Beiträge: 5557
Registriert: 25.09.2007 19:59:30

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von MSfree » 03.03.2020 14:47:43

Code: Alles auswählen

apt-get purge nsd
?

mazlum23
Beiträge: 5
Registriert: 03.03.2020 14:13:57

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von mazlum23 » 04.03.2020 15:28:46

Hi MSfree,

danke für die Antwort, ich kriege diese Meldung...
Bild

Viele Grüße
Mazlum

MSfree
Beiträge: 5557
Registriert: 25.09.2007 19:59:30

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von MSfree » 04.03.2020 15:34:56

mazlum23 hat geschrieben: ↑ zum Beitrag ↑
04.03.2020 15:28:46
Bild
Gibt es das auch als Text?

mazlum23
Beiträge: 5
Registriert: 03.03.2020 14:13:57

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von mazlum23 » 05.03.2020 15:19:29

Hi MSfree,

klar: Paketlisten werden gelesen.... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.. Fertig
Paket <<nsd>>ist nicht installiert, wird also auch nicht entfernt.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 488 nicht aktualisiert.

LG
Mazlum

MSfree
Beiträge: 5557
Registriert: 25.09.2007 19:59:30

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von MSfree » 05.03.2020 15:46:04

mazlum23 hat geschrieben: ↑ zum Beitrag ↑
05.03.2020 15:19:29
Paket <<nsd>>ist nicht installiert, wird also auch nicht entfernt.
Wie soll ein nicht installiertes Programm dann Resourcen auf deinem Rechner verbrauchen?

Hast du auch auf den VMs geschaut, ob dort nsd installiert ist?

mazlum23
Beiträge: 5
Registriert: 03.03.2020 14:13:57

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von mazlum23 » 06.03.2020 07:59:18

Ja das weiß ich leider auch nicht..
Ich habe bestimmt 14 VM nur mit Debian auf HyperV und auf 2 Vms habe ich das Problem, er frisst trotz nicht installiertem nsd unmengen an Ressourcen für nsd....

pferdefreund
Beiträge: 3657
Registriert: 26.02.2009 14:35:56

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von pferdefreund » 06.03.2020 08:14:18

da würde ich als erstes mal nachschauen, ob das Programm überhaupt vorhanden ist oder ob da die Anzeige im Taskmanager oder was auch immer nur was falsches anzeigt. Übliche Kandidaten sind /usr/bin, /usr/sbin /bin /sbin und ggf noch was unter /usr/local oder /opt.
Es gibt da ja so addons für VMs wie die Vmware-Tools. Ist da sowas installiert ?
Ich würde mal mit ps versuchen, die Prozess-ID zu ermitteln und dann unter /proc/prozessid nachschauen, was da wirklich so läuft.

mazlum23
Beiträge: 5
Registriert: 03.03.2020 14:13:57

Re: Debian 9 problem mit "nsd" Dienst

Beitrag von mazlum23 » 09.03.2020 10:31:53

Hi @pferdefreund,

danke dir. Hab nun den Übeltäter gefunden.
Es ist unsere Syncjob Software. Mir hat unter anderem auch "ps -ef" geholfen.

VIele Grüße

Antworten