wire messenger auf debian 9 installieren?

Du suchst ein Programm für einen bestimmten Zweck?
Antworten
funkto
Beiträge: 14
Registriert: 16.01.2017 21:47:01

wire messenger auf debian 9 installieren?

Beitrag von funkto » 08.11.2018 17:35:26

debian 9 64bit main
https://wire.com/en/

In readme steht
Prerequisites
Node.js
Git
Python 2.x

git clone https://github.com/wireapp/wire-desktop.git
cd wire-desktop
npm install

git und python installiert. Node nicht in synaptic package manager. Npm auch nicht.
I will nur wire installieren wenn es mit
git clone https://github.com/wireapp/wire-desktop.git
und in synaptic package manager vorhanden pakete geht.

Kann ich wire installieren? Danke.

rendegast
Beiträge: 15038
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: wire messenger auf debian 9 installieren?

Beitrag von rendegast » 10.11.2018 11:39:30

https://packages.debian.org/nodejs
4.8 in stretch (virtuell resp. provides nodejs-abi-46), 8.11 in stretch-backports (virtuell resp. provides nodejs-abi-57)


Code: Alles auswählen

apt-cache search node | sort | grep -i node

apt-cache search npm | sort

"npm-install" in Dateinamen:
https://packages.debian.org/file:npm-install ->
https://packages.debian.org/search?mode ... pm-install



In aptitude kann gut verfolgt werden, was auf zBsp. nodejs referenziert.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

funkto
Beiträge: 14
Registriert: 16.01.2017 21:47:01

Re: wire messenger auf debian 9 installieren?

Beitrag von funkto » 22.12.2018 19:54:26

Danke.

Hier reicht mein Wissen nicht. Ist npm ein Teil von nodejs?
Ich habe mit synaptic package manager nodejs installiert.
Version 4.8.2.
Command npm install ergibt

Code: Alles auswählen

bash: npm: command not found
Auf stackoverflow habe ich gelesen man solle nodejs direkt vom provider
installieren weil version in synaptic package manager nicht neu
genug ist. Es ging nicht um wire sondern um ein anderes
Program das sich auch nicht installieren liesse.

rendegast
Beiträge: 15038
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: wire messenger auf debian 9 installieren?

Beitrag von rendegast » 23.12.2018 00:45:56

Es ginge vielleicht Paket Debiannpm 5.8 aus buster/testing.
Abhängigkeiten lassen sich nach schneller Durchsicht scheinbar mit aktivierten stretch-backports auflösen.


Mit npm wird aber am Paketsystem vorbei gearbeitet,
ähnlich 'pear upgrade' oder pearl-CPAN.
Bsp. Debiannode-gyp Debianpaket oder per 'npm install ...'.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Colttt
Beiträge: 2850
Registriert: 16.10.2008 23:25:34
Wohnort: Brandenburg
Kontaktdaten:

Re: wire messenger auf debian 9 installieren?

Beitrag von Colttt » 23.12.2018 23:07:56

Warum nicht ganz einfach aus dem debianpaket?

https://github.com/wireapp/wire-desktop ... p-on-Linux
Debian-Nutzer :D

ZABBIX Certified Specialist

Antworten