ntfs-3g buggt? E/A I/O Fehler

Du suchst ein Programm für einen bestimmten Zweck?
Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

ntfs-3g buggt? E/A I/O Fehler

Beitrag von Knogle » 11.01.2017 18:39:59

Ich gruesse euch liebe Community,

Aktuell habe ich einen Server auf Debian laufen, und ich moechte jetzt noch einige Festplatten mit NTFS as Dateisystem einbinden.

Unter Windows und Ubuntu laufen die interessanterweise super, aber sobald ich unter Debian probiere etwas von meinem EXT4 Drive auf Mein NTFS Laufwerk zu kopieren kriege ich beispielsweise folgenden Fehler:

root@DEBED04:/media/windows# cp -r /mnt/sde1/Bilder ./
cp: der Aufruf von stat für „./Bilder“ ist nicht möglich: Eingabe-/Ausgabefehler

Wie gehe ich vor?
Ich bekomme die E/A Fehler beispielsweise auch bei ls -lah etc.

Hoffe das jemand weiter weiss

MfG

scientific
Beiträge: 2701
Registriert: 03.11.2009 13:45:23
Lizenz eigener Beiträge: Artistic Lizenz
Kontaktdaten:

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von scientific » 11.01.2017 19:41:44

Was sagt dmesg?
dann putze ich hier mal nur...

Eine Auswahl meiner Skripte und systemd-units.
https://github.com/xundeenergie

auch als Debian-Repo für Testing einbindbar:
deb http://debian.xundeenergie.at/xundeenergie testing main

Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von Knogle » 11.01.2017 22:04:15

Wie mache ich das genau mit dmesg?

Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von Knogle » 11.01.2017 22:07:18

Hat geklappt
192827.830848] usb-storage 2-2:1.0: USB Mass Storage device detected
[192827.830974] usb-storage 2-2:1.0: Quirks match for vid 174c pid 55aa: 400000
[192827.831008] scsi93 : usb-storage 2-2:1.0
[192828.830070] scsi 93:0:0:0: Direct-Access ST1000LM 035-1RK172 SDM1 PQ: 0 ANSI: 5
[192828.830481] sd 93:0:0:0: Attached scsi generic sg3 type 0
[192828.830614] sd 93:0:0:0: [sdf] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[192828.830808] sd 93:0:0:0: [sdf] Write Protect is off
[192828.830812] sd 93:0:0:0: [sdf] Mode Sense: 23 00 00 00
[192828.831006] sd 93:0:0:0: [sdf] No Caching mode page found
[192828.832182] sd 93:0:0:0: [sdf] Assuming drive cache: write through
[192829.160638] sdf: sdf1 sdf2
[192829.161665] sd 93:0:0:0: [sdf] Attached SCSI disk
[192988.189259] usb 2-2: USB disconnect, device number 85
[192988.429382] usb 2-2: new SuperSpeed USB device number 86 using xhci_hcd
[192988.445861] usb 2-2: New USB device found, idVendor=174c, idProduct=55aa
[192988.445866] usb 2-2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[192988.445869] usb 2-2: Product: 012345678901234567890123456789012345678901234567
[192988.445871] usb 2-2: Manufacturer: 01234567890123456789012345678901234567890123
[192988.445874] usb 2-2: SerialNumber: 2011092012D1
[192988.446557] usb-storage 2-2:1.0: USB Mass Storage device detected
[192988.446686] usb-storage 2-2:1.0: Quirks match for vid 174c pid 55aa: 400000
[192988.446717] scsi94 : usb-storage 2-2:1.0
[192989.470447] scsi 94:0:0:0: Direct-Access ST1000LM 035-1RK172 SDM1 PQ: 0 ANSI: 5
[192989.470885] sd 94:0:0:0: Attached scsi generic sg3 type 0
[192989.471043] sd 94:0:0:0: [sdf] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[192989.471237] sd 94:0:0:0: [sdf] Write Protect is off
[192989.471241] sd 94:0:0:0: [sdf] Mode Sense: 23 00 00 00
[192989.471436] sd 94:0:0:0: [sdf] No Caching mode page found
[192989.472537] sd 94:0:0:0: [sdf] Assuming drive cache: write through
[192990.474921] sdf: sdf1 sdf2
[192990.475907] sd 94:0:0:0: [sdf] Attached SCSI disk
[192995.126664] usb 2-2: USB disconnect, device number 86
[192995.366720] usb 2-2: new SuperSpeed USB device number 87 using xhci_hcd
[192995.383253] usb 2-2: New USB device found, idVendor=174c, idProduct=55aa
[192995.383258] usb 2-2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[192995.383261] usb 2-2: Product: 012345678901234567890123456789012345678901234567
[192995.383263] usb 2-2: Manufacturer: 01234567890123456789012345678901234567890123
[192995.383266] usb 2-2: SerialNumber: 2011092012D1
[192995.383948] usb-storage 2-2:1.0: USB Mass Storage device detected
[192995.384064] usb-storage 2-2:1.0: Quirks match for vid 174c pid 55aa: 400000
[192995.384093] scsi95 : usb-storage 2-2:1.0
[192996.383160] scsi 95:0:0:0: Direct-Access ST1000LM 035-1RK172 SDM1 PQ: 0 ANSI: 5
[192996.383540] sd 95:0:0:0: Attached scsi generic sg3 type 0
[192996.383630] sd 95:0:0:0: [sdf] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[192996.383823] sd 95:0:0:0: [sdf] Write Protect is off
[192996.383827] sd 95:0:0:0: [sdf] Mode Sense: 23 00 00 00
[192996.384023] sd 95:0:0:0: [sdf] No Caching mode page found
[192996.385141] sd 95:0:0:0: [sdf] Assuming drive cache: write through
[192996.483228] sdf: sdf1 sdf2
[192996.484269] sd 95:0:0:0: [sdf] Attached SCSI disk
[259758.316910] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f20.
[259758.318112] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f21.
[259758.319223] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f22.
[259758.320337] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f23.
[259758.321411] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f24.
[259758.322477] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f25.
[259758.323517] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f26.
[259758.324540] ntfs: (device sde2): ntfs_end_buffer_async_read(): Buffer I/O error, logical block 0x605f27.
[259758.325559] ntfs: (device sde2): map_mft_record(): Failed with error code 5.
[259758.326573] ntfs: (device sde2): ntfs_read_locked_inode(): Failed with error code -5. Marking corrupt inode 0x2f92 as bad. Run chkdsk.

Benutzeravatar
sbruder
Beiträge: 325
Registriert: 24.06.2016 13:54:36
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Wallmersbach

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von sbruder » 11.01.2017 22:09:24

dmesg hat geschrieben:Run chkdsk.
Das würde ich mal probieren.

Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von Knogle » 11.01.2017 22:19:12

Habe ich mal gemacht, und auch neu formatiert, und ne andere Platte benutzt
Jetzt kommt das
root@DEBED04:/media/windows# cp -r /mnt/sde1/Bilder /media/windows
cp: das Verzeichnis „/media/windows/Bilder“ kann nicht angelegt werden: Die Operation ist nicht erlaubt
root@DEBED04:/media/windows# ^C
root@DEBED04:/media/windows# chattr -i ./windows
chattr: Datei oder Verzeichnis nicht gefunden beim Auslesen des Status von ./windows
root@DEBED04:/media/windows# cd ../
root@DEBED04:/media# ls
cdrom windows
root@DEBED04:/media# chattr -i windows
chattr: Unpassender IOCTL (I/O-Control) für das Gerät beim Lesens der Flags in windows
und dmesg
[275135.326793] usb-storage 2-1:1.0: Quirks match for vid 174c pid 55aa: 400000
[275135.326819] scsi98 : usb-storage 2-1:1.0
[275136.325804] scsi 98:0:0:0: Direct-Access ST1000LM 035-1RK172 SDM1 PQ: 0 ANSI: 5
[275136.326169] sd 98:0:0:0: Attached scsi generic sg3 type 0
[275136.326323] sd 98:0:0:0: [sdg] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[275136.326517] sd 98:0:0:0: [sdg] Write Protect is off
[275136.326521] sd 98:0:0:0: [sdg] Mode Sense: 23 00 00 00
[275136.326717] sd 98:0:0:0: [sdg] No Caching mode page found
[275136.327896] sd 98:0:0:0: [sdg] Assuming drive cache: write through
[275136.333314] sdg: sdg1
[275136.334330] sd 98:0:0:0: [sdg] Attached SCSI disk


Benutzeravatar
CH777
Beiträge: 1104
Registriert: 27.05.2008 16:37:17

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von CH777 » 12.01.2017 09:53:46

Knogle hat geschrieben:root@DEBED04:/media# chattr -i windows
chattr: Unpassender IOCTL (I/O-Control) für das Gerät beim Lesens der Flags in windows
Da chattr soweit ich weiß kein NTFS unterstützt ist das nicht weiter verwunderlich.

owl102
Beiträge: 2088
Registriert: 16.10.2010 13:05:57
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Timbuktu

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von owl102 » 12.01.2017 11:28:18


Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Beitrag von Knogle » 12.01.2017 11:48:19

Und wo finde ich einen Link zu einem funktionierenden ntfs-3g Paket? Ich finde leider irgendwie nix :/
Kann ich sonst das Ubuntu Paket draufklatschen? Oder wird das nicht klappen?

rendegast
Beiträge: 14272
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von rendegast » 12.01.2017 12:07:29

Knogle hat geschrieben: Aktuell habe ich einen Server auf Debian laufen, und ich moechte jetzt noch einige Festplatten mit NTFS as Dateisystem einbinden.

Unter Windows und Ubuntu laufen die interessanterweise super, aber sobald ich unter Debian ...
Die jeweiligen Versionen?


WinXP hat bei Zugriff auf ein früheres ntfs (unter WinNT4 erstellt) dieses modifiziert
(damit gingen keine chkdsk vom WinNT4 mehr).
Inwieweit solches Verhalten heute noch besteht?

Wenn Win10 (falls beteiligt) das "Standard-Herunterfahren" praktiziert
(für schnellen Start EDIT resp. "fast boot feature" (ab Win8)),
hinterläßt es ntfs wohl in einem generell nicht mountbaren Zustand,
eine besondere Art suspend-to-disk. ( gilt für alle Partitionen oder nur %SystemDrive% ? )
Da Mounten "unter ubuntu" funktioniert, kann das hier wohl nicht die Ursache sein.

EDIT ntfs-3g hat wohl dem obigen Bug-Link nach eine Erkennung des fast-boot-feature, Versionen später als 2012.*.
Demnach sollte die Version jessie 2014.2.15AR vor daraus resultierenden Fehlern schützen.



Nach wikipedia scheint ntfs WinXP bis Win10 unverändert.
Bis auf ab Vista mögliche, aber wohl kaum verwendete "atomare Operationen / Transaktionen".
Zuletzt geändert von rendegast am 12.01.2017 16:09:47, insgesamt 1-mal geändert.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von Knogle » 12.01.2017 12:13:23

Nutze Windows 10, Ubuntu 16.04 und Debian 8.6.0
Erstellt habe ich das NTfs einmal mit GParted und mit Windows 10. Macht aber keinen Unterschied

rendegast
Beiträge: 14272
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von rendegast » 12.01.2017 15:51:06

xenial 16.04LTS benutzt ntfs-3g 2015.3.14AR.
http://packages.ubuntu.com/ntfs-3g

Versuche es mit stretch und dessen Debianntfs-3g 2016.2.22AR.



Anm.
Ich kann scheinbar problemlos mit 2014.2.15AR (grml 2014-11) auf ntfs von WinXP und Win7 zugreifen.

ntfs-3g hat wohl dem obigen Bug-Link nach eine Erkennung des fast-boot-feature, Versionen später als 2012.*.
Demnach sollte die Version jessie 2014.2.15AR vor daraus resultierenden Fehlern schützen.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von Knogle » 12.01.2017 17:55:11

Super danke habs hingekriegt.
Ich habe kurz in der Sources.list von jessie auf testing umgestellt, mir dann ntfs-3g gezogen, und da wurde dann die 2014er Version gezogen.

Nun laeuft alles prima :D

Knogle
Beiträge: 150
Registriert: 06.05.2016 19:29:00
Lizenz eigener Beiträge: GNU General Public License

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von Knogle » 12.01.2017 18:36:31

war voreilig:

Kommen doch wieder Fehlerr

Code: Alles auswählen


root@DEBED04:/media/windows# root@DEBED04:/media/windows#
-bash: root@DEBED04:/media/windows#: Eingabe-/Ausgabefehler
root@DEBED04:/media/windows#


rendegast
Beiträge: 14272
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: ntfs-3g buggt? E/A I/O Fehler

Beitrag von rendegast » 12.01.2017 18:42:20

Knogle hat geschrieben: Unter Windows und Ubuntu laufen die interessanterweise super,
Also auch der eventvwr zeigt nichts an?

Vielleicht ist es doch ein Datenträgerfehler,
und windows / ubuntu kaschieren das besser?



Ich habe kurz in der Sources.list von jessie auf testing umgestellt, mir dann ntfs-3g gezogen, und da wurde dann die 2014er Version gezogen.
Das paßt so nicht zusammen.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Antworten