[Gelöst/Intel] Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Antworten
inne
Beiträge: 1726
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

[Gelöst/Intel] Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Beitrag von inne » 17.07.2017 12:28:40

Code: Alles auswählen

$ blender
...
Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.
Kann man da was machen? Hardware ist ein T530 mit:

Code: Alles auswählen

$ lspci | grep vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Zuletzt geändert von inne am 17.07.2017 14:27:30, insgesamt 1-mal geändert.
(=_=)

Benutzeravatar
towo
Beiträge: 2948
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Beitrag von towo » 17.07.2017 12:42:11

glxinfo | grep OpenGL

Sagt was?

inne
Beiträge: 1726
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Beitrag von inne » 17.07.2017 13:21:50

Code: Alles auswählen

$ glxinfo 
name of display: :0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  35
  Current serial number in output stream:  36
Hmm, was ist da kaputt?
(=_=)

Benutzeravatar
towo
Beiträge: 2948
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Beitrag von towo » 17.07.2017 13:26:51

Schwer zu sagen, ohne ein Xorg.0.log gesehen zu haben.

inne
Beiträge: 1726
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Beitrag von inne » 17.07.2017 13:45:18

pastebin/?mode=view&s=39908
(Hoffe das ist korrekt verlinkt)
(=_=)

Benutzeravatar
towo
Beiträge: 2948
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Beitrag von towo » 17.07.2017 13:56:29

Hm, das Xlog sieht eigentlich gut aus. Eigentlich sollte modesetting auch 3D können, aber Du könntest ja spaßhalber mal intel als X-Treiber probieren.
Dazu muß xserver-xorg-video-intel installiert sein und per

Code: Alles auswählen

 mkdir -p /etc/X11/xorg.conf.d ; echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "intel"\nEndSection' > /etc/X11/xorg.conf.d/20-intel.conf
Ein Config-Schnipsel angelegt werden.

Ich hoffe mal, alle benötigen Mesa-Libs sind installiert.

inne
Beiträge: 1726
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Error! Blender requires OpenGL 2.1 to run. Try updating your drivers.

Beitrag von inne » 17.07.2017 14:27:04

Vielen Dank towo. Damit geht es.
(=_=)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste