Stretch und vim: altes Verhalten wiederherstellen

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Antworten
dominicpratt
Beiträge: 5
Registriert: 26.02.2016 08:12:58
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Bad Kreuznach
Kontaktdaten:

Stretch und vim: altes Verhalten wiederherstellen

Beitrag von dominicpratt » 13.09.2017 09:56:19

Guten Morgen!

Ich habe meine Debian-Server inzwischen erfolgreich auf Stretch aktualisiert, alles läuft wunderbar.

Was mich aber wirklich nervt ist das neue Verhalten von vim - beim einfügen von Codeschnipseln mit Kommentarzeilen versucht er "schlau" zu sein und fügt selbstständig Kommentare hinzu, was das Ganze völlig überflüssig macht. Außerdem das Verhalten der Maus, das ich zwar inzwischen abstellen konnte.

Meine Frage daher: gibt es eine elegante Möglichkeit, dem vim wieder sein altes Verhalten beizubringen? :?

Benutzeravatar
rodney
Beiträge: 43
Registriert: 09.12.2016 04:15:59
Lizenz eigener Beiträge: MIT Lizenz

Re: Strech und vim: altes Verhalten wiederherstellen

Beitrag von rodney » 13.09.2017 16:02:45

Das ist abhaengig von der Art wie du Codeschnipsel einfuegst. Fuegst du diese von der Zwischenablage mittels Shift-Ins oder Ctrl-v ein hilft ein :set paste in vim bzw. set paste in deiner vimrc

Soll generell das automatische Kommentieren deaktiviert werden helfen die formatoptions weiter.

Detailierte Infos gibt es in der integrierten Dokumentation von vim:
  • :help paste
  • :help formatoptions
  • :help fo-table
I don't like poofy coffee... give me Columbian Supremo. --Izchak

RichardFreeman
Beiträge: 20
Registriert: 26.08.2016 15:26:21

Re: Stretch und vim: altes Verhalten wiederherstellen

Beitrag von RichardFreeman » 13.09.2017 22:10:35

Evtl. liegt es an den in Vim 8 eingeführten default settings.
Gemäß :h defaults sollst du

Code: Alles auswählen

        unlet! skip_defaults_vim
        source $VIMRUNTIME/defaults.vim
oben in deine .vimrc kopieren, um das alte Verhalten wiederherzustellen.

Edit: Okay, falsch. Um die bis Vim 7 üblichen settings beizubehalten, muss lediglich eine .vimrc existieren. Möchte man die neu eingeführten defaults trotz eigener .vimrc, muss man obige Befehle in die .vimrc schreiben...

Benutzeravatar
rodney
Beiträge: 43
Registriert: 09.12.2016 04:15:59
Lizenz eigener Beiträge: MIT Lizenz

Re: Stretch und vim: altes Verhalten wiederherstellen

Beitrag von rodney » 14.09.2017 02:26:08

Habe gerade mal die /usr/share/vim/vim80/defaults.vim durchgeschaut und die einzigen Zeilen wo etwas mit dem Einfuegen zu tun haben koennten sind die Zeilen 76-80 mit set mouse=a. Also wie RichardFreeman vorgeschlagen hat einfach eine leere vimrc anlegen und das Problem duerfte Geschichte sein.
I don't like poofy coffee... give me Columbian Supremo. --Izchak

dominicpratt
Beiträge: 5
Registriert: 26.02.2016 08:12:58
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Bad Kreuznach
Kontaktdaten:

Re: Stretch und vim: altes Verhalten wiederherstellen

Beitrag von dominicpratt » 14.09.2017 06:55:23

Tatsache, eine leere .vimrc stellt das "alte" Verhalten wieder her - danke! :hail:

Antworten