vmware-mks.xpi installieren

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Antworten
Benutzeravatar
McAldo
Moderator
Beiträge: 2020
Registriert: 26.11.2003 11:43:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Terra / Sol-System / Milchstraße

vmware-mks.xpi installieren

Beitrag von McAldo » 28.04.2009 16:36:57

Hallo,

ich versuche per Browser auf einen VMWare-Server zu verbinden, um die dort installierten virtuellen Maschinen zu verwalten. (Zwischenbemerkung: Nein, ich kann keine andere Virtuallisierung an der Stelle verwenden, da mir das so vorgegeben ist, leider!). Login klappt auch soweit, aber wenn ich dann versuche auf die Console zu kommen, werde ich aufgefordert ein Plugin zu installieren. Das wird dann gedownloaded und anschließend kommt eine Fehlermeldung:

Code: Alles auswählen

Iceweasel konnte das Add-on von folgender Adresse nicht installieren:

https://vi.domain.de/ui/plugin/mozilla/linux/vmware-mks.xpi

Grund: Installationsscript nicht gefunden
-204
Ich habe auch versucht nach diesen Anleitungen die Installation vorzunehmen:
- http://www.tu-chemnitz.de/urz/vpsh/betrieb.html
- http://kb.vmware.com/selfservice/viewCo ... &sliceId=1
mit dem selben Ergebnis - Fehler.

Den Firefox habe ich auch von Konsole aus gestartet um Fehlermeldungen zu sehen:

Code: Alles auswählen

LoadPlugin: failed to initialize shared library ~/.mozilla/plugins/libmks.so [libexpat.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden]
LoadPlugin: failed to initialize shared library ~/bin/firefox/plugins/libmks.so [libexpat.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden]
LoadPlugin: failed to initialize shared library ~/.mozilla/plugins/libmks.so [libexpat.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden]
LoadPlugin: failed to initialize shared library ~/bin/firefox/plugins/libmks.so [libexpat.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden]
Ich habe alle Pakete installiert, die libexpa* enthalten:

Code: Alles auswählen

>  dpkg -l | grep libexpa
ii  libexpat-ocaml                       0.9.1+debian1-4+b1             OCaml expat bindings
ii  libexpat1                            2.0.1-4                        XML parsing C library - runtime library
ii  libexpat1-dev                        2.0.1-4                        XML parsing C library - development kit
Eine mitgelieferte Anleitung (http://nopaste.debianforum.de/21101) zur Installation des Plugins zeigt auch, dass alles unter Linux laufen sollte.

System:
Debian/Lenny i686 Kernel 2.6.26-1
Browser: Iceweasel aus Lenny und Firefox 3.0.9 als binary von mozilla.org

McAldo

Edit:

Weitere Informationen:
- http://communities.vmware.com/docs/DOC-2671
- http://communities.vmware.com/docs/DOC-8840
Zuletzt geändert von McAldo am 28.04.2009 18:53:10, insgesamt 1-mal geändert.
Achte auf deine Gedanken, denn sie werden Worte.
Achte auf deine Worte, denn sie werden Handlungen.
Achte auf deine Handlungen, denn sie werden Gewohnheiten.
Achte auf deine Gewohnheiten, denn sie werden dein Charakter.
Achte auf deinen Charakter, denn er wird dein Schicksal.
(Talmud)

Benutzeravatar
McAldo
Moderator
Beiträge: 2020
Registriert: 26.11.2003 11:43:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Terra / Sol-System / Milchstraße

Re: vmware-mks.xpi installieren

Beitrag von McAldo » 28.04.2009 18:51:50

So, die Infos in diesem Link (http://communities.vmware.com/docs/DOC-2671) haben geholfen. Naja, eigentlich irgendwie alle Links zusammen.
Daher mal eine kurze Zusammenfassung (für 32bit Systeme mit Debian/Lenny):

Den Inhalt von der Datei vmware-mks.xpi kopiert man nach

> ~/.mozilla/firefox/hashdefault/extensions/
> ~/.mozilla/plugins/

Folgende Pakete sollten installiert werden/sein:

Code: Alles auswählen

apt-get install libexpat-ocaml libexpat1 libstdc++5 libstdc++6
Anschließend muss noch eine Verlinkung erfolgen:

Code: Alles auswählen

> ln -s /usr/lib/libexpat.so.1.5.2 /usr/lib/libexpat.so.0
> rm -f /usr/lib/libexpat.so.1
> ln -s /usr/lib/libexpat.so.0 /usr/lib/libexpat.so.1
Nun den Browser neu starten und die VMWare Console sollte funktionieren.

McAldo
Achte auf deine Gedanken, denn sie werden Worte.
Achte auf deine Worte, denn sie werden Handlungen.
Achte auf deine Handlungen, denn sie werden Gewohnheiten.
Achte auf deine Gewohnheiten, denn sie werden dein Charakter.
Achte auf deinen Charakter, denn er wird dein Schicksal.
(Talmud)

Benutzeravatar
McAldo
Moderator
Beiträge: 2020
Registriert: 26.11.2003 11:43:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Terra / Sol-System / Milchstraße

Re: vmware-mks.xpi installieren

Beitrag von McAldo » 12.07.2010 12:03:33

Nun funktioniert der Spaß nicht mehr. :(

Ich habe ein 32bit Debian/Lenny in VirtualBox installiert um eine stabile Umgebung zu haben dafür. Dort läuft iceweasel 3.0.6 und ich habe oben genannten Plugin mit den beschriebenen Schritten installiert. Per Plguin-Install ist das auch gescheitert.
Nun komm zwar, wenn man bei einer VM auf "Console" klickt eine Anzeige, die ist aber grau. Die Konsole von Firebug meldet dann:

Code: Alles auswählen

https://vi.domain.de/ui/viewCheckForUpdatesXml.do?viewIds=110393260,110393886,110393388 462ms
Das kommt nun die ganze Zeit mit unterschiedlichen Zugriffszeiten.

Jemand eine Idee, was da ist und wie ich doch noch ein Bild in der Console bekomme?

McAldo
Achte auf deine Gedanken, denn sie werden Worte.
Achte auf deine Worte, denn sie werden Handlungen.
Achte auf deine Handlungen, denn sie werden Gewohnheiten.
Achte auf deine Gewohnheiten, denn sie werden dein Charakter.
Achte auf deinen Charakter, denn er wird dein Schicksal.
(Talmud)

Antworten