VICE C64-Emulator (Debian-Squeeze)

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Antworten
spike77
Beiträge: 12
Registriert: 06.04.2012 02:07:20
Lizenz eigener Beiträge: GNU Free Documentation License

VICE C64-Emulator (Debian-Squeeze)

Beitrag von spike77 » 09.04.2012 13:17:16

Hi,

ich habe heute versucht unter Debian 6.04 Squeeze und auch unter Debian Testing das Paket für den C64-Emulator VICE (2.2) zu installieren.
Ich habe dafür ganz normal den Paketmanager genommen (Gnome hat da ja einen eigenen und unter LXDE habe ich es auch mit Synaptic versucht).
Die Installation läuft unproblematisch, allerdings lässt sich das Programm danach nicht starten. Es werden zwar noch die dazugehörigen Shortcuts für Gnome Classic erstellt, aber das wars dann auch. Die Programmdateien befinden sich allerdings korrekt an ihrem Ort.

Ich habe auch bereits im Manual nachgelesen und zudem auch die notwendigen ROMs aus der Windows-Version in die entsprechenden Verzeichnisse nachinstalliert.

Wenn ich versuche VICE zu starten, passiert über das Shortcut in der GUI gar nichts, und wenn ich es per Terminal probiere kommt nur die Meldung: "Ungültiger Maschinenbefehl".

Hat jemand ein paar Ratschläge was ich nun tun kann um VICE doch noch zum Laufen zu kriegen? Bin für jede Hilfe dankbar!

Gruß
Spike


P.S. unter Ubuntu hat es bei mir auf Anhieb funktioniert, also gehe ich mal davon aus, das ich selbst nicht das Problem in diesem Fall bin :)
panic!

spike77
Beiträge: 12
Registriert: 06.04.2012 02:07:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: VICE C64-Emulator (Debian-Squeeze)

Beitrag von spike77 » 09.04.2012 18:37:27

Okay,

nach einer kompletten Neuinstallation von Squeeze 6.0.4 funktioniert es nun doch. Da war wohl irgendein Paket kaputt.

Unter Testing (Wheezy) funktioniert es weiterhin nicht, aber das soll meine Sorge nicht sein. Hauptsache es läuft.

Gruß
spike
panic!

Cae
Moderator
Beiträge: 6328
Registriert: 17.07.2011 23:36:39
Wohnort: 2130706433

Re: VICE C64-Emulator (Debian-Squeeze)

Beitrag von Cae » 09.04.2012 20:26:45

spike77 hat geschrieben:wenn ich es per Terminal probiere kommt nur die Meldung: "Ungültiger Maschinenbefehl".
Klingt für mich jetzt nach unterschiedlicher Architektur (logisch, dafür ist es ja ein Emulator). Evtl. ist bloß beim Kopieren des ROMs etwas schiefgegangen? Nach einer Neuinstallation kann man das nicht mehr sagen… Merke: Neuinstallieren braucht man unter GNU/Linux mit so ausgereiftem Paketmanagement wie bei Debian praktisch nie.

Gruß Cae
If universal surveillance were the answer, lots of us would have moved to the former East Germany. If surveillance cameras were the answer, camera-happy London, with something like 500,000 of them at a cost of $700 million, would be the safest city on the planet.

—Bruce Schneier

spike77
Beiträge: 12
Registriert: 06.04.2012 02:07:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: VICE C64-Emulator (Debian-Squeeze)

Beitrag von spike77 » 09.04.2012 21:39:05

Aber zumindest was Debian Testing betrifft ist der Fehler ja eindeutig reproduzierbar, ich glaube daher nicht das es am Kopieren der ROMs liegt/lag.

Eine andere Sache ist es natürlich wenn ich der Einzige bin, der mit Testing kein VICE mehr mittels gewöhnlichem Paketmanager installieren kann.

Gruß
spike
panic!

Antworten