pg_hba.conf fehlt in postgresql 8.4

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Antworten
niederrheiner1
Beiträge: 2
Registriert: 14.12.2012 12:22:54

pg_hba.conf fehlt in postgresql 8.4

Beitrag von niederrheiner1 » 14.12.2012 12:58:47

Hallo an Alle,
ich möchte nach der folgenden Vorlage
http://failhack.bplaced.net/wordpress/w ... archives/7
einen OSM-Server aufbauen.

Wenn ich aber den Befehl

Code: Alles auswählen

psql -f /usr/shar/postgres/8.4/contrib/postgis-1.5/postgis.sql -d osm
ausführe, bekomme ich folgende Fehlermeldung

Code: Alles auswählen

psql: fatal: ident Authentifizierung für Benutzer  >>osm<< fehlgeschlagen
Bei der Suche im Web bin ich auf die Datei

Code: Alles auswählen

/var/lib/postgresql/8.4/main/pg_hba.conf
gestossen. Doch diese Datei existiert nicht auf meinem Rechner.
Die Installation nach der Vorlage lief bis zu dieser Zeile offenbar fehlerfrei, obwohl in der Datei

Code: Alles auswählen

/var/log/postgresql/postgresql-8.4-main.log
die Zeile

Code: Alles auswählen

unvollständiges Startpaket
steht.
Könnt Ihr mir Hinweise oder Tipps zur Lösung dieses Problems geben?

MfG
Günter

Benutzeravatar
Six
Beiträge: 8045
Registriert: 21.12.2001 13:39:28
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Siegburg

Re: pg_hba.conf fehlt in postgresql 8.4

Beitrag von Six » 14.12.2012 13:44:28

Hallo und willkommen im df.de!

Eigentlich sollte die Datei standardmäßig mitinstalliert werden. Du kannst entweder versuchen, die Installation von postgresql zu wiederholen

Code: Alles auswählen

apt-get install --reinstall postgresql
oder du guckst mal in /usr/share/doc/postgresql/examples, ob dort eine Beispieldatei rumliegt. Die kopierst du dann nach /etc/postgresql/8.4/main/ und passt sie an, wie du sie brauchst.
Be seeing you!

niederrheiner1
Beiträge: 2
Registriert: 14.12.2012 12:22:54

Re: pg_hba.conf fehlt in postgresql 8.4

Beitrag von niederrheiner1 » 14.12.2012 14:05:40

Danke für Deine Antwort.
in dem von Dir angegebenen Ordner bin ich zwar nicht fündig geworden. Aber nach einem

Code: Alles auswählen

sudo updatedb
warum habe ich erst jetzt daran gedacht ????????, bin ich im Ordner

Code: Alles auswählen

/usr/share/postgresql/8.4/
fündig geworden. Jetzt werde ich Datei mal anpassen und dann weiter sehen.
Nochmals Danke für die Hilfe.

Bis dann ...
MfG
Günter
Six hat geschrieben:Hallo und willkommen im df.de!

Eigentlich sollte die Datei standardmäßig mitinstalliert werden. Du kannst entweder versuchen, die Installation von postgresql zu wiederholen

Code: Alles auswählen

apt-get install --reinstall postgresql
oder du guckst mal in /usr/share/doc/postgresql/examples, ob dort eine Beispieldatei rumliegt. Die kopierst du dann nach /etc/postgresql/8.4/main/ und passt sie an, wie du sie brauchst.

Antworten