Thunderbird 60 - Lightning funktioniert nicht

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Benutzeravatar
Profbunny
Beiträge: 570
Registriert: 04.04.2004 11:12:29
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Bautzen

Thunderbird 60 - Lightning funktioniert nicht

Beitrag von Profbunny » 10.09.2018 11:03:17

Hey,

nach dem Update von Thunderbird zu Version 60 in Debian Sid, funktioniert bei mir der Lightning Kalender nicht mehr. Es werden überhaupt keine
Möglichkeiten angezeigt, an den Kalender zu kommen.

https://support.mozilla.org/en-US/kb/ca ... hunderbird hilft mir nicht, da es diesen Eintrag in der about:config nicht gibt.

Ein Deinstall mit anschließendem Neuinstallieren brachte auch nichts.Mehr Ideen habe ich leider nicht, einen passenden Bugreport habe ich nicht gefunden.
Jemand von euch ähnliche Schwierigkeiten mit Lightning, bzw sogar einen Lösung dazu?

danke Micha
Rechner / Server Debian sid

KP97
Beiträge: 1498
Registriert: 01.02.2013 15:07:36

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von KP97 » 10.09.2018 15:21:47

Ist denn die Version 60.0-3 passend zur Thunderbird-Version installiert?
Ein Blick nach Add-ons würde zumindest eine unpassende Version anzeigen, oder ist der Kalender nur deaktiviert?

Benutzeravatar
Profbunny
Beiträge: 570
Registriert: 04.04.2004 11:12:29
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Bautzen

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von Profbunny » 10.09.2018 15:56:07

Code: Alles auswählen

mdomann@sysiphus:~/handy/build/lineage-15.1$ dpkg -l|grep thunderbird
ii  thunderbird                                                 1:60.0-3                             amd64        mail/news client with RSS, chat and integrated spam filter support
ii  thunderbird-l10n-de                                         1:60.0-3                             all          German language package for Thunderbird
mdomann@sysiphus:~/handy/build/lineage-15.1$ dpkg -l|grep lightning  
ii  lightning                                                   1:60.0-3                             all          Calendar Extension for Thunderbird
das Addon wird als aktiviert in den Addon Manager angezeigt.
gallery/image/1853
Rechner / Server Debian sid

KP97
Beiträge: 1498
Registriert: 01.02.2013 15:07:36

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von KP97 » 10.09.2018 16:22:18

Ich nehme meine Thunderbird's immer von der Mozilla HP. Meine Version ist 60.0
https://archive.mozilla.org/pub/thunder ... ases/60.0/
und der damit kompatible Kalender ist 6.2b4
https://archive.mozilla.org/pub/calenda ... ux-x86_64/

Bild

Kannst ja mal die Version aus dem Archiv separat installieren, evtl. funktioniert das besser.

Benutzeravatar
Profbunny
Beiträge: 570
Registriert: 04.04.2004 11:12:29
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Bautzen

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von Profbunny » 10.09.2018 18:14:49

geht auch nicht, wenn ich lightning runterwerfe und seperat per xpi file installiere. Scheint nun doch ein Bug zu sein.[bug]#908494[/bug]
Rechner / Server Debian sid

KP97
Beiträge: 1498
Registriert: 01.02.2013 15:07:36

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von KP97 » 10.09.2018 20:13:20

Eine Möglichkeit kannst Du noch probieren.
Verschiebe mal die Datei e2fda1a4-.....(das ist der Kalender) von /distribution/extensions nach /extensions.
Den genauen Pfad habe ich nicht mehr im Kopf, entweder /usr/share oder /usr/lib.
Der Kalender ist ja integriert, aber in der Vergangenheit wurde mal ein falsches Verzeichnis gewählt.
Falls das auch nichts bringt, ist es wohl der Bug.

Benutzeravatar
Profbunny
Beiträge: 570
Registriert: 04.04.2004 11:12:29
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Bautzen

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von Profbunny » 11.09.2018 13:53:31

liegt schon richtig, wenn ich dein Post richtig deute:
root@sysiphus:/home/mdomann# ll /usr/lib/thunderbird/extensions
insgesamt 8,0K
lrwxrwxrwx 1 root root 24 Sep 6 18:46 {e2fda1a4-762b-4020-b5ad-a41df1933103} -> ../../../share/lightning
lrwxrwxrwx 1 root root 77 Sep 6 18:46 langpack-de@thunderbird.mozilla.org.xpi -> ../../../share/thunderbird/extensions/langpack-de@thunderbird.mozilla.org.xpi
Rechner / Server Debian sid

KP97
Beiträge: 1498
Registriert: 01.02.2013 15:07:36

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von KP97 » 11.09.2018 15:36:58

Ich habe jetzt extra auf meinem Sid-Testsystem Thunderbird und Lightning aus dem Repo installiert und Bildchen gemacht.
Hier funktioniert der Kalender wie gewünscht, sei es mit meinem Profil aus dem Arbeitssystem oder mit einem ganz neuen Profil:

Bild

Bild

Der Bug ist es dann nicht, eher scheint in Deinem System etwas im Argen zu sein.
Da hilft dann nur suchen...ein neues Profil hattest Du doch erstellt, oder?

Benutzeravatar
Profbunny
Beiträge: 570
Registriert: 04.04.2004 11:12:29
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Bautzen

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von Profbunny » 12.09.2018 21:56:50

Ein neues Profil habe ich getestet, ging auch nicht. Leider gibt keines der im debian wiki benannten Debugmöglichkeiten irgendeine Meldung aus.
Werde mal ein Downgrade versuchen
Rechner / Server Debian sid

snuggle
Beiträge: 1
Registriert: 17.09.2018 12:56:22

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von snuggle » 17.09.2018 13:29:38

Ich habe das gleiche Problem mit thunderbird 60, das jetzt in die stable gekommen ist. Eine neue Beta von Mozilla von
https://archive.mozilla.org/pub/calenda ... ux-x86_64/ hat geholfen.

M4he
Beiträge: 7
Registriert: 06.03.2016 09:40:30

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von M4he » 17.09.2018 15:07:08

Hatte eben grad auch das Problem nach einem Upgrade auf Thunderbird 60 unter Debian stable.
Bei mir hat es geholfen, das Paket "lightning-l10n-de" zu installieren, da ich auch das "*-l10n-de" für Thunderbird nutze. Danach gab es in der Toolbar wieder die Buttons für Kalender und Aufgaben.

inne
Beiträge: 2126
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von inne » 17.09.2018 15:39:33

M4he hat geschrieben: ↑ zum Beitrag ↑
17.09.2018 15:07:08
Bei mir hat es geholfen, das Paket "lightning-l10n-de" zu installieren, da ich auch das "*-l10n-de" für Thunderbird nutze.
:THX:
(=_=)

Have mercy!

Lookbehind
Beiträge: 104
Registriert: 12.08.2011 18:09:13

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von Lookbehind » 17.09.2018 21:33:52

Kleiner Zusatz von mir, weil ich mich damit heute auch 2 Stunden rum geärgert habe.

Bei mir war der Trick thunderbird-l10n-de und lightning-l10n-de erst mit apt purge zu deinstallieren, dann den Thunderbird einmal zu starten und den Kalender einmal auf englisch öffnen, Thunderbird wieder schließen und die beiden Pakete wieder installieren. Danach gabs dann Thunderbird und Lightning auch wieder auf deutsch.
Nur lightning-l10n-de deinstallieren und wieder installieren hat bei mir nicht geholfen.

snowy
Beiträge: 79
Registriert: 12.12.2017 22:32:52

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von snowy » 17.09.2018 23:53:22

@inne, @lookbehind,

bin ich froh, daß Ihr etwas zeitlichen Vorsprung und schon die Lösung ausgearbeitet habt :THX: :hail:
Auch bei mir mußten zuerst die deutschen Pakete mit purge deinstalliert werden.

tijuca
Beiträge: 50
Registriert: 22.06.2017 22:12:20

Re: Thunderbird 60 - Lightning funktioniert nicht

Beitrag von tijuca » 18.09.2018 11:43:05

Mit Verlaub, das kann nicht die Ursache für eine voll umfängliche Funktion sein.

Wenn ein Update installiert wird werden zunächst alle alten Pakete deinstalliert, und dpkg erkennt wenn jemand in diesen Verzeichnissen etwas verändert hat was die Paketstruktur angeht, steht dann auch in der Konsole wenn man das Update dort anstösst. Das puren ist daher genau genommen unnötig da das Gleiche auch bei einem Update automatisch durch apt-dpkg ausgeführt wird.

Was das eigentlich Problem angeht, man muss beide zugehörigen l10n Pakete der jeweiligen Sprache installieren da die Paket sich gegenseitig ergänzen und nun wohl auch Abhängigkeiten zueinander haben. Mozilla macht es sich da einfacher, dort ist man der Meinung, dass jeder Nutzer sich doch bitte direkt die lokalisierte Version herunter laden soll. Es gibt auch nur noch diese Variante dort zum Download. Dabei wird irgendwie verkannt, dass es auch Systeme gibt an denen Benutzer mit verschiedenen Sprachen arbeiten können und müssen. In Debian schon immer so gelöst, dass die startenden Programme die Variable LANG auslesen und intern den Inhalt der Variable benutzen um die UI in der richtigen Sprache anzuzeigen.

Mit Version 60 (genau genommen mit Version 58) hat sich der Mechanismus wie die System Locale ausgelesen wird etwas geändert, auch wird jetzt eine andere Preference Variable dazu benutzt. Ergebnis ist das Gleiche, Thunderbird weiss was der Benutzer für einen Sprache benutzt und will diese Sprache auch intern setzen. Nur hakt das jetzt wohl wenn nicht alle zugehörigen übersetzen Variablen in der erkannten Sprache vorhanden sind.

Entweder wir bauen jetzt nur noch ein zugehöriges Sprachpaket oder wir müssen uns überlegen ob man dies mit Depends erschlagen könnte. Wobei ich schon Bugreports vor mir sehe das Benutzer zwangsmäßig lightning-l10n-foo installiert bekommen ...

Antworten