apt upgrade

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Antworten
junitiv
Beiträge: 18
Registriert: 11.03.2018 12:59:49

apt upgrade

Beitrag von junitiv » 23.04.2021 20:11:25

Hallo,
ich wollte den Befehl:

Code: Alles auswählen

apt-get upgrade
ausführen.

Leider bekomme ich diesen Fehler:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libpam-systemd : Depends: systemd-sysv but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or spec
fy a solution).
Selbstverständlich habe ich dann

Code: Alles auswählen

apt --fix-broken install
ausgeführt
The following additional packages will be installed:
systemd-sysv
The following NEW packages will be installed:
systemd-sysv
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 0 B/100 kB of archives.
After this operation, 128 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 57997 files and directories currently installed.)
Preparing to unpack .../systemd-sysv_241-7~deb10u7_amd64.deb ...
Unpacking systemd-sysv (241-7~deb10u7) ...
dpkg: error processing archive /var/cache/apt/archives/systemd-sysv_241-7~deb10u7_amd64.deb (--unpack):
trying to overwrite '/usr/share/man/man8/halt.8.gz', which is also in package sysvinit 2.88dsf-41+deb7u1
Errors were encountered while processing:
/var/cache/apt/archives/systemd-sysv_241-7~deb10u7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Hat jemand eine Lösung?

Gruß André

cronoik
Beiträge: 2037
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: apt upgrade

Beitrag von cronoik » 23.04.2021 20:16:58

Zeig mal bitte:

Code: Alles auswählen

apt policy
Hilf mit unser Wiki zu verbessern!

junitiv
Beiträge: 18
Registriert: 11.03.2018 12:59:49

Re: apt upgrade

Beitrag von junitiv » 23.04.2021 20:23:02

Hier die Ausgabe:
Package files:
100 /var/lib/dpkg/status
release a=now
500 https://deb.nodesource.com/node_15.x buster/main amd64 Packages
release o=Node Source,n=buster,l=Node Source,c=main,b=amd64
origin deb.nodesource.com
500 http://ftp.de.debian.org/debian-security stable/updates/main amd64 Packages
release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
origin ftp.de.debian.org
500 http://ftp.de.debian.org/debian stable/contrib amd64 Packages
release v=10.9,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
origin ftp.de.debian.org
500 http://ftp.de.debian.org/debian stable/main amd64 Packages
release v=10.9,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
origin ftp.de.debian.org
Pinned packages:

Benutzeravatar
TRex
Moderator
Beiträge: 6882
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: apt upgrade

Beitrag von TRex » 23.04.2021 20:35:08

Wo hast du das denn her? sysvinit 2.88dsf-41+deb7u1
Die Antwort hierauf gibt hoffentlich

apt-cache policy sysvinit
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

junitiv
Beiträge: 18
Registriert: 11.03.2018 12:59:49

Re: apt upgrade

Beitrag von junitiv » 23.04.2021 20:39:28

Code: Alles auswählen

sysvinit:
  Installed: 2.88dsf-41+deb7u1
  Candidate: 2.88dsf-41+deb7u1
  Version table:
 *** 2.88dsf-41+deb7u1 100
        100 /var/lib/dpkg/status

Benutzeravatar
TRex
Moderator
Beiträge: 6882
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: apt upgrade

Beitrag von TRex » 23.04.2021 22:40:34

Das solltest du löschen können. Das ist ein Relikt, was nicht deinstalliert wurde. Hatte schon befürchtet, dass die node-Installation das irgendwie mitbringt.
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

Antworten