[erledigt] Open VPN TUN nicht sichtbar, keine Verbindung

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

[erledigt] Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 16.07.2017 22:42:14

Hallo zusammen.
Server ist ein Debian Jessie, auf dem OpenVPN-Server laufen soll. Eingerichtet nach dieser Anleitung:
https://www.df.eu/de/support/df-faq/clo ... an-ubuntu/

Eine Verbindung vom client (Android) auf den Server bricht mit Fehler 111 ab.
Auf dem Server wird mir das tun-device nicht angezeigt, obwohl unter /dev/net ein tun existiert.
Die br0 ist von einer KVM-Maschine auf demselben Rechner.

Code: Alles auswählen

root@ptLWL01:~# ifconfig
br0       Link encap:Ethernet  Hardware Adresse 3c:4a:92:77:ad:43  
          inet Adresse:192.168.178.2  Bcast:192.168.178.255  Maske:255.255.255.0
          inet6-Adresse: fe80::3e4a:92ff:fe77:ad43/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:4649 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3604 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:428508 (418.4 KiB)  TX bytes:2558713 (2.4 MiB)

eth0      Link encap:Ethernet  Hardware Adresse 3c:4a:92:77:ad:43  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:4997 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4088 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:601337 (587.2 KiB)  TX bytes:2608109 (2.4 MiB)
          Interrupt:18 

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0                                                                                                                                                                                             
          RX bytes:960 (960.0 B)  TX bytes:960 (960.0 B)                                                                                                                                                                                       
                                                                                                                                                                                                                                               
root@ptLWL01:~#   
Die server.conf:

Code: Alles auswählen

port 1194

proto udp

;dev tap
dev tun

ca /etc/openvpn/easy-rsa/keys/ca.crt
cert /etc/openvpn/easy-rsa/keys/++++++++++++++.myfritz.net.crt
key /etc/openvpn/easy-rsa/keys/++++++++++++++.net.key  # This file should be kept secret

dh dh2048.pem

server 192.168.178.0 255.255.255.0

ifconfig-pool-persist ipp.txt

comp-lzo

user nobody
group nogroup

persist-key
persist-tun

status openvpn-status.log

verb 3
1194 ist in der firewall freigeschaltet und im vorliegenden Router durchgereicht.

Der Server selbst startet ohe Fehlermeldung:

Code: Alles auswählen

root@ptLWL01:~# service openvpn restart
root@ptLWL01:~# service openvpn status
● openvpn.service - OpenVPN service
   Loaded: loaded (/lib/systemd/system/openvpn.service; enabled)
   Active: active (exited) since So 2017-07-16 22:43:13 CEST; 59s ago
  Process: 3569 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 3569 (code=exited, status=0/SUCCESS)

Jul 16 22:43:13 ptLWL01 systemd[1]: Started OpenVPN service.
root@ptLWL01:~# 

Was kann das Problem sein und wie löse ich es?
Zuletzt geändert von letzter3 am 20.07.2017 14:27:53, insgesamt 2-mal geändert.

Benutzeravatar
catdog2
Beiträge: 5339
Registriert: 24.06.2006 16:50:03
Lizenz eigener Beiträge: MIT Lizenz

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von catdog2 » 17.07.2017 04:36:39

Code: Alles auswählen

  Process: 3569 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
/bin/true tut genau das Richtige ;)

Du willst openvpn@.service, also für deine /etc/openvpn/server.conf musst du openvpn@server.service starten.
Unix is user-friendly; it's just picky about who its friends are.

MSfree
Beiträge: 2626
Registriert: 25.09.2007 19:59:30

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von MSfree » 17.07.2017 08:03:29

catdog2 hat geschrieben: ↑ zum Beitrag ↑
17.07.2017 04:36:39
Du willst openvpn@.service, also für deine /etc/openvpn/server.conf musst du openvpn@server.service starten.
Eigentlich sollte es reichen, die .conf-Datei für OpenVPN in der Datei /etc/default/openvpn einzutragen.
z.B.:

Code: Alles auswählen

AUTOSTART="server"
STATUSREFRESH=10

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 20:03:28

doppelpost mit nachfolgenden 2 Beiträgen
Zuletzt geändert von letzter3 am 18.07.2017 22:41:27, insgesamt 1-mal geändert.

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 20:06:14

Da ist aber noch ne ziemlich kurze Längenbeschränkung für Beiträge in der Datenbank :-/

Daher in 2 Teilen:
catdog2 hat geschrieben: ↑ zum Beitrag ↑
17.07.2017 04:36:39

Code: Alles auswählen

  Process: 3569 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
/bin/true tut genau das Richtige ;)

Du willst openvpn@.service, also für deine /etc/openvpn/server.conf musst du openvpn@server.service starten.
mpf.

Code: Alles auswählen

root@ptLWL01:~# service openvpn stop 

Code: Alles auswählen

root@ptLWL01:~# systemctl status openvpn@server.service
● openvpn@server.service - OpenVPN connection to server
   Loaded: loaded (/lib/systemd/system/openvpn@.service; disabled)
   Active: failed (Result: exit-code) since Di 2017-07-18 19:45:54 CEST; 1min 14s ago
  Process: 6873 ExecStart=/usr/sbin/openvpn --daemon ovpn-%i --status /run/openvpn/%i.status 10 --cd /etc/openvpn --config /etc/openvpn/%i.conf (code=exited, status=1/FAILURE)

Jul 18 19:45:54 ptLWL01 systemd[1]: openvpn@server.service: control process exited, code=exited status=1
Jul 18 19:45:54 ptLWL01 systemd[1]: Failed to start OpenVPN connection to server.
Jul 18 19:45:54 ptLWL01 systemd[1]: Unit openvpn@server.service entered failed state.

Code: Alles auswählen

root@ptLWL01:~# systemctl start openvpn@server.service
Job for openvpn@server.service failed. See 'systemctl status openvpn@server.service' and 'journalctl -xn' for details.

Code: Alles auswählen

root@ptLWL01:~# systemctl daemon-reload

Code: Alles auswählen

root@ptLWL01:~# systemctl list-units

...
● firestarter.service                                                                       loaded failed failed    LSB: Start firewall
 ...
● openvpn@server.service                                                                    loaded failed failed    OpenVPN connection to server
....

Code: Alles auswählen

root@ptLWL01:~# journalctl -xn
-- Logs begin at So 2017-07-16 21:44:18 CEST, end at Di 2017-07-18 19:54:37 CEST. --
Jul 18 19:54:32 ptLWL01 sshd[6969]: pam_unix(sshd:auth): check pass; user unknown
Jul 18 19:54:34 ptLWL01 sshd[6969]: Failed password for invalid user identd from 46.140.157.157 port 25609 ssh2
Jul 18 19:54:34 ptLWL01 sshd[6969]: Connection closed by 46.140.157.157 [preauth]
Jul 18 19:54:34 ptLWL01 sshd[6969]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=46.140.157.157
Jul 18 19:54:37 ptLWL01 systemd[1]: Starting OpenVPN connection to server...
-- Subject: Unit openvpn@server.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit openvpn@server.service has begun starting up.
Jul 18 19:54:37 ptLWL01 ovpn-server[6974]: Options error: --server directive network/netmask combination is invalid
Jul 18 19:54:37 ptLWL01 ovpn-server[6974]: Use --help for more information.
Jul 18 19:54:37 ptLWL01 systemd[1]: openvpn@server.service: control process exited, code=exited status=1
Jul 18 19:54:37 ptLWL01 systemd[1]: Failed to start OpenVPN connection to server.
-- Subject: Unit openvpn@server.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit openvpn@server.service has failed.
-- 
-- The result is failed.
Jul 18 19:54:37 ptLWL01 systemd[1]: Unit openvpn@server.service entered failed state.
root@ptLWL01:~# 

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 20:07:01

Da ist aber noch ne ziemlich kurze Längenbeschränkung für Beiträge in der Datenbank :-/

Daher in 2 Teilen:
catdog2 hat geschrieben: ↑ zum Beitrag ↑
17.07.2017 04:36:39

Code: Alles auswählen

  Process: 3569 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
/bin/true tut genau das Richtige ;)

Du willst openvpn@.service, also für deine /etc/openvpn/server.conf musst du openvpn@server.service starten.
mpf.

Code: Alles auswählen

root@ptLWL01:~# service openvpn stop 

Code: Alles auswählen

root@ptLWL01:~# systemctl status openvpn@server.service
● openvpn@server.service - OpenVPN connection to server
   Loaded: loaded (/lib/systemd/system/openvpn@.service; disabled)
   Active: failed (Result: exit-code) since Di 2017-07-18 19:45:54 CEST; 1min 14s ago
  Process: 6873 ExecStart=/usr/sbin/openvpn --daemon ovpn-%i --status /run/openvpn/%i.status 10 --cd /etc/openvpn --config /etc/openvpn/%i.conf (code=exited, status=1/FAILURE)

Jul 18 19:45:54 ptLWL01 systemd[1]: openvpn@server.service: control process exited, code=exited status=1
Jul 18 19:45:54 ptLWL01 systemd[1]: Failed to start OpenVPN connection to server.
Jul 18 19:45:54 ptLWL01 systemd[1]: Unit openvpn@server.service entered failed state.

Code: Alles auswählen

root@ptLWL01:~# systemctl start openvpn@server.service
Job for openvpn@server.service failed. See 'systemctl status openvpn@server.service' and 'journalctl -xn' for details.

Code: Alles auswählen

root@ptLWL01:~# systemctl daemon-reload

Code: Alles auswählen

root@ptLWL01:~# systemctl list-units

...
● firestarter.service                                                                       loaded failed failed    LSB: Start firewall
 ...
● openvpn@server.service                                                                    loaded failed failed    OpenVPN connection to server
....

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 20:07:49

Code: Alles auswählen

root@ptLWL01:~# journalctl -xn
-- Logs begin at So 2017-07-16 21:44:18 CEST, end at Di 2017-07-18 19:54:37 CEST. --
Jul 18 19:54:32 ptLWL01 sshd[6969]: pam_unix(sshd:auth): check pass; user unknown
Jul 18 19:54:34 ptLWL01 sshd[6969]: Failed password for invalid user identd from 46.140.157.157 port 25609 ssh2
Jul 18 19:54:34 ptLWL01 sshd[6969]: Connection closed by 46.140.157.157 [preauth]
Jul 18 19:54:34 ptLWL01 sshd[6969]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=46.140.157.157
Jul 18 19:54:37 ptLWL01 systemd[1]: Starting OpenVPN connection to server...
-- Subject: Unit openvpn@server.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit openvpn@server.service has begun starting up.
Jul 18 19:54:37 ptLWL01 ovpn-server[6974]: Options error: --server directive network/netmask combination is invalid
Jul 18 19:54:37 ptLWL01 ovpn-server[6974]: Use --help for more information.
Jul 18 19:54:37 ptLWL01 systemd[1]: openvpn@server.service: control process exited, code=exited status=1
Jul 18 19:54:37 ptLWL01 systemd[1]: Failed to start OpenVPN connection to server.
-- Subject: Unit openvpn@server.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit openvpn@server.service has failed.
-- 
-- The result is failed.
Jul 18 19:54:37 ptLWL01 systemd[1]: Unit openvpn@server.service entered failed state.
root@ptLWL01:~# 

Code: Alles auswählen

root@ptLWL01:~# cat /etc/openvpn/server.conf
#################################################
# Sample OpenVPN 2.0 config file for            #
port 1194
proto udp
;dev tap
dev tun
ca /etc/openvpn/easy-rsa/keys/ca.crt
cert /etc/openvpn/easy-rsa/keys/++++++++++++++.myfritz.net.crt
key /etc/openvpn/easy-rsa/keys/++++++++++++++.myfritz.net.key  # This file should be kept secret
dh dh2048.pem
server 192.168.178.2 255.255.255.0
ifconfig-pool-persist ipp.txt
keepalive 10 120
comp-lzo
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
verb 3
1:~# 

Code: Alles auswählen

root@ptLWL01:~# ifconfig
br0       Link encap:Ethernet  Hardware Adresse 3c:4a:92:77:ad:43  
          inet Adresse:192.168.178.2  Bcast:192.168.178.255  Maske:255.255.255.0
          inet6-Adresse: fe80::3e4a:92ff:fe77:ad43/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:1051221 errors:0 dropped:0 overruns:0 frame:0
          TX packets:608676 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:63834183 (60.8 MiB)  TX bytes:1592664600 (1.4 GiB)

eth0      Link encap:Ethernet  Hardware Adresse 3c:4a:92:77:ad:43  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:1067896 errors:0 dropped:100 overruns:0 frame:0
          TX packets:1117849 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:87869633 (83.7 MiB)  TX bytes:1629912876 (1.5 GiB)
          Interrupt:18 

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX packets:1443 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1443 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:449832 (439.2 KiB)  TX bytes:449832 (439.2 KiB)

root@ptLWL01:~# 
Zuletzt geändert von letzter3 am 18.07.2017 22:39:58, insgesamt 1-mal geändert.

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 20:09:19

ääääh, nu hat das Forum doch noch den 1. Teil akzeptiert, obwohl Fehlermeldung?????

inne
Beiträge: 1803
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von inne » 18.07.2017 20:49:42

Jul 18 19:54:37 ptLWL01 ovpn-server[6974]: Options error: --server directive network/netmask combination is invalid

Im ersten Post hast du es noch richtig.
(=_=)

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 22:32:11

Okay, vielen Dank!
das zurück ändern in 192.168.178.0 und die Pfadangabe zum dh-Schlüssel haben noch gefehlt.
Der Verbindungsaufbau funktioniert jetzt.

Code: Alles auswählen

Jul 18 22:20:29 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 TLS: Initial packet from [AF_INET]31.18.32.188:44885, sid=37052abc 8329bde3
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 VERIFY OK: depth=1, C=DE, ST=MV, L=LUDWIGSLUST, O=PHYSIO-SCHUETT, OU=MyOrganizationalUnit, CN=PHYSIO-SCHUETT CA, name=EasyRSA, emailAddress=k*******-lulu.de
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 VERIFY OK: depth=0, C=DE, ST=MV, L=LUDWIGSLUST, O=PHYSIO-SCHUETT, OU=MyOrganizationalUnit, CN=++++++++++++++.myfritz.net, name=EasyRSA, emailAddress=k*******-lulu.de
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: 31.18.32.188:44885 [++++++++++++++.myfritz.net] Peer Connection Initiated with [AF_INET]31.18.32.188:44885
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: SCHLÜSSEL/31.18.32.188:44885 MULTI_sva: pool returned IPv4=192.168.178.6, IPv6=(Not enabled)
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: SCHLÜSSEL/31.18.32.188:44885 MULTI: Learn: 192.168.178.6 -> ++++++++++++++.myfritz.net/31.18.32.188:44885
Jul 18 22:20:45 ptLWL01 ovpn-server[7532]: SCHLÜSSEL/31.18.32.188:44885 MULTI: primary virtual IP for ++++++++++++++.myfritz.net/31.18.32.188:44885: 192.168.178.6
Jul 18 22:20:46 ptLWL01 ovpn-server[7532]: SCHLÜSSEL/31.18.32.188:44885 PUSH: Received control message: 'PUSH_REQUEST'
Jul 18 22:20:46 ptLWL01 ovpn-server[7532]: SCHLÜSSEL/31.18.32.188:44885 send_push_reply(): safe_cap=940
Jul 18 22:20:46 ptLWL01 ovpn-server[7532]: SCHLÜSSEL/31.18.32.188:44885 SENT CONTROL [++++++++++++++.myfritz.net]: 'PUSH_REPLY,route 192.168.178.1,topology net30,ping 10,ping-restart 120,ifconfig 192.168.178.6 192.168.178.5' (status=1)
Dummerweise bekomme ich trotzdem keinen Zugriff auf die auf dem dort lfd. Webserver liegenden Daten. Dieser wird mit IP angesprochen, also http://192.168.178.2/.......
Ich kann mir da keinen Reim drauf machen....
Ich kriege eine netzinterne IP und das hat in der Vergangenheit (mittels Fritz!Box-VPN auf die Fritz!Box) immer ausgereicht und funktioniert.

Hat da jemand noch einen Schupser für mich?
Zuletzt geändert von letzter3 am 18.07.2017 22:51:18, insgesamt 1-mal geändert.

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 22:35:51

Nachtrag: die client-Konfigurationsdatei sieht so aus:

Code: Alles auswählen

client
dev tun
proto udp
remote ++++++++++++++.myfritz.net 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert ++++++++++++++.myfritz.net.crt
key ++++++++++++++.myfritz.net.key
ns-cert-type server
comp-lzo
verb 3

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 18.07.2017 23:00:00

Und noch ein Nachtrag:

Code: Alles auswählen

br0       Link encap:Ethernet  Hardware Adresse 3c:4a:92:77:ad:43  
          inet Adresse:192.168.178.2  Bcast:192.168.178.255  Maske:255.255.255.0
          inet6-Adresse: fe80::3e4a:92ff:fe77:ad43/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:1055022 errors:0 dropped:0 overruns:0 frame:0
          TX packets:611528 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:64535088 (61.5 MiB)  TX bytes:1593390700 (1.4 GiB)

eth0      Link encap:Ethernet  Hardware Adresse 3c:4a:92:77:ad:43  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:1072688 errors:0 dropped:100 overruns:0 frame:0
          TX packets:1120781 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:88932225 (84.8 MiB)  TX bytes:1630660342 (1.5 GiB)
          Interrupt:18 

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX packets:1855 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1855 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:476573 (465.4 KiB)  TX bytes:476573 (465.4 KiB)

tun0      Link encap:UNSPEC  Hardware Adresse 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet Adresse:192.168.178.1  P-z-P:192.168.178.2  Maske:255.255.255.255                                                                                                                                                               
          UP PUNKTZUPUNKT RUNNING NOARP MULTICAST  MTU:1500  Metrik:1                                                                                                                                                                          
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                                                                                                                                                                                   
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                                                                                                                                                                                                                                                                                                            
          Kollisionen:0 Sendewarteschlangenlänge:100                                                                                                                                                                                                                                                                                                                      
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                                                                                                                                                                                                                                                                                                                          
                                                                                                                                                                                                                                                                                                                                                                          
root@ptLWL01:~#                        

Code: Alles auswählen

root@ptLWL01:~# route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.178.1   0.0.0.0         UG    0      0        0 br0
192.168.178.0   0.0.0.0         255.255.255.0   U     0      0        0 br0
192.168.178.2   0.0.0.0         255.255.255.255 UH    0      0        0 tun0
root@ptLWL01:~# 
tun0 hat jetzt die 192.168.178.1, das ist eigentlich meine Fritz!Box. :?

inne
Beiträge: 1803
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von inne » 19.07.2017 09:46:47

Läuft der ovpn-server auf dem selben Host wie der Webserver?
letzter3 hat geschrieben: ↑ zum Beitrag ↑
18.07.2017 23:00:00
tun0 hat jetzt die 192.168.178.1, das ist eigentlich meine Fritz!Box. :?
Du hast bei OpenVPN mehrere Möglichkeiten.
Es sollte aber ausreichen, wenn du ein eigenes Netz für das VPN nimmst: server 192.168.10.1 255.255.255.0. Da hat der ovpn-server dann die Adresse .1.
letzter3 hat geschrieben: ↑ zum Beitrag ↑
18.07.2017 22:32:11
Ich kriege eine netzinterne IP und das hat in der Vergangenheit (mittels Fritz!Box-VPN auf die Fritz!Box) immer ausgereicht und funktioniert.
Kenne ich nicht.
Vielleicht lief das Fritz!Box-VPN, analog zur OpenVPN-Direktive server-bridge? Du bekommst aber auch via der Direktive server bzw. Routing (TUN) Zugriff auf das LAN, wenn du das willst.
https://wiki.ubuntuusers.de/OpenVPN/#LA ... s-Internet
https://wiki.ubuntuusers.de/OpenVPN/#LA ... inbeziehen

https://www.thomas-krenn.com/de/wiki/Op ... munikation
(=_=)

letzter3
Beiträge: 258
Registriert: 16.07.2011 22:07:31

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von letzter3 » 19.07.2017 10:23:58

inne hat geschrieben: ↑ zum Beitrag ↑
19.07.2017 09:46:47
Läuft der ovpn-server auf dem selben Host wie der Webserver?
Ja. Auch nicht virtualisiert, sondern direkt,
inne hat geschrieben: ↑ zum Beitrag ↑
19.07.2017 09:46:47
Du hast bei VPN mehrere Möglichkeiten.
Es sollte aber ausreichen, wenn du ein eigenes Netz für das VPN nimmst: server 192.168.10.1 255.255.255.0. Da hat der ovpn-server dann die Adresse .1.
Für mein Verständnis:
Für lokale und netzinterne Anwendungen bleibt die IP bei 192.168.178.2. "Klassisch" auf eth0, in meinem Fall auf br0, welcher dann auf eth0 weiterleitet.

Bei Zugriffen per OpenVPN bekommt das externe Gerät eine IP aus dem 192.168.10-er Netz, muss dann aber irgendwie noch das 192.168.178er finden.
Dieses "irgendwie" erledigt dann die zusätzliche Zeile

Code: Alles auswählen

push "route 192.168.178.0 255.255.255.0"
. Und solange ich die PCs per IP anspreche, muss ich auch keinen DNS angeben.
Soweit korrekt?
Ziemlich umständlich.....

Reicht es nicht aus, dem tun0 eine andere IP aus dem 192.168.178-er zu verpassen?
Wie kommt es überhaupt dazu, sich die 192.168.178.1 zu krallen? Ziemlich frech!
Oder verstehe ich das falsch?

Michael

inne
Beiträge: 1803
Registriert: 25.06.2013 15:45:12
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: Open VPN TUN nicht sichtbar, keine Verbindung

Beitrag von inne » 19.07.2017 10:36:30

letzter3 hat geschrieben: ↑ zum Beitrag ↑
19.07.2017 10:23:58
inne hat geschrieben: ↑ zum Beitrag ↑
19.07.2017 09:46:47
Läuft der ovpn-server auf dem selben Host wie der Webserver?
Ja. Auch nicht virtualisiert, sondern direkt,
Na einfacher und unkomplizierter geht es ja nicht :-) Achte nur darauf, dass der Webserver auch an den richtigen Adressen gebunden (bind) ist.
Bei Zugriffen per OpenVPN bekommt das externe Gerät eine IP aus dem 192.168.10-er Netz, muss dann aber irgendwie noch das 192.168.178er finden
Das Geräte ist dann halt in zwei Netzen unterwegs. Das ist eigentlich recht unproblematisch.
Reicht es nicht aus, dem tun0 eine andere IP aus dem 192.168.178-er zu verpassen?
Das dürfte so nicht funktionieren... Du musst hier mit einem eigenen Netz arbeiten.
Wie kommt es überhaupt dazu, sich die 192.168.178.1 zu krallen? Ziemlich frech!
Oder verstehe ich das falsch?

Michael
Na du hast es so konfiguriert ;-)
(=_=)

Antworten