[GELÖST]Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
Tommy82
Beiträge: 27
Registriert: 07.01.2018 16:56:25

[GELÖST]Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von Tommy82 » 09.01.2018 21:14:28

Hi,
also ich habe dieses Image https://www.armbian.com/cubietruck/ mit dem mainlaine Kernel auf meinem Cubietruck installiert, soweit klappt auch erstmal alles, allerdings wird weder der Cubietruck als Gerät in der Windows Netzwerkumgebung angezeigt, noch kann ich auf die Samba Freigabe die ich eingerichtet habe zugreifen.
Die /etc/samba/smb.conf hab ich so eingestellt:

Code: Alles auswählen

[global]
   workgroup = WORKGROUP
   public = yes
   guest ok = yes
   map to guest = bad user
   guest account = nobody
   wins support = yes

[Downloads]
   path = /home/fhem/Downloads
   guest ok = yes
   writeable = yes
   browseable = yes
   public = yes

Einer eine idee was ich falsch gemacht habe?

Danke
Zuletzt geändert von Tommy82 am 14.01.2018 12:34:22, insgesamt 1-mal geändert.

Benutzeravatar
smutbert
Beiträge: 5963
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von smutbert » 09.01.2018 22:51:14

Mit Samba kenne ich mich nicht aus, aber ich hatte ein sehr interessantes und vielleicht ähnliches WLAN-Problem mit dem Cubietruck. Schuld war das aktivierte Powersaving des WLAN-Controllers. Ich weiß nicht ob das bei armbian auch auftritt oder nur bei debian - was sagt denn

Code: Alles auswählen

# iw dev wlan0 get power_save

Tommy82
Beiträge: 27
Registriert: 07.01.2018 16:56:25

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von Tommy82 » 10.01.2018 05:59:55

Hi, dann bekomme ich diese Antwort

Code: Alles auswählen

iw dev wlan0 get power_save
Power save: on
Ich kann mich noch dran erinnern das ich damals beim ersten inbetriebnehemen auch irgendein Problem mit dem Wlan hatte und da ich das eh nicht nutze hab ich es dann deaktiviert, weiss nur leider nicht mehr wie ich es deaktivieren kann

schwedenmann
Beiträge: 3848
Registriert: 30.12.2004 15:31:07
Wohnort: Wegberg

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von schwedenmann » 10.01.2018 08:10:23

Hallo


letzter Abschnitt
https://forum.ubuntuusers.de/topic/powe ... ff-stelle/


Ansonsten sollte das auch gehen, wenn man ein kleines Script für das entsprechende Modul schreibt (dort eben powersave deaktiveren) und dann das Script.conf z.B. in /etc/modprobe.d reinkopiert.

mfg
schwedenmann

Benutzeravatar
smutbert
Beiträge: 5963
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von smutbert » 10.01.2018 11:19:48

Etwas entscheidendes hab ich vergessen: Nutzt du überhaupt das WLAN? (Wenn nicht, muss die Ursache natürlich woanders liegen.)

Wenn ja: Das hier war mein Thread zu dem Problem: viewtopic.php?f=30&t=167946
edit: ich habe meine Lösung in den verlinkten Thread verschoben, weil sie hier ohnehin nicht weiterhilft
Zuletzt geändert von smutbert am 10.01.2018 12:55:49, insgesamt 1-mal geändert.

Tommy82
Beiträge: 27
Registriert: 07.01.2018 16:56:25

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von Tommy82 » 10.01.2018 12:25:18

Nein nutze kein wlan, von daher kann das nicht das Problem sein


Gesendet von iPhone mit Tapatalk

Tommy82
Beiträge: 27
Registriert: 07.01.2018 16:56:25

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von Tommy82 » 10.01.2018 20:21:00

Ich habe Wlan auf dem Cubie mal deaktiviert, allerdings keine änderung, gibt es bei den Images irgendetwas ähnliches wie unter Windows die Netzwerkerkennung die man aktivieren muss? Ansonsten kann es eigentlich nur an meiner samba config liegen, da ich ansonsten ohne Probleme (Putty, Filezilla etc.) auf den Cubie komme

Benutzeravatar
DynaBlaster
Beiträge: 933
Registriert: 25.03.2004 18:18:57
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: DF0://dynablaster.adf

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von DynaBlaster » 10.01.2018 21:00:54

Ich glaube, die Option browseable solltest du in browsable ändern (https://www.samba.org/samba/docs/using_samba/ch07.html)

Ausserdem mal schauen, ob der Samba-Server-Prozess gestartet ist und welche Ports geöffnet sind

Code: Alles auswählen

netstat -tulpen
Und mal unabhängig davon, das dein Share nicht in der Netzwerkumgebung auftaucht. Kannst du denn über \\IP.Adresse.des.Cubi\Downloads auf das Share zugreifen? Zumindest müsste dann immerhin ein Login-Prompt auf dem Windows-Rechner, von dem aus du zugreifst, erscheinen.

Tommy82
Beiträge: 27
Registriert: 07.01.2018 16:56:25

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von Tommy82 » 12.01.2018 21:36:23

DynaBlaster hat geschrieben: ↑ zum Beitrag ↑
10.01.2018 21:00:54
Ich glaube, die Option browseable solltest du in browsable ändern (https://www.samba.org/samba/docs/using_samba/ch07.html)

Ausserdem mal schauen, ob der Samba-Server-Prozess gestartet ist und welche Ports geöffnet sind

Code: Alles auswählen

netstat -tulpen
Und mal unabhängig davon, das dein Share nicht in der Netzwerkumgebung auftaucht. Kannst du denn über \\IP.Adresse.des.Cubi\Downloads auf das Share zugreifen? Zumindest müsste dann immerhin ein Login-Prompt auf dem Windows-Rechner, von dem aus du zugreifst, erscheinen.

Hi, hier die gewünschte Ausgabe

Code: Alles auswählen

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode      PID/Program name
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      0          22218      1214/smbd
tcp        0      0 0.0.0.0:9981            0.0.0.0:*               LISTEN      0          19296      709/tvheadend
tcp        0      0 0.0.0.0:9982            0.0.0.0:*               LISTEN      0          19299      709/tvheadend
tcp        0      0 0.0.0.0:7072            0.0.0.0:*               LISTEN      1000       20907      876/perl
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      110        22582      868/mysqld
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      0          22219      1214/smbd
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      0          16790      481/rpcbind
tcp        0      0 0.0.0.0:8083            0.0.0.0:*               LISTEN      1000       20973      876/perl
tcp        0      0 0.0.0.0:8084            0.0.0.0:*               LISTEN      1000       22578      876/perl
tcp        0      0 0.0.0.0:8085            0.0.0.0:*               LISTEN      1000       22579      876/perl
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          22364      701/sshd
tcp        0      0 0.0.0.0:8090            0.0.0.0:*               LISTEN      1000       24791      876/perl
tcp6       0      0 :::445                  :::*                    LISTEN      0          22216      1214/smbd
tcp6       0      0 :::139                  :::*                    LISTEN      0          22217      1214/smbd
tcp6       0      0 :::111                  :::*                    LISTEN      0          16793      481/rpcbind
tcp6       0      0 :::80                   :::*                    LISTEN      0          20556      792/apache2
tcp6       0      0 :::22                   :::*                    LISTEN      0          22366      701/sshd
udp        0      0 239.255.255.250:1900    0.0.0.0:*                           111        20500      709/tvheadend
udp        0      0 0.0.0.0:68              0.0.0.0:*                           0          17199      1299/dhclient
udp        0      0 0.0.0.0:111             0.0.0.0:*                           0          16786      481/rpcbind
udp        0      0 192.168.188.47:123      0.0.0.0:*                           0          22838      1287/ntpd
udp        0      0 127.0.0.1:123           0.0.0.0:*                           0          22836      1287/ntpd
udp        0      0 0.0.0.0:123             0.0.0.0:*                           0          22831      1287/ntpd
udp        0      0 192.168.188.255:137     0.0.0.0:*                           0          23358      1203/nmbd
udp        0      0 192.168.188.47:137      0.0.0.0:*                           0          23357      1203/nmbd
udp        0      0 0.0.0.0:137             0.0.0.0:*                           0          22610      1203/nmbd
udp        0      0 192.168.188.255:138     0.0.0.0:*                           0          23360      1203/nmbd
udp        0      0 192.168.188.47:138      0.0.0.0:*                           0          23359      1203/nmbd
udp        0      0 0.0.0.0:138             0.0.0.0:*                           0          22611      1203/nmbd
udp        0      0 0.0.0.0:657             0.0.0.0:*                           0          16789      481/rpcbind
udp        0      0 0.0.0.0:60572           0.0.0.0:*                           111        20503      709/tvheadend
udp        0      0 0.0.0.0:10000           0.0.0.0:*                           0          26304      2033/oscam.armel
udp6       0      0 :::111                  :::*                                0          16791      481/rpcbind
udp6       0      0 fe80::45:5ff:fec1:4:123 :::*                                0          22842      1287/ntpd
udp6       0      0 ::1:123                 :::*                                0          22840      1287/ntpd
udp6       0      0 :::123                  :::*                                0          22828      1287/ntpd
udp6       0      0 :::657                  :::*                                0          16792      481/rpcbind
Ich komme auch über \\IP.Adresse.des.Cubi\Downloads nicht auf die Freigabe , wird nichts gefunden

Tommy82
Beiträge: 27
Registriert: 07.01.2018 16:56:25

Re: Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von Tommy82 » 14.01.2018 12:34:05

Ok, fehler gefunden, das Problem liegt nicht am Cubie oder an Samba, sondern an meinem Win10 Laptop.
Denn alle meine anderen Rechner (Win10 PC, OpenSuse etc.) finden die Freigabe und können auch zugreifen.

Danke für eure Hilfe

MSfree
Beiträge: 2833
Registriert: 25.09.2007 19:59:30

Re: [GELÖST]Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von MSfree » 14.01.2018 12:46:54

Bei Win10 wurden die SMB-Protokollversionen 1 und 2 von Microsoft aus Sicherheitsgründen deaktiviert. Du kannst also jetzt entweder unter Win10 in der Registry hacken und die Protokollversion 2 wieder aktivieren. Du kannst aber auch in der smb.conf einen Eintrag

Code: Alles auswählen

server max protocol = SMB3
Einfügen und den Dienst neustarten.

Tommy82
Beiträge: 27
Registriert: 07.01.2018 16:56:25

Re: [GELÖST]Cubie wird nicht im Windows Netzwerk angezeigt, auch die Samba Freigabe nicht

Beitrag von Tommy82 » 14.01.2018 14:07:34

Also SMB2 ist bei meinem Win10 noch aktiv

Code: Alles auswählen

 Get-SmbServerConfiguration | Select EnableSMB2Protocol

EnableSMB2Protocol
------------------
              True
SMB1 ist deaktiviert, aber das soll auch so sein.

Also das dürfte es eher nicht sein, der Win10 Laptop findet ja garkeine Netzwerkgeräte mehr, auch keine anderen Windows Rechner/Server mehr

Antworten