systemd-networkd, Erreichbarkeit der Rechner im Netz

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
TomL
Beiträge: 3706
Registriert: 24.07.2014 10:56:59

Re: systemd-networkd, Erreichbarkeit der Rechner im Netz

Beitrag von TomL » 13.03.2018 16:04:05

halo44 hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 15:58:44
Wenn das heissen soll, daß die Dienste wpa_supplicant und wpa_supplicant@wlp7s0 disabled sein sollen, so ist das schon bei mir der Fall. Oder muß ich da etwas anderes unternehmen?
Keine Ahnung... ich weiss nicht, wie Du das eingerichtet hast, dass das WLAN-NIC bei Systemstart automatisch geöffnet wird und ein Connect-Versuch unternommen wird.... genau diese Schritte würde ich testweise wieder zurücknehmen... eben damit es nicht automatisch gestartet wird.
vg, Thomas

halo44
Beiträge: 413
Registriert: 12.05.2015 15:19:13

Re: systemd-networkd, Erreichbarkeit der Rechner im Netz

Beitrag von halo44 » 13.03.2018 16:23:09

TomL hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 16:04:05
... ich weiss nicht, wie Du das eingerichtet hast, dass das WLAN-NIC bei Systemstart automatisch geöffnet wird ...
Anscheinend belässt Debian den Status des WLAN-NIC bei dem, der beim letzten Shutdown/Reboot aktuell war.

Schalte ich das WLAN-NIC aus:

Code: Alles auswählen

iwconfig wlp7s0 txpower off
dann ist es beim nächsten Systemstart abgeschaltet und die beiden Rechner erreichen einander mittels systemd-networkd über LAN-Kabel. Das ist im Grunde, was ich erreichen will.

Ich werde also den Zustand des NIC, der sich leider über Fn+F3 auf meinem Notebook fast nie umstellen lässt, künftig über o.a. Befehl in einem Skript steuern, welches auch die erforderlichen Dienste schaltet.

Danke an alle Helfer.

Gruss H.
Debian Stretch-64 KDE (Desktop)
Debian Stretch-64 KDE (Notebook)
Kanotix64 (auf beiden Rechnern)
Debian Stretch-64 armel (NAS)

mat6937
Beiträge: 1133
Registriert: 09.12.2014 10:44:00

Re: systemd-networkd, Erreichbarkeit der Rechner im Netz

Beitrag von mat6937 » 13.03.2018 16:41:28

halo44 hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 15:22:18
Ich bekomme über systemd-networkd keine LAN-Verbindung zum jeweils anderen Rechner, wenn WLAN nicht läuft, ...
Lt. der arping-Ausgabe funktioniert die LAN-Verbidung:

Code: Alles auswählen

arping -c 3 -I enp9s0 -s 192.168.2.205 192.168.2.201
ARPING 192.168.2.201 from 192.168.2.205 enp9s0
Unicast reply from 192.168.2.201 [D8:CB:8A:C0:AE:72]  1.219ms
Unicast reply from 192.168.2.201 [D8:CB:8A:C0:AE:72]  1.114ms
Unicast reply from 192.168.2.201 [D8:CB:8A:C0:AE:72]  1.083ms
Sent 3 probes (1 broadcast(s))
Received 3 response(s)
War zum Zeitpunkt des arpings, das WLAN aktiv oder war das WLAN deaktiviert? Wenn aktiviert, dann versuch mal den arping, wenn das WLAN deaktiviert ist.

halo44
Beiträge: 413
Registriert: 12.05.2015 15:19:13

Re: systemd-networkd, Erreichbarkeit der Rechner im Netz

Beitrag von halo44 » 13.03.2018 17:19:36

mat6937 hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 16:41:28
... Lt. der arping-Ausgabe funktioniert die LAN-Verbidung ...
Ja, arping kann das anscheinend, ping und ssh aber nicht.
mat6937 hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 16:41:28
War zum Zeitpunkt des arpings, das WLAN aktiv oder war das WLAN deaktiviert? Wenn aktiviert, dann versuch mal den arping, wenn das WLAN deaktiviert ist.
WLAN war nicht aktiv.

Gruss H.
Debian Stretch-64 KDE (Desktop)
Debian Stretch-64 KDE (Notebook)
Kanotix64 (auf beiden Rechnern)
Debian Stretch-64 armel (NAS)

mat6937
Beiträge: 1133
Registriert: 09.12.2014 10:44:00

Re: systemd-networkd, Erreichbarkeit der Rechner im Netz

Beitrag von mat6937 » 13.03.2018 17:29:22

halo44 hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 17:19:36
Ja, arping kann das anscheinend, ping und ssh aber nicht.

WLAN war nicht aktiv.
Wenn arping das kann, dann muss es auch mit icmp und tcp/udp funktionieren, wenn das Routing OK ist.

Und lt. einem deiner Beiträge (siehe oben) ist das auch der Fall, wenn Du:

Code: Alles auswählen

iwconfig wlp7s0 txpower off
ausgeführt hast.

Poste mal die Ausgaben von:

Code: Alles auswählen

route -n
arp -av
wenn Du "iwconfig wlp7s0 txpower off" ausgeführt hast und die LAN-Verbindung funktioniert.

halo44
Beiträge: 413
Registriert: 12.05.2015 15:19:13

Re: systemd-networkd, Erreichbarkeit der Rechner im Netz

Beitrag von halo44 » 13.03.2018 18:06:01

mat6937 hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 17:29:22
... Poste mal die Ausgaben von:

Code: Alles auswählen

route -n
arp -av
wenn Du "iwconfig wlp7s0 txpower off" ausgeführt hast und die LAN-Verbindung funktioniert.
Gerne, hier die Ausgaben:

Code: Alles auswählen

route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 enp9s0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 enp9s0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0

arp -av
? (192.168.2.1) auf 9c:c7:a6:55:d5:49 [ether] auf enp9s0
? (192.168.2.201) auf d8:cb:8a:c0:ae:72 [ether] auf enp9s0
Einträge: 2   Ignoriert: 0   Gefunden: 2
Gruss H.
Debian Stretch-64 KDE (Desktop)
Debian Stretch-64 KDE (Notebook)
Kanotix64 (auf beiden Rechnern)
Debian Stretch-64 armel (NAS)

mat6937
Beiträge: 1133
Registriert: 09.12.2014 10:44:00

Re: systemd-networkd, Erreichbarkeit der Rechner im Netz

Beitrag von mat6937 » 13.03.2018 18:43:22

halo44 hat geschrieben: ↑ zum Beitrag ↑
13.03.2018 18:06:01
... hier die Ausgaben:

Code: Alles auswählen

route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 enp9s0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 enp9s0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0

arp -av
? (192.168.2.1) auf 9c:c7:a6:55:d5:49 [ether] auf enp9s0
? (192.168.2.201) auf d8:cb:8a:c0:ae:72 [ether] auf enp9s0
Einträge: 2   Ignoriert: 0   Gefunden: 2
Das sieht ganz anders aus. D. h., nur am deaktivieren des WLANs lag es nicht, sondern auch am fehlerhaften Routing und den fehlerhaften arp-cache-Einträgen (... für ein WLAN-Interface das noch up war aber keine Verbindung mehr hatte), nach dem Du das WLAN deaktiviert hast.

Antworten