Trotz "Fix Released" kein Mobile Broadband für NichtAdmin!?

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
debflash
Beiträge: 69
Registriert: 19.07.2007 20:38:44

Trotz "Fix Released" kein Mobile Broadband für NichtAdmin!?

Beitrag von debflash » 11.01.2017 18:36:15

Mein System:
Debian GNU/Linux 8 (jessie) 64-bit
Gnome Version 3.14.1
Mobile Broadband: Aldi/Medion Huawei E173 USB stick

Hallo,

in
https://bugs.launchpad.net/ubuntu/+sour ... bug/964705
lese ich, dass der Bug "System policy prevents modification of network settings for all users" in Debian behoben sein soll, nämlich
"network-manager (Debian) Fix Released"

Trotzdem habe ich noch den gleichen Bug in Debian 8, mein NichtAdminUser kann den o.g. Mobile Stick NUR als Admin mittels PIN-Eingabe aktivieren!

Ich habe alle aktuellen Updates (apt-get update && apt-get dist-upgrade). Was bedeutet hier "Fix Released"? Der Thread scheint von 2012 zu sein. Wie lange dauert es im Schnitt, bis so ein Fix in den Updates auftaucht?

Danke,

debflash

P.S. WiFi funktioniert für alle User ohne Probleme.

MSfree
Beiträge: 2323
Registriert: 25.09.2007 19:59:30

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von MSfree » 11.01.2017 19:52:08

Ich befürchte, mit dem Bug hat dein Problem nichts zu tun.

Bei einem meiner Laptops habe ich ein eingebautes UMTS-Modem auf dem Motherboard, das per USB angebunden ist. Durch das Modem wird eine serielle Schnittstelle unter /dev mit dem Namen ttyUSB0 angelegt.

Schau mal, ob das bei dir auch der Fall ist. Bei mir gehört diese Schnittstelle root und sie hat read/write-Berechtigung für alle Nutzer, die in der Gruppe dialout sind. Das sollte bei dir auch der Fall sein.

Wenn du also ohne root-Rechte über diese Schnittstelle kommunizieren willst, mußt du deinen Benutzer in die dialout-Gruppe zufügen.

debflash
Beiträge: 69
Registriert: 19.07.2007 20:38:44

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von debflash » 12.01.2017 16:54:04

Danke erst mal :-)
MSfree hat geschrieben:...Bei einem meiner Laptops habe ich ein eingebautes UMTS-Modem auf dem Motherboard, das per USB angebunden ist. Durch das Modem wird eine serielle Schnittstelle unter /dev mit dem Namen ttyUSB0 angelegt. Schau mal, ob das bei dir auch der Fall ist.
Wenn ich mein externes USB Modem reinstecke werden /dev/ttyUSB3, ttyUSB7, ttyUSB8 und ttyUSB9 neu angelegt.
Bei mir gehört diese Schnittstelle root und sie hat read/write-Berechtigung für alle Nutzer, die in der Gruppe dialout sind. Das sollte bei dir auch der Fall sein. Wenn du also ohne root-Rechte über diese Schnittstelle kommunizieren willst, mußt du deinen Benutzer in die dialout-Gruppe zufügen.
Leider hilft das nicht. Es passiert folgendes:

* 1 * Starten von Debian, noch vor einloggen wird nach SIM PIN gefragt.
* 2 * PIN eingeben, Anschließend kommt, wie bei Ubuntu 16.04, die Fehlermeldung "PolicyKit authorization failed: challenge needed for org.freedesktop.ModemManager1.Device.Control". Nicht schlimm, einfach <Cancel>, dann ist sie weg.
* 3 * Einloggen als NichtAdminUser, nach einiger Zeit kommt wieder die Aufforderung zur SIM PIN Eingabe.
* 4 * Also PIN eingeben, danach kommt die Aufforderung zum Authentizieren, wobei das ICON des NichtAdminUsers abgebildet ist.
* 5 * Also gibt der NichtAdminUser sein Passwort ein, und die Aufforderung verschwindet. Aber es ist keine Mobile Broadband Verbindung zu sehen (oben rechts in der Taskleiste, nach Klick auf das kleine Dreieckchen) mit der man verbinden könnte. Der Stick blinkt blau.
* 6 * Folgendes hilft jetzt, hier immer noch in der NichtAdminUmgebung:
* 7 * Root-Terminal aufmachen und

Code: Alles auswählen

# service network-manager stop
# service network-manager restart
Jetzt leuchtet die Stick-LED konstant blau und "Medion Mobile" ist zu sehen, mit der der NichtAdminUser eine Verbindung herstellen kann.

Ich muss, anmerken, dass ich das mit "# service network-manager..." irgendwann mal irgenwo aufgeschnappt hatte, und ich weiss nicht, was das genau bewirkt.

In Ubuntu 16.04 fängt es so an wie oben bei Debian geschildert. Allerdings wird bei der Authentisieungsabfrage nach dem Admin verlangt (nicht nach dem NichtAdminUser wie bei Debian)... aber oh Wunder, der NichtAdmin muss diese Abfrage nur zwemal <Cancel>n und kann seine Mobile Broadband Verbindung selbst herstellen! Ist zwar auch nicht das Gelbe vom Ei, aber es klappt wenigstens. Übrigens spielt es keine Rolle, ob der NichtAdmin in der Gruppe dialout drin ist oder nicht.

Das gelbe vom Ei ist Ubuntu 14.04: da klappt alles ohne Probleme und <Cancel>n. Mitgliedschaft in dialout ist nicht vorhanden, geht alles ohne.

Was mich jetzt wundert, warum bei Ubuntu 14.04 alles ok, bei Ubuntu 16.04 nur mit Tricks, bei Debian aber nur mit Eingriffen des Admin?

P.S. Noch eine Anmerkung: alles wie oben für Ubuntu 16.04 und Debian geschildert klappt nur, wenn ich in /lib/udev/rules.d/70-usb-modeswitch.rules (neu angelegt) stehen habe:

Code: Alles auswählen

# own udev rules for Aldi/Medion Huawei E173
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446", RUN+="/usr/sbin/usb_modeswitch -v 12d1 -p 1446 -M '55534243123456780000000000000011062000000100000000000000000000'"
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1436", RUN+="/bin/bash -c 'modprobe option && echo 12d1 1436 > /sys/bus/usb-serial/drivers/option1/new_id'"
Modifiziert nach einem Ubuntuusers.de Wiki. Bei Ubuntu 14.04 ist das nicht nötig. Schade, dass hier Fortschritt mit soviel Rückschritt verbunden ist ;-)

MSfree
Beiträge: 2323
Registriert: 25.09.2007 19:59:30

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von MSfree » 12.01.2017 18:21:38

debflash hat geschrieben:Wenn ich mein externes USB Modem reinstecke werden /dev/ttyUSB3, ttyUSB7, ttyUSB8 und ttyUSB9 neu angelegt.
OK, und wem gehören die Devices? Führ bitte mal

Code: Alles auswählen

ls -l /dev/ttyUSB*
aus.

debflash
Beiträge: 69
Registriert: 19.07.2007 20:38:44

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von debflash » 12.01.2017 22:41:23

MSfree hat geschrieben: Führ bitte mal

Code: Alles auswählen

ls -l /dev/ttyUSB*
aus.

Code: Alles auswählen

$ ls -l /dev/ttyUSB*
crw-rw---- 1 root dialout 188, 0 Jan 13 08:18 /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 1 Jan 13 08:18 /dev/ttyUSB1
crw-rw---- 1 root dialout 188, 2 Jan 13 08:18 /dev/ttyUSB2
crw-rw---- 1 root dialout 188, 4 Jan 13 08:18 /dev/ttyUSB4
$
Jetzt sind sie 0, 1, 2, 4

Neustart, danach wieder 0, 1, 2, 4

Jetzt Stick herausgezogen, wieder reingesteckt, danach 0, 4, 5, 6

Bei meinem vorherigen Post waren sie ja 3, 7, 8, 9. Aber jedesmal gehören sie root. Seltsam mit dem Wechsel der Nummern!

scientific
Beiträge: 1908
Registriert: 03.11.2009 13:45:23
Lizenz eigener Beiträge: Artistic Lizenz
Kontaktdaten:

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von scientific » 13.01.2017 14:18:19

Ich machte die Erfahrung mit Jessie, dass ein Aktivieren und anschließendes Deaktivieren den Flugmodus die UMTS-Verbindung zum Vorschein brachte.
Das kann auch der User ohne root.
dann putze ich hier mal nur...

Eine Auswahl meiner Skripte und systemd-units.
https://github.com/xundeenergie

auch als Debian-Repo für Testing einbindbar:
deb http://debian.xundeenergie.at/xundeenergie testing main

debflash
Beiträge: 69
Registriert: 19.07.2007 20:38:44

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von debflash » 14.01.2017 20:46:25

Hat bei mir leider nicht geholfen :(

scientific
Beiträge: 1908
Registriert: 03.11.2009 13:45:23
Lizenz eigener Beiträge: Artistic Lizenz
Kontaktdaten:

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von scientific » 15.01.2017 09:47:55

Gehe grad in mich... Ich glaub, ich hab dazu noch eine polkit-regel geschrieben. Bin aber erst morgen wieder an diesem rechner um sie dir zu schicken.
dann putze ich hier mal nur...

Eine Auswahl meiner Skripte und systemd-units.
https://github.com/xundeenergie

auch als Debian-Repo für Testing einbindbar:
deb http://debian.xundeenergie.at/xundeenergie testing main

rendegast
Beiträge: 14200
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von rendegast » 15.01.2017 11:32:35

debflash hat geschrieben: P.S. Noch eine Anmerkung: alles wie oben für Ubuntu 16.04 und Debian geschildert klappt nur, wenn ich in /lib/udev/rules.d/70-usb-modeswitch.rules (neu angelegt) stehen habe:

# own udev rules for Aldi/Medion Huawei E173
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446", RUN+="/usr/sbin/usb_modeswitch -v 12d1 -p 1446 -M '55534243123456780000000000000011062000000100000000000000000000'"

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1436", RUN+="/bin/bash -c 'modprobe option && echo 12d1 1436 > /sys/bus/usb-serial/drivers/option1/new_id'"
Beim ersten wird wohl sichergestellt, daß der Modem-Stick von 'storage' (windows-Treiber) zu 'modem' schaltet.
Beim zweiten wird das Modul option eine Berücksichtigung dieses speziellen Sticks beigebracht,
wobei jedoch die ID im storage-Modus benutzt wird.
Sollte da nicht die ID im modem-Modus gesetzt werden?


kernel 4.8

Code: Alles auswählen

# modprobe -c | grep 1436
alias usb:v12D1p1436d0000dc*dsc*dp*ic*isc*ip*in* usb_storage
Die ID im modem-Modus (lsusb) muß nicht explizit im option-Modul stehen,
es könnte sich auch nach den Funktions-Tags richten (lsusb -v).



Könnte aber auch sein, daß bei beiden Modi des Stick dieselbe ID gilt.
Dann wäre eventuell noch usb-storage vom Stick abzukoppeln.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

debflash
Beiträge: 69
Registriert: 19.07.2007 20:38:44

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von debflash » 19.01.2017 17:21:55

Für mich gelöst für Debian 8.7.1 Gnome Classic (und Ubuntu 16.04 Unity, da gibt's mit meinem Stick das gleich Problem)

Mit viel Herumprobieren, scheint es jetzt so zu klappen:

Erst mal bei ausgeschaltetem Notbook USB modem (Aldi/Medion E173) einstecken, dann Computer einschalten und hochfahren. Ich habe, ausser root, zwei User, user1 und user2.

* 1 *
Einloggen als user2, SIM PIN eingeben, wenn verlangt, dann

Code: Alles auswählen

# nm-connection-editor
, falls noch eine Mobile Broadband Connection da ist, diese entfernen

* 2 *

Code: Alles auswählen

# exit
* 3 *
Neue Mobile Broadband Connection mit dem Menü anlegen

* 4 *

Code: Alles auswählen

# nm-connection-editor
, sichergehen, dass "All Users may connect..." und "Automatically connect to this connection" aktiviert werden

Code: Alles auswählen

# exit
* 5 *
Die neue Verbindung benutzen

* 6 *
Computer herunterfahren. Und nur, wenn heruntergefahren, USB Modem entfernen.

* 7 *
Vor erneutem Einschalten des Computers, USB Modem einstecken

* 8 *
Einlogen als user1 oder user2, SIM PIN Abfrage beantworten, die danach folgende Meldung "System Policy prevents..." mit dem gegenwärtigen user1 oder user2 Passwort beantworten, wenn danach gefragt wird. Falls danach noch eine Abfrage des Administrator Passworts kommt, diese mit <Cancel> beantworten (wenn es sein muss zweimal nacheinander)

* 9 *
Im Mobile Broadband Menü rechts "Connect" wählen, auch wenn kein Connection Name angezeigt wird. Die Verbindung kommt.

* 10 *
Von jetzt an Schritte * 6 * bis * 10 * durchführen.

Warum es so bei mir klappt, weiss ich nicht.

debflash
Beiträge: 69
Registriert: 19.07.2007 20:38:44

Re: Trotz "Fix Released" kein Mobile Broadband für NichtAdmi

Beitrag von debflash » 22.01.2017 11:39:55

Endlich habe ich die SIM PIN deaktiviert. Jetzt läuft alles wie geschmiert, ohne das etwas umständliche Vorgehen in meinem vorigen Post :D

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste