Problem mit WLAN AP mit network-manager-gnome

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
Benutzeravatar
smutbert
Beiträge: 6546
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Problem mit WLAN AP mit network-manager-gnome

Beitrag von smutbert » 04.05.2018 13:24:41

Hallo allerseits,

diesen Thread erstelle ich nicht für mich sondern weil ein relativ junges Mitglied (ItsTacoLP, ich hab ihm eine PN geschickt) den Sinn des Wikis etwas missverstanden hat. Hier ist dieser Beitrag besser aufgehoben denke ich
Guten Tag, liebe Community. Ich hatte seit vielen Wochen ein Problem mit meinem Ralink RT5370 USB Wlan Stick. Ich nutze Debian 9, bei Debian 8 hatte alles super geklappt. Ich habe den Treiber rt2800usb mit "apt-get install firmware-misc-nonfree" installiert. "modprobe rt2800usb" hat geklappt. Wenn ich bei den Drahtlosnetzwerk-Einstellungen auf "Als Hotspot verwenden..." klicke, wird dank "https://bugs.debian.org/cgi-bin/bugrepo ... bug=858870", Wlan-Passwort, SSID und Verschlüsselungsart angezeigt. Jetzt zum Problem, das Wlan wird auf dem Handy erkannt, jedoch wird obwohl ich das korrekte Passwort eingebe, Authentifizierungsproblem angezeigt. Bei anderen Geräten geht die Verbindung auch nicht.

Hatte jemand auch dieses Problem und kann mir weiterhelfen? MfG ItsTacoLP
(Quelle Wiki-Artikel zum Thema Wlan USB Stick RT5370 - Authentifizierungsproblem)

(ich selbst hab mit dem network-manager noch nie versucht ein WLAN „aufzuspannen“)
hoffentlich liest ItsTacoLP die private Nachricht...

lg smutbert

BenutzerGa4gooPh

Re: Problem mit WLAN AP mit network-manager-gnome

Beitrag von BenutzerGa4gooPh » 04.05.2018 16:18:54

... das Wlan wird auf dem Handy erkannt, jedoch wird obwohl ich das korrekte Passwort eingebe, Authentifizierungsproblem angezeigt
Funktioniert der Hotspot ohne PSK ("Passwort"), also offenes WLAN? Mit unsicheren Authentifizierungen TKIP, WEP, WPA(1)?
Kannst du mittels Windows einen funktionierenden Hotspot erstellen? Dualboot ist vielleicht vorhanden.

Poste

Code: Alles auswählen

dmesg | grep firmware
journalctl -b -p err
iw list
Dann mal Netzwerk/Hotspot deaktivieren, ein Terminal und

Code: Alles auswählen

journalctl -f
Hotspot aktivieren und Ausgaben posten.


2. Linux-Rechner als Client. Netzwerk deaktivieren, Terminal und

Code: Alles auswählen

journalctl -f
Hotspot aktivieren und Ausgaben posten.

Code: Alles auswählen

iw dev wlan0 scan 
posten. wlan0 anpassen. Wie verrät

Code: Alles auswählen

ip link
Zuletzt geändert von BenutzerGa4gooPh am 05.05.2018 09:32:08, insgesamt 1-mal geändert.

Benutzeravatar
smutbert
Beiträge: 6546
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Problem mit WLAN AP mit network-manager-gnome

Beitrag von smutbert » 04.05.2018 22:19:06

Im Bugreport Debian Bugreport858870 ist eindeutig die Rede vom gnome-control-center. Wenn also tatsächlich dieser Bug schuld am Problem ist und der Bugreport nicht gegen das falsche Paket verfasst wurde, dann sollte es helfen einfach ein anderes Tool zu verwenden.

Auf der Kommandozeile mit nmtui oder in grafischen Oberfläche mit nm-connection-editor (beide lassen sich im Terminal starten und das zweite wahlweise auch über <Alt>+<F2>) kann man eine neue WLAN-Verbindung erstellen und den Modus von "Client" auf "Hotspot" umstellen.

Ansonsten wäre es eventuell auch einen Versuch wert den Workaround aus dem Bugreport auszuprobieren

Code: Alles auswählen

# hostnamectl --pretty set-hostname <Hostname>
wobei ich vermute dass du einen beliebigen Hostnamen verwenden kannst, aber ich würde einfach den normalen Hostnamen verwenden:

Code: Alles auswählen

# hostnamectl --pretty set-hostname $(hostname)
danach einfach noch einmal versuchen den AP einzurichten.


Sollte das nichts bringen wäre – ergänzend zu den Informationen nach denen Jana gefragt hat – vielleicht auch interessant was nach einem fehlgeschlagenen Versuch bei

Code: Alles auswählen

journalctl -p7 -u NetworkManager
herauskommt.

Antworten