Bootverzögerung beim Start

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Bootverzögerung beim Start

Beitrag von fnliner » 04.08.2018 11:10:52

Hallo Debian - Freunde ...
seit dem letzten Update ( SMP Debian 4.17.8-1 )) braucht der Rechner ca.5min bis er hochgefahren ist. :(
Hängt irgendwie am Netzwerkmanager / WLAN etc.
LSB Script , init Script ...habe mal ein Bild angehängt, vielleicht hat jemand eine Idee zur Lösung des Problems.

Bild

mat6937
Beiträge: 1061
Registriert: 09.12.2014 10:44:00

Re: Bootverzögerung beim Start

Beitrag von mat6937 » 04.08.2018 11:23:50

fnliner hat geschrieben: ↑ zum Beitrag ↑
04.08.2018 11:10:52
... braucht der Rechner ca.5min bis er hochgefahren ist. :(
Hängt irgendwie am Netzwerkmanager / WLAN etc.
Wenn Du temporär (schon beim booten) IPv6 deaktivieren kannst/darfst, dann teste mal mit deaktiviertem IPv6 zu booten.

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 05.08.2018 10:36:27

Hallo ... danke für die schnelle Antwort ... leider ohne Erfolg.
Habe die IPV6 temporär und später auch permanent deaktiviert, trotzdem verzögert sich der Bootvorgang 5min !! :(
Muss irgendwie mit dem thin - Script in Verbindung stehen, vielleicht kann man dieses Script modifizieren ... ???

Bin für weitere Vorschläge dankbar. ....

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 06.08.2018 07:43:14

Gibt's noch weitere Vorschläge. ???

Benutzeravatar
niemand
Beiträge: 11590
Registriert: 18.07.2004 16:43:29

Re: Bootverzögerung beim Start

Beitrag von niemand » 06.08.2018 07:46:15

Braucht das Ding vielleicht Entropie? Dann mal Debianhaveged installieren.

OT: deine Fragezeichentaste – sie klemmt.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 06.08.2018 08:12:28

Hallo, danke für die Nachricht, bin allerdings nicht überzeugt davon , daß Haveget zur Lösung meines Problemes beiträgt ?

Benutzeravatar
niemand
Beiträge: 11590
Registriert: 18.07.2004 16:43:29

Re: Bootverzögerung beim Start

Beitrag von niemand » 06.08.2018 08:21:37

Ist ’n Schuss ins Blaue, ja – ich hab auch keine Lust, für dich zu recherchieren, was dieses thin-Dings macht, und ob es Entropie braucht.

Der Gedanke ist einfach: gerade in der jüngeren Vergangenheit hat sich gezeigt, dass ein Mangel an Entropie für viele Startverzögerungen ursächlich war – und haveged kann das halt beheben. Zudem kostet ’n Test etwa 5 Minuten Arbeit (je ein Befehl zur Installation und für Reboot), und wenn’s dann doch nix bringen sollte, weiß man einerseits, dass es nicht an der Entropie liegt, andererseits ist’s mit ähnlich geringem Aufwand wieder deinstalliert.

Du kannst natürlich auch weiterhin solche Vorschläge in Frage stellen und auf den warten, der dir die Ursache samt Lösung präsentiert. Kann dann halt noch etwas dauern …
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 06.08.2018 08:59:25

Danke für deine Nachricht.
Hast ja recht, ein Versuch kann nicht schaden.
Mal schauen ob,s was bringt.
Das Problem ist aber erst nach einem Kernel - Upgrade enstanden.
Vermute daher, dass sich da ein Bug eingeschlichen hat.
Dafür spricht auch , dass nach nach einer Neuinstallation mit Kernel 4.15 das Problem nicht auftritt.
Gruß
Ralf

Benutzeravatar
niemand
Beiträge: 11590
Registriert: 18.07.2004 16:43:29

Re: Bootverzögerung beim Start

Beitrag von niemand » 06.08.2018 09:20:55

Das spricht eher dafür, dass es einen Versuch wert ist. Der hohe Bedarf an Entropie kam erst in der letzten Zeit.

Mal ganz ehrlich: in der Zeit, in der du die beiden Beiträge verfasst hast, hätte ich dreimal ›aptitude install haveged && reboot‹ eingetippt. Dann hätte Klarheit bestanden, und man hätte den Thread entweder auf [gelöst] setzen, oder aber eine mögliche Ursache auf der Liste abhaken können.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 06.08.2018 09:25:46

Bin im Geschäft, der Rechner steht daheim :D

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 07.08.2018 13:20:22

haveged && reboot ... leider ohne Erfolg!

geier22

Re: Bootverzögerung beim Start

Beitrag von geier22 » 07.08.2018 14:01:45

Code: Alles auswählen

thin/testing 1.6.3-2+b5 amd64
  Schneller und sehr einfacher Ruby-Webserver
Was hast denn da für einen Maschine ?
fnliner hat geschrieben: ↑ zum Beitrag ↑
05.08.2018 10:36:27
Muss irgendwie mit dem thin - Script in Verbindung stehen, vielleicht kann man dieses Script modifizieren ... ???
Dann deinstalliere doch malDebian thin. Hört sich nicht so an, als bräuchtest du den.

und vielleicht mal

Code: Alles auswählen

systemd-analyze critical-chain

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 08.08.2018 11:15:20

Hallo... habe den thin __Server de installiert , das Ergebnis ist das gleiche.
Meine Maschine ist ein DELL D830 .

Ich vermute es liegt am Netzwerk - Manager?

MSfree
Beiträge: 3473
Registriert: 25.09.2007 19:59:30

Re: Bootverzögerung beim Start

Beitrag von MSfree » 08.08.2018 11:55:36

fnliner hat geschrieben: ↑ zum Beitrag ↑
08.08.2018 11:15:20

Ich vermute es liegt am Netzwerk - Manager?

Code: Alles auswählen

systemd-analyze plot > start.svg
Und dann die Datei start.svg nach nopaste hochladen.

Du kannst dir die Datei start.svg natürlich auch selbst mit dem Firefox ansehen.

geier22

Re: Bootverzögerung beim Start

Beitrag von geier22 » 08.08.2018 15:09:57

fnliner hat geschrieben: ↑ zum Beitrag ↑
08.08.2018 11:15:20
Hallo... habe den thin __Server de installiert , das Ergebnis ist das gleiche.
Das thin initscript ist Bestandteil des Pakets Debianthin und sollte sich in /etc/init.d/thin (thin.sh oder ähnlich)befinden .
Hast du Debianthin gepurgt oder nur gelöscht ?
Wenn es nicht mehr da ist sollte zumindest der Start Job auf Grund diese Scripts verschwunden sein

Code: Alles auswählen

ls -l /etc/init.d/ |grep thin

Antworten