Routing Problem nach aktiver openvpn Verbindung

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
lip90
Beiträge: 6
Registriert: 17.09.2018 17:05:12

Routing Problem nach aktiver openvpn Verbindung

Beitrag von lip90 » 18.09.2018 11:27:49

Hallo Leute,

ich hoffe ihr könnt mir bei meinem Problem helfen.

Ich verwende einen Linux Server welcher als openvpn Client mit einem Payed VPN Server verbunden ist. Mein Server dient quasi als Gateway.

Ich habe mein Netzwerk durch verschiedene VLANs getrennt und scheitere schon am anpingen. Wenn die VPN Verbindung nicht aufgebaut ist, habe ich keine Probleme von meinem PC (192.168.1.70) den Server (192.168.30.13) anzupingen. Sobald der openVPN Client verbunden ist, geht das nicht mehr. Die Pings laufen in einen Timeout.

LAN1: 192.168.1.1/24 LAN2: 192.168.30.1/24

Anbei die Routing Tabelle des Linux Servers wenn openVPN nicht verbunden ist:

Code: Alles auswählen

root@ovpn-gateway:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.30.1    0.0.0.0         UG    0      0        0 eth0
128.90.178.62   192.168.30.1    255.255.255.255 UGH   0      0        0 eth0
192.168.30.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
Hier die Tabelle wenn die openVPN Verbindung steht:

Code: Alles auswählen

root@ovpn-gateway:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.11.62.1      128.0.0.0       UG    0      0        0 tun0
0.0.0.0         192.168.30.1    0.0.0.0         UG    0      0        0 eth0
10.11.62.0      0.0.0.0         255.255.255.0   U     0      0        0 tun0
128.0.0.0       10.11.62.1      128.0.0.0       UG    0      0        0 tun0
128.90.178.62   192.168.30.1    255.255.255.255 UGH   0      0        0 eth0
192.168.30.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
Was muss ich tun das LAN1 auf LAN2 auch zugreifen kann wenn die vpn Verbindung besteht?

mat6937
Beiträge: 1133
Registriert: 09.12.2014 10:44:00

Re: Routing Problem nach aktiver openvpn Verbindung

Beitrag von mat6937 » 18.09.2018 11:42:20

lip90 hat geschrieben: ↑ zum Beitrag ↑
18.09.2018 11:27:49
Ich habe mein Netzwerk durch verschiedene VLANs getrennt und scheitere schon am anpingen. Wenn die VPN Verbindung nicht aufgebaut ist, habe ich keine Probleme von meinem PC (192.168.1.70) den Server (192.168.30.13) anzupingen. Sobald der openVPN Client verbunden ist, geht das nicht mehr. Die Pings laufen in einen Timeout.

LAN1: 192.168.1.1/24 LAN2: 192.168.30.1/24

Anbei die Routing Tabelle des Linux Servers wenn openVPN nicht verbunden ist:

Code: Alles auswählen

root@ovpn-gateway:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.30.1    0.0.0.0         UG    0      0        0 eth0
128.90.178.62   192.168.30.1    255.255.255.255 UGH   0      0        0 eth0
192.168.30.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
Hier die Tabelle wenn die openVPN Verbindung steht:

Code: Alles auswählen

root@ovpn-gateway:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.11.62.1      128.0.0.0       UG    0      0        0 tun0
0.0.0.0         192.168.30.1    0.0.0.0         UG    0      0        0 eth0
10.11.62.0      0.0.0.0         255.255.255.0   U     0      0        0 tun0
128.0.0.0       10.11.62.1      128.0.0.0       UG    0      0        0 tun0
128.90.178.62   192.168.30.1    255.255.255.255 UGH   0      0        0 eth0
192.168.30.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
Was muss ich tun das LAN1 auf LAN2 auch zugreifen kann wenn die vpn Verbindung besteht?
Starte mal auf deinem Server (VPN-Client als VPN-gateway) ohne VPN-Verbindung:

Code: Alles auswählen

tcpdump -c 20 -vvveni eth0 host  192.168.1.70 and icmp
und mit VPN-Verbindung:

Code: Alles auswählen

tcpdump -c 20 -vvveni eth0 host  192.168.1.70 and icmp
tcpdump -c 20 -vvveni tun0 host  192.168.1.70 and icmp
Führe danach den Ping von 192.168.1.70 auf 192.168.30.13 und poste danach die Ausgaben von tcpdump.

Benutzeravatar
WinMaik
Beiträge: 302
Registriert: 22.03.2008 10:38:00

Re: Routing Problem nach aktiver openvpn Verbindung

Beitrag von WinMaik » 18.09.2018 11:49:12

Ohne VPN ist

Code: Alles auswählen

0.0.0.0         192.168.30.1    0.0.0.0         UG    0      0        0 eth0
deine Default-Route, mit VPN jedoch

Code: Alles auswählen

0.0.0.0         10.11.62.1      128.0.0.0       UG    0      0        0 tun0
128.0.0.0       10.11.62.1      128.0.0.0       UG    0      0        0 tun0
Wenn du nun Pakete an 192.168.1.0/24 schickst, klappt das vermutlich ohne VPN Verbindung, da 192.168.30.1 weiß, wie es das Netz erreicht. Wenn die VPN Verbindung aber aktiv ist, schickst Du alle Pakete an 192.168.1.0/24 zu dem VPN Server, der damit nichts anfangen kann.
Versuch mal folgendes:

Code: Alles auswählen

ip r a 192.168.1.0/24 via 192.168.30.1

mat6937
Beiträge: 1133
Registriert: 09.12.2014 10:44:00

Re: Routing Problem nach aktiver openvpn Verbindung

Beitrag von mat6937 » 18.09.2018 11:53:19

lip90 hat geschrieben: ↑ zum Beitrag ↑
18.09.2018 11:27:49
ich hoffe ihr könnt mir bei meinem Problem helfen.
Siehe z. B. auch: https://forum-raspberrypi.de/forum/thre ... n-zugriff/

Antworten