"Energy Efficient Ethernet" permanent deaktivieren

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
DirkHo
Beiträge: 52
Registriert: 10.05.2004 08:13:11

"Energy Efficient Ethernet" permanent deaktivieren

Beitrag von DirkHo » 18.04.2019 18:09:00

Hallo,

ich möchte meinen Mini-Server über Wake on LAN starten können und habe mich hierfür an diese Anleitung gehalten: https://www.dell.com/support/article/de ... em?lang=en

Mein Dell läuft allerdings unter Debian (OMV). Im BIOS habe ich WoL -> "LAN Only" aktiviert und "Deep Sleep" deaktiviert. In OMV habe ich zudem WOL aktiviert. Wenn ich mir in ethtool Infos zu meinem NIC anzeigen lasse, bekommen ich Supported dumbg und aktivierter Modus ist "g" (Magic Packet).

Es klappt aber nicht und das liegt eventuell daran, dass ich Energy Efficient Ethernet permanent deaktivieren muss. Wenn ich

ethtool --set-eee <NIC> eee off

ausführe wird es mir beim Aufruf des Befehls

ethtool --show-eee <NIC>

zwar als deaktiviert angezeigt, allerdings ist es nach dem nächsten Booten wieder aktiviert. Ich bin mir bei meinem Vorhaben auch nicht sicher, ob es reicht, beim nächsten Booten EEE zu deaktivieren, da es ja genau dann deaktiviert sein soll(te), wenn der Server abgeschalten ist, oder?

Könnt ihr mir da vielleicht weiterhelfen?

Vielen Dank und viele Grüße

Dirk


DirkHo
Beiträge: 52
Registriert: 10.05.2004 08:13:11

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von DirkHo » 18.04.2019 18:52:10

Vielen Dank für deine Antwort. In dem Link habe ich nachgelesen, was ich genau auf OMV-Seite machen muss, um WOL zu aktivieren. Letztendlich habe ich es über die GUI gemacht und nachdem es nicht funktionierte, habe ich nochmal alles auf der Shell nachgeprüft (ethtool und /etc/network/interfaces-Eintrag).

Das hat aber leider auch nichts gebracht. :(

Benutzeravatar
willy4711
Beiträge: 1965
Registriert: 08.09.2018 16:51:16

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von willy4711 » 18.04.2019 19:42:58

Hab schon ewig keinen Server und NAS mehr.

Es stellt sich trotzdem die Frage, mit welchen Tool du deinen Server aufweckst, und was du da rein geschrieben hast.

Vielleicht mal hier einstellen :

Code: Alles auswählen

cat /etc/network/interfaces
und

Code: Alles auswählen

ip a

DirkHo
Beiträge: 52
Registriert: 10.05.2004 08:13:11

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von DirkHo » 18.04.2019 20:18:08

Vielen Dank für deine Antwort.

/etc/network/interfaces

Code: Alles auswählen

# Include additional interface stanzas.
source-directory interfaces.d

# The loopback network interface
auto lo
iface lo inet loopback

# enp0s31f6 network interface
auto enp0s31f6
allow-hotplug enp0s31f6
iface enp0s31f6 inet static
    address 10.50.50.10
    gateway 10.50.50.1
    netmask 255.255.255.0
    dns-nameservers 10.50.50.1
    pre-down ethtool -s $IFACE wol g
    iface enp0s31f6 inet6 manual
    pre-down ip -6 addr flush dev $IFACE
ifconfig -a (die mac adresse habe ich für das Forum-Posting hier angepasst)

Code: Alles auswählen

enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.50.50.10  netmask 255.255.255.0  broadcast 10.50.50.255
        ether 12:8c:9d:a2:d3:bq  txqueuelen 1000  (Ethernet)
        RX packets 892999  bytes 59398131 (56.6 MiB)
        RX errors 0  dropped 15  overruns 0  frame 0
        TX packets 2350982  bytes 3517405680 (3.2 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xdf100000-df120000

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2770  bytes 315226 (307.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2770  bytes 315226 (307.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Aufwecken will ich den Server mit wol.exe (aus Windows heraus) mit dem Befehl:

wol.exe 12:8c:9d:a2:d3:bq

optional auch schon mit

wol.exe 12:8c:9d:a2:d3:bq /d 10.50.50.10

probiert.

Vielen Dank und viele Grüße

Dirk

Benutzeravatar
willy4711
Beiträge: 1965
Registriert: 08.09.2018 16:51:16

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von willy4711 » 18.04.2019 22:12:34

zumindest scheint die Syntax nach https://www.heise.de/download/product/w ... &hgf=false
falsch zu sein:
Bild

dufty2
Beiträge: 1582
Registriert: 22.12.2013 16:41:16

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von dufty2 » 19.04.2019 16:53:20

Laut
https://www.toradex.com/community/quest ... ernet.html
lässt es sich mit einem Bootparameter
igb.EEE=0
abschalten.

Denke mal, mit "igb" ist hier der Intel-Netzwerkkarten-Treiber (Intel GigaBit) gemeint.
Deinen eigenen Treiber kannst Du per

Code: Alles auswählen

# ethtool -i enp0s31f6
herausfinden können und dann ggf. anpassen.

DirkHo
Beiträge: 52
Registriert: 10.05.2004 08:13:11

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von DirkHo » 21.04.2019 09:53:50

Hallo ihr beiden,

vielen Dank für eure Antworten und entschuldigt meine späte Reaktion.
willy4711 hat geschrieben: ↑ zum Beitrag ↑
18.04.2019 22:12:34
zumindest scheint die Syntax nach https://www.heise.de/download/product/w ... &hgf=false
falsch zu sein:
Bild
Den Screenshot auf der heise-Seite - von dort habe ich wol.exe heruntergeladen - habe ich Dank der Werbung gar nicht gesehen. Ich dachte, das sei ein reiner Werbebereich.

Ich habe es mit der Syntax (einfach alle ":" aus der Mac-Adresse entfernt) versucht, allerdings hat das auch nicht den gewünschten Erfolg gebracht.
dufty2 hat geschrieben: ↑ zum Beitrag ↑
19.04.2019 16:53:20
Laut
https://www.toradex.com/community/quest ... ernet.html
lässt es sich mit einem Bootparameter
igb.EEE=0
abschalten.

Denke mal, mit "igb" ist hier der Intel-Netzwerkkarten-Treiber (Intel GigaBit) gemeint.
Deinen eigenen Treiber kannst Du per

Code: Alles auswählen

# ethtool -i enp0s31f6
herausfinden können und dann ggf. anpassen.
Unter /etc/default/grub habe ich folgendes hinzugefügt:

Code: Alles auswählen

e1000e.EEE=0
Nach einem Neustart wurde mir Energy Efficience aber weiterhin als active angezeigt. Also habe ich es, wie im Originalpost mit

Code: Alles auswählen

igb.EEE=0
und danach mit

Code: Alles auswählen

enp0s31f6.EEE=0
probiert. Allerdings mit demselben Ergebnis.

Meine Ausgabe beim Aufruf des Befehls

Code: Alles auswählen

ethtool -i enp0s31f6
sieht wie folgt aus:

Code: Alles auswählen

root@server:~# ethtool -i enp0s31f6
driver: e1000e
version: 3.2.6-k
firmware-version: 0.8-4
expansion-rom-version:
bus-info: 0000:00:1f.6
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no
Ich bin ja kein Fachmann, aber EEE "erst" beim Booten zu deaktivieren, ist das nicht etwas spät? Müsste es nicht komplett deaktiviert werden, damit die Netzwerkkarte nicht in den Energiesparmodus verfällt, wenn der T30 ausgeschalten ist?

Vielen Dank, frohe Ostern und viele Grüße

Dirk

dufty2
Beiträge: 1582
Registriert: 22.12.2013 16:41:16

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von dufty2 » 22.04.2019 07:22:05

Bin jetzt auch kein EEE-Experte,
aber mein Verständnis ist, dass selbst im State S5 (Soft-Off) die NIC auch noch Strom hat (deshalb sich ihre Einstellung - EEE off - merkt).
Deswegen musstest Du ja auch "Deep Sleep" deaktivieren.
Bei einem Reboot hingegen ist sie - die NIC - kurz stromlos und verliert deshalb jegliche Einstellungen.

Deshalb in "/etc/modprobe.d" eine Datei "e1000e.conf" anlegen mit

Code: Alles auswählen

options e1000e EEE=0
als Inhalt.
Evtl. noch

Code: Alles auswählen

# depmod -ae
# update-initramfs -u
absetzen.
Ob es dann geht? Beim rumg**glen scheint "e1000e" mit "EEE" ein bischen buggy zu sein,
zumindest mit älteren Treibern/Hardware.

DirkHo
Beiträge: 52
Registriert: 10.05.2004 08:13:11

Re: "Energy Efficient Ethernet" permanent deaktivieren

Beitrag von DirkHo » 22.04.2019 10:51:03

Hallo,

leider hat das bei mir nicht funktioniert. Ich habe dann auch noch bisschen weiter gegoogled und bin auf folgendes gestoßen: https://bbs.deepin.org/forum.php?mod=vi ... tid=143496

Dabei wird ein eigener Service angelegt, der beim Boot ausgeführt wird. Damit ist nach dem (Neu-)Start EEE deaktiviert.
root@server:~# ethtool --show-eee enp0s31f6
EEE Settings for enp0s31f6:
EEE status: disabled
Tx LPI: 17 (us)
Supported EEE link modes: 100baseT/Full
1000baseT/Full
Advertised EEE link modes: 100baseT/Full
1000baseT/Full
Link partner advertised EEE link modes: 100baseT/Full
1000baseT/Full
Wenn ich dann aber mit wol.exe oder MagicPacket (da gebe ich rein die Mac-Adresse ein und muss nicht das Kommando selbst zusammensetzen) versuche den Rechner aufzuwecken, wacht er leider trotzdem nicht auf. :(

Ich denke mal, einen Log, o.ä. dafür gibt es nicht oder eine Möglichkeit anders zu sehen, ob das WOL richtig aktiviert ist?! Zumindest konnte ich nichts finden. :(

Ich wünsche euch noch frohe Ostern und viele Grüße

Dirk

Antworten