Automount eines SMB Shares klappt nicht

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
Mandarine
Beiträge: 82
Registriert: 03.05.2005 07:59:28

Automount eines SMB Shares klappt nicht

Beitrag von Mandarine » 17.03.2021 11:56:03

Hallo,

ich betreibe einen Samba Server auf Debian 10.8 Basis und verbinde einige Windows 10 Rechner und einen Linux Rechner mit Debian 10.8 und Xfce 4.16. Wenn ich die SMB Freigaben manuell einbinde funktioniert alles einwandfrei, aber das automatische einhängen beim Login klappt nicht.

So sieht meine FSTAB aus:

Code: Alles auswählen

//192.168.2.83/USER /home/USER/Daten cifs noauto,users,uid=1000,gid=100,credentials=/home/USER/.smbcredentials 0 0
//192.168.2.83/austausch /home/USER/Austausch cifs noauto,users,uid=1000,gid=100,credentials=/home/USER/.smbcredentials 0 0
//192.168.2.83/media /home/sUSER/Media cifs noauto,users,uid=1000,gid=100,credentials=/home/USER/.smbcredentials 0 0
Ich habe dann ein Sricpt erstellt ".mountsmb"

Code: Alles auswählen

#!/bin/sh
#
mount ~/Daten
mount ~/Media
mount ~/Austausch
und das über den Xfce Autostart eingebunden. Dabei wird auch eine .desktop Datei in "~/.config/autostart" erzeugt:

Mountsmb.desktop

Code: Alles auswählen

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=MountSMB
Comment=
Exec=/home/sascha/.mountsmb
OnlyShowIn=XFCE;
RunHook=0
StartupNotify=false
Terminal=false
Hidden=false
Trotzdem werden die Laufwerke beim login nicht eingebunden. Wenn ich das Skript .mountsmb manuell aufrufe klappt es.

Ich habe auch schon versucht die Freigaben in der FSTAB ohne die Option "noauto" direkt einzubinden, aber auch das schlägt fehl. Hier hilft dann nur ein "mount -a" als "root".

Warum wird das Skript "Mountsmb.desktop" nicht ausgeführt? Hat da jemand eine Idee?

Danke.

Benutzeravatar
unitra
Beiträge: 524
Registriert: 15.06.2002 21:09:38
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kölle

Re: Automount eines SMB Shares klappt nicht

Beitrag von unitra » 17.03.2021 18:24:20

Keine Ahnung warum das Autostarskript nicht funktioniert. Benutze lieber Debianautofs, dann braucht man nicht mit gebastelten Skripten im Startmenü beim Autostart Irgendetwas zu hinterlegen. Sondern das Mounten funktioniert dann automatisch beim Zugriff auf die Netzfreigabe. Das ist zuverlässiger und einfacher als diese Skripte beim Anmelden.

Mandarine
Beiträge: 82
Registriert: 03.05.2005 07:59:28

Re: Automount eines SMB Shares klappt nicht

Beitrag von Mandarine » 17.03.2021 19:24:24

Ganz ehrlich, habe mich gerade an AutoFS versucht, das klappt bei mir noch weniger. Außerdem benötige ich kein automatisches einhängen bei Bedarf und kein Aushängen nach Timeout.

Die Lösung über die fstab funktioniert ja im Prinzip, und der Server auf den ich zugreife ist 24/7h im Netzwerk erreichbar ... gibt es keine Lösung für den Autostart?

Benutzeravatar
jph
Beiträge: 914
Registriert: 06.12.2015 15:06:07
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Greven/Westf.

Re: Automount eines SMB Shares klappt nicht

Beitrag von jph » 17.03.2021 20:37:17

Wenn du systemd verwendest, verwendest du einfach einen Automount: Wiki-Artikel zum Thema Netzlaufwerke einbinden

Antworten