[gelöst] CUPS: http://localhost:631/admin: Ich kann die Konfiguration nicht mehr rückgängig machen

Einrichten des Druckers und des Drucksystems, Scannerkonfiguration und Software zum Scannen und Faxen.
Antworten
Anschfust
Beiträge: 44
Registriert: 22.04.2020 11:01:52

[gelöst] CUPS: http://localhost:631/admin: Ich kann die Konfiguration nicht mehr rückgängig machen

Beitrag von Anschfust » 18.06.2021 07:58:19

Hallo zusammen

Ich habe in den Einstellungen auf "http://localhost:631/admin" einen Haken gesetzt und jetzt kann ich ihn nicht mehr herausnehmen.

Hier seht Ihr, was genau ich gemacht habe:

1. Firefox geöffnet
2. http://localhost:631/admin aufgerufen
3. Kontrollkästchen bei "Kerberos-Authentifizierung verwenden" angekreuzt
4. auf die die Schaltfläche "Eistellungen ändern" gedrückt
5. Kontrollkästchen bei "Kerberos-Authentifizierung verwenden" entfernt
6. auf die die Schaltfläche "Eistellungen ändern" gedrückt

Bild:
gallery/image/3223

Ich hätte erwartet, dass es jetzt zum vorherigen Zustand zurückkehrt.
Aber folgendes passiert: Die CPU Auslastung ist 100% und Firefox verfällt in den ewigen Aktualisierungsmodus.

Wenn ich die Schaltfläche "Konfigurationsdatei bearbeiten" wähle und dann im nächsten Fenster die aktuelle Konfiguration mit der Konfiguration vergleiche, die ich nach dem Klick auf die Schaltfläche "Standardkonfigurationsdatei verwenden" erhalten habe, dann sehe ich keinen Unterschied.
-> Ich hätte erwartet, dass sich die beiden Unterscheiden, da ich ja wie oben beschrieben eine Änderung vorgenommen habe. Ist das nicht die zugehörige Konfigurationsdatei?

Bitte beachten: Ich brauche keine spezielle Kerberos-Autentifizierung. Ich habe Kerberos nicht konfiguriert. Ich habe nur mit den Einstellungen herumgespielt in der Hoffnung sie wieder zurückstellen zu können.

Wie kann ich das zurückstellen? Bzw. welches ist die Config Datei, die wirklich diese Einstellung repräsentiert?

Konntet Ihr das Verhalten nachvollziehen? Verhält sich das auf Eurem System auch so?

Danke.
Zuletzt geändert von JTH am 18.06.2021 09:41:07, insgesamt 2-mal geändert.
Grund: CUPS im Titel erwähnt

Benutzeravatar
TRex
Moderator
Beiträge: 6931
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: http://localhost:631/admin: Ich kann die Konfiguration nicht mehr rückgängig machen

Beitrag von TRex » 18.06.2021 08:38:53

Nein, ich hab nie den Reiz verspürt, das zu tun, aber wenn du mal im Netz danach suchst, findest du neben Leidensgenossen auch ne Lösung hier:

https://ubuntuforums.org/showthread.php ... st11714193
The documentation of cupsd.conf says that `Kerberos Authentication` is denoted with `Negotiate` keyword and making cups to use local groups and user passwds is denoted with `Basic`, so i changed the
defalt authentication to `Basic`, changing the line below;
...
DefaultAuthType Negotiate # old one,
...

...
DefaultAuthType Basic # new one,
...

The rest of the regions requiring authentication in cupsd.conf file uses Default authentication method, so changing the default method yields changing all of them, i.e.,

...
<Location /admin/conf>
AuthType Default
...

After that i killed the cups daemon and performed a re-start,

# sudo cupsd

Now it worked for me and i can use username: root and pass: <my-root-passwd> to administrate the server.
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

MSfree
Beiträge: 7347
Registriert: 25.09.2007 19:59:30

Re: http://localhost:631/admin: Ich kann die Konfiguration nicht mehr rückgängig machen

Beitrag von MSfree » 18.06.2021 08:53:52

Hallo Werkstatt, ich habe ein Problem mit meinem Auto

Was haben sie denn für ein Auto?

Ein rotes.

Anschfust
Beiträge: 44
Registriert: 22.04.2020 11:01:52

Re: http://localhost:631/admin: Ich kann die Konfiguration nicht mehr rückgängig machen

Beitrag von Anschfust » 18.06.2021 09:34:35

Vielen Dank @TRex . :THX: :D

Obwohl ich vorgängig im Internet eine Lösung gesucht habe, habe ich Deinen Link nicht gefunden. Vielen Dank. Der hat mir sehr geholfen.

Man muss also einfach in der Datei "/etc/cups/cupsd.conf" ca. auf der 9ten Zeile (je nachdem wie viele #-Kommentare man hat) den Eintrag

Code: Alles auswählen

DefaultAuthType Negotiate
auf

Code: Alles auswählen

DefaultAuthType Basic
andern.

Danach ein Neustart und das Problem ist gelöst. :facepalm:
(Einen Prozess oder Daemon zu killen war bei mir nicht nötig)
Anschfust hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 07:58:19
Wenn ich die Schaltfläche "Konfigurationsdatei bearbeiten" wähle und dann im nächsten Fenster die aktuelle Konfiguration mit der Konfiguration vergleiche, die ich nach dem Klick auf die Schaltfläche "Standardkonfigurationsdatei verwenden" erhalten habe, dann sehe ich keinen Unterschied.
-> Ich hätte erwartet, dass sich die beiden Unterscheiden, da ich ja wie oben beschrieben eine Änderung vorgenommen habe. Ist das nicht die zugehörige Konfigurationsdatei?
Ich muss mich korrigieren. Die beiden Konfigurationen unterscheiden sich doch. Ich weiss nicht wo oder wie ich da hingeschaut habe.

Antworten