Font beim Drucken mit lp einstellen

Einrichten des Druckers und des Drucksystems, Scannerkonfiguration und Software zum Scannen und Faxen.
Antworten
ropri8
Beiträge: 40
Registriert: 22.02.2008 08:37:56

Font beim Drucken mit lp einstellen

Beitrag von ropri8 » 26.01.2012 17:38:30

Hallo!
Ich habe Squeeze im Grundsystem (ohne Grafische Oberfläche) installiert;
Ich möchte nun beim Drucken von Text-Files mit lp einen Font angeben, da der Standard-Font auf dem HP Laserjet CP1515N schlecht lesbar (sehr "dünn") ist.
Ich habe schon jede Menge herumgesucht und nichts gefunden;
Wenn man beim lp keinen Font mit-angeben kann (was ich befürchte), so sollte es zumindest möglich sein, den Standard-Font zu ändern, nur wie ??

Gruß,
Roman

dillo
Beiträge: 303
Registriert: 28.05.2005 19:53:56

Re: Font beim Drucken mit lp einstellen

Beitrag von dillo » 27.01.2012 05:54:06

Interessante Frage.....

Vielleicht hilft dir ja ein workaround:
[...]in /usr/share/cups/fonts I renamed the 'Courier' font text file as 'NotCourierAnymore', and copied 'Courier-Bold' onto 'Courier'. It worked! the 'lp' command output is darker and more readable to the researcher's elderly eyes.
siehe: http://ubuntuforums.org/archive/index.p ... 61940.html

evtl lässt sich auch über lpoptions was drehen.

Viel Erfolg
dillo

ropri8
Beiträge: 40
Registriert: 22.02.2008 08:37:56

Re: Font beim Drucken mit lp einstellen

Beitrag von ropri8 » 27.01.2012 08:00:26

Hallo!
Danke für den Tipp - mir fehlt aber da noch der Durchblick:

Unter usr/share/cups/fonts sind bei mir folgende Dateien enthalten:
FreeMono.ttf
FreeMonoBold.ttf
FreeMonoBoldOblique.ttf
FreeMonoOblique.ttf
Monospace
Monospace-Bold
Monospace-BoldOblique
Monospace-Oblique

Der DefautFont in der Datei /etc/cups/ppd/HP_Color_LaserJet_CP1515n ist aber auf "Courier" gestellt ....

Also wo ist da der Zusammenhang ?

Gruß,
Roman

dillo
Beiträge: 303
Registriert: 28.05.2005 19:53:56

Re: Font beim Drucken mit lp einstellen

Beitrag von dillo » 27.01.2012 14:02:35

ropri8 hat geschrieben: Der DefautFont in der Datei /etc/cups/ppd/HP_Color_LaserJet_CP1515n ist aber auf "Courier" gestellt ....

Also wo ist da der Zusammenhang ?
kann ich dir jetzt auch nicht sagen, aber wenn der Ausdruck momentan wie du schreibst "sehr dünn" ist, würde ich erst mal in der ppd deines Druckers als default einen fetten (Bold) einstellen und schauen, was sich tut.
Vor dem Editieren der ppd den cups-daemaon stoppen und danach wieder starten!

Gruß
dillo

ropri8
Beiträge: 40
Registriert: 22.02.2008 08:37:56

Re: Font beim Drucken mit lp einstellen

Beitrag von ropri8 » 27.01.2012 14:14:10

Hallo!

Den DefaultFont in der ppd-Datei habe ich versuchsweise schon geändert - hat aber keinerlei Wirkung gezeigt.
Und ja - den cupsd hatte ich dabei vorher gestoppt und dann wieder gestartet....

Gruß,
Roman

ropri8
Beiträge: 40
Registriert: 22.02.2008 08:37:56

Re: Font beim Drucken mit lp einstellen

Beitrag von ropri8 » 04.03.2013 14:29:33

Hallo!
Ich möchte das Thema nochmals aufwärmen, da ich noch keine Lösung gefunden habe.
Hat vielleicht doch noch jemand einen Tipp, wie ich den Font ändern könnte?

Ach ja, mir wäre natürlich auch geholfen, wenn ich die Sättigung auf Treiber- (Linux-)seite verstellen (erhöhen) könnte.
Am Drucker selbst habe ich sie schon auf ein Maximum gestellt ...

Roman

cosmac
Beiträge: 4551
Registriert: 28.03.2005 22:24:30

Re: Font beim Drucken mit lp einstellen

Beitrag von cosmac » 04.03.2013 18:48:52

hi,

die meisten Laserjet haben extra für den Zweck eine Einstellung, etwa so:

System Setup Menu -> Print Quality -> Courier Font -> Regular / Dark
Beware of programmers who carry screwdrivers.

ropri8
Beiträge: 40
Registriert: 22.02.2008 08:37:56

Re: Font beim Drucken mit lp einstellen

Beitrag von ropri8 » 18.03.2013 10:41:08

Hallo!
Entschuldige die späte Rückmeldung.
Ich habe nun die Einstellungen direkt am Drucker angesehen - Schrift Courier ist auf "Dunkel" gestellt - mehr geht nicht. Beim Ausdruck wirkt es aber alles andere als dunkel ...

Übrigens habe ich mir mal vom Drucker die konfigurierten Schriften ausgeben lassen. Also da sieht das Schriftbild sehr gut aus - viel dunkler, als wenn ich vom PC drucke.
Ich weiß alllerdings nicht, wie ich ihm (dem Drucker) beibringen soll, daß er Textdateien, die er vom PC zum Drucken erhält, auch so schön dunkel drucken soll.
Das Problem ist übrigens nicht nur auf Debian beschränkt - auch wenn ich von Windows Textdateien (aus Texteditor) drucke, sind die sehr blaß.

Roman

Benutzeravatar
xanvader
Beiträge: 148
Registriert: 03.12.2008 02:24:29

Re: Font beim Drucken mit lp einstellen

Beitrag von xanvader » 22.03.2013 08:49:57

1. Versuch: how-do-i-change-the-font-size-when-using-lp-on-linux

Code: Alles auswählen

enscript -FCourier12 myfiletoprint.txt -d KONICA-MINOLTA-C652-Series
2. Versuch: …ich weiss nicht ob es was aendern wuerde am Ausdruck, wenn du mal die Optionen fuer die Grafikdarstellung beim Ausdruck, verstaerkst. Siehe mal meine Uebersetzung:
Einstellung der Farbsaettigung von Grafiken

-o saturation=persent → Farbsaettigung der Grafik, dadurch die Anzeige des Farbstands kontrollieren.

Code: Alles auswählen

lp -o saturation=persent <dateiname>
lpr -o saturation=persent <dateiname>
persent (Prozent) → Zahl von 0 bis 200 bestimmen die Farbsaettigung.
Farbsaettigung von 0 → Schwarz/Weiss Druck
Farbsaettigung von 200 → Extrem Hohe Farbsaettigung

Grundeinstellung ist 100.
3. Versuch; …oder vllt.:
Use the postprint option. Check the man pages on this command:
Here is an example of printing in landscape with 50 lines with a font size of 9:

Code: Alles auswählen

/usr/lib/lp/postscript/postprint -pland -l 50 -s 9 <filename> | lp -d printer
4. Versuch:…Font Size when printing too big...., wenn dein Drucker PCL code versteht.
5. Versuch:…lese bitte mal den Abschnitt: 14.1.3. nenscript and enscript, vllt. hilft er dir weiter.
6. Versuch:…dann haette ich noch von den Nachbarn Fedora: Default printer font
So, back in /usr/share/cups/fonts I renamed the 'Courier' font text file as 'NotCourierAnymore', and copied 'Courier-Bold' onto 'Courier'. It worked! the 'lp' command output is darker and more readable to the researcher's elderly eyes.

CLearly, this is not the correct way to do this, but it works. If anyone knows the correct way to change the default 'lp' font on this system (RHEL4 and CUPS), please advise.
…Fonts in diesem Ordner, bei mir, sind nur:

Code: Alles auswählen

/usr/share/cups/fonts/FreeMono.ttf
/usr/share/cups/fonts/FreeMonoBold.ttf
/usr/share/cups/fonts/FreeMonoBoldOblique.ttf
/usr/share/cups/fonts/FreeMonoOblique.ttf
It has not been a great spirit without an admixture of madness.
by Lucius Annaeus Seneca (4 vChr - 65)

ropri8
Beiträge: 40
Registriert: 22.02.2008 08:37:56

Re: Font beim Drucken mit lp einstellen

Beitrag von ropri8 » 26.03.2013 11:02:05

Hallo!
@xanvader, danke für deine ausführliche Antwort!

Leider hatte ich bis jetzt noch keinen Erfolg.

zu 1.) enscript ist nicht installiert
zu 2.) davon hätte ich mir am meisten versprochen - hat aber nichts gebracht (getestet beim Ausdruck einer normalen Text-Datei)
zu 3.) ab /usr/lib/... ist der angegebene Pfad nicht mehr auffindbar, d. h. postprint ist vermutlich nicht installiert
zu 4.) nicht die Fontgröße, sonderen die Sättigung / Sichtbarkeit der einzelnen Zeichen möchte ich verstellen
zu 5.) siehe 1.)
zu 6.) die Seite hatte ich schon mal entdeckt, kann das aber bei mir nicht nachvollziehen.

Wenn möglich, möchte ich eine Änderung des Fonts bzw. der Sättigung ohne Zusatzprogramme erreichen; sollte dann nur mit lp funktionieren, aber wie ?

Roman

Antworten