Cups findet Bluetooth Drucker nicht

Einrichten des Druckers und des Drucksystems, Scannerkonfiguration und Software zum Scannen und Faxen.
Antworten
dmant
Beiträge: 188
Registriert: 09.10.2017 10:28:29

Cups findet Bluetooth Drucker nicht

Beitrag von dmant » 21.10.2017 11:45:02

Hallo,

ich habe hier einen HP OfficeJet 150 Mobile Printer. Allerdings kann ich ihn nicht installieren.

Ich habe dann veruscht mittels

Code: Alles auswählen

 hcitools -scan
den Drucker zu finden. Das hat auch funktioniert. Vorher habe ich die hplib installiert.

Ich habe dann zur GUI gewechselt und bei Drucker suchen unten eingegeben bluetooth//HIER_DIE_BT_ADRESSE_OHNE_DOPPELPUNKTE/

Aber dann sagt er "keinen Drucker gefunden".

Ich bin nach dieser Seite vorgegangen: http://www.free-it.org/archiv/talks/pap ... paper.html

Wenn ich eine "standart" printers.conf nehme und bei DeviceURI bluetooth...... eintrage dann kann ich drucken. Allergings kommen dann nur hyroglypische Zeichen.

Also die einzige printers.conf die in gefunden habe sieht so aus

Code: Alles auswählen

# Printer configuration file for CUPS v1.1.23
<DefaultPrinter HL-1050>
Info HL-1050
DeviceURI bluetooth://050C1B107416/
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
Wie kann ich da Treiber etc. angeben?

Vielleicht kann mir jemand weiter helfen. Ich denke an ein Treiber Problem.

Benutzeravatar
Drache
Beiträge: 710
Registriert: 22.11.2009 05:49:55

Re: Cups findet Bluetooth Drucker nicht

Beitrag von Drache » 21.10.2017 12:11:34

Weiß nicht, ob es hilft, aber laut

http://www.zdnet.com/article/hands-on-s ... d-windows/

Was ich so rauslese ist:

Benötigte Pakete: bluez-cups
Treiber: OfficeJet 150 Mobile l511



ignorierbares Klugscheiß-PS.: Standarte (mit e!) ist eine Art Fahne, i.d.R. bei militärischen Einheiten.
“Don't you think that if I were wrong, I'd know it?” (Dr. Sheldon Cooper)
XFCE: alt,steinhart,langweilig,immer noch da.

dmant
Beiträge: 188
Registriert: 09.10.2017 10:28:29

Re: Cups findet Bluetooth Drucker nicht

Beitrag von dmant » 21.10.2017 12:19:37

Hi,

das paket habe ich bereits installiert.

Code: Alles auswählen

root@Area51:~# hcitool scan
Scanning ...
	74:46:A0:38:F6:88	OJL511MY399810FB
root@Area51:~# sdptool browse 74:46:A0:38:F6:88
Browsing 74:46:A0:38:F6:88 ...
Service Name: OPP
Service RecHandle: 0x10000
Service Class ID List:
  "OBEX Object Push" (0x1105)
  "Public Browse Group" (0x1002)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 1
  "OBEX" (0x0008)
Profile Descriptor List:
  "OBEX Object Push" (0x1105)
    Version: 0x0100

Service Name: IMAGING
Service RecHandle: 0x10001
Service Class ID List:
  "Imaging Responder" (0x111b)
  "Public Browse Group" (0x1002)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 2
  "OBEX" (0x0008)
Profile Descriptor List:
  "Imaging" (0x111a)
    Version: 0x0100

Service Name: COM0
Service RecHandle: 0x10002
Service Class ID List:
  "Serial Port" (0x1101)
  "Public Browse Group" (0x1002)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 3

Service Name: Hardcopy Cable Replacement
Service RecHandle: 0x10003
Service Class ID List:
  "HCR Print" (0x1126)
  "Public Browse Group" (0x1002)
  "Hardcopy Cable Replacement" (0x1125)
  "" (0x0100)
  "" (0x0012)
  "" (0x0014)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 8193
  "HCRP-Ct" (0x0012)
Language Base Attr List:
  code_ISO639: 0x656e
  encoding:    0x6a
  base_offset: 0x100
Profile Descriptor List:
  "Hardcopy Cable Replacement" (0x1125)
    Version: 0x0100

root@Area51:~# 

Antworten