saned masked nach Hardware-Ausfall

Einrichten des Druckers und des Drucksystems, Scannerkonfiguration und Software zum Scannen und Faxen.
Antworten
mitscherdinger
Beiträge: 204
Registriert: 08.02.2006 00:57:42

saned masked nach Hardware-Ausfall

Beitrag von mitscherdinger » 01.03.2020 11:56:55

Hi!
An meinem NAS hing über mehrere Jahre ein Canon Scanner. Das Netzwerk ist in so weit eingerichtet, dass jeder per WLAN oder Kabelnetz auf den Scanner zugreifen kann. Letztlich wollte ich was scannen, ging nicht. Ich also ins NAS und nachgeschaut:

Code: Alles auswählen

# systemctl status saned
● saned.service
   Loaded: masked (Reason: Unit saned.service is masked.)
   Active: inactive (dead)
Mal versucht, den Service mittels "systemctl unmask saned.service" wieder flott zu bekommen, aber systemctl blieb, obwohl das Programm den Befehl ohne Fehlermeldung beendet hatte, dabei, dass saned "masked" ist. USB-Kabel aus dem NAS gezogen, ins Laptop eingesteckt: Aha! Der Scanner macht keinen Mucks mehr! Glücklicherweise denselben Scanner nochmal auf Ebay-Kleinanzeigen gefunden. Beim Verkäufer vorbei gefahren, Scanner eingesteckt, funktioniert, bezahlt, gegangen, daheim angekommen, Scanner in NAS eingesteckt, saned ist weiterhin "masked", auch nach dem Befehl an systemctl, saned wieder zu demaskieren. Okay: Reboot! NAS wieder hochgefahren, saned ist "masked". Und bleibt das auch.

Code: Alles auswählen

# scanimage -L
Created directory: /var/lib/snmp/mib_indexes
device `plustek:libusb:001:004' is a Canon CanoScan N1240U/LiDE30 flatbed scanner
Eigentlich sollte es sich doch wieder demaskieren lassen… Was mach ich falsch?

schwedenmann
Beiträge: 4611
Registriert: 30.12.2004 15:31:07
Wohnort: Wegberg

Re: saned masked nach Hardware-Ausfall

Beitrag von schwedenmann » 01.03.2020 12:10:19

Hallo


Ev hilft dir das:
https://feeding.cloud.geek.nz/posts/set ... sing-sane/

Stichwort saned.socket

mfg
schwedenmann

mitscherdinger
Beiträge: 204
Registriert: 08.02.2006 00:57:42

Re: saned masked nach Hardware-Ausfall

Beitrag von mitscherdinger » 01.03.2020 12:31:57

Leider nein:

Code: Alles auswählen

# systemctl status saned.socket 
● saned.socket - saned incoming socket
   Loaded: loaded (/etc/systemd/system/saned.socket; enabled; vendor preset: enabled)
   Active: active (listening) since Sun 2020-03-01 12:20:30 CET; 6min ago
   Listen: [::]:6566 (Stream)
 Accepted: 3; Connected: 0;
   CGroup: /system.slice/saned.socket

Mär 01 12:20:30 rappelkiste systemd[1]: Listening on saned incoming socket.
…und trotzdem lässt sich saned.service nicht demaskieren.

mitscherdinger
Beiträge: 204
Registriert: 08.02.2006 00:57:42

Re: saned masked nach Hardware-Ausfall

Beitrag von mitscherdinger » 01.03.2020 12:33:26

Bin in dem Link alles durch gegangen. Ich finde nichts, was bei mir falsch laufen könnte…

KP97
Beiträge: 2080
Registriert: 01.02.2013 15:07:36

Re: saned masked nach Hardware-Ausfall

Beitrag von KP97 » 01.03.2020 17:03:46

Das scheint wohl normal zu sein, ist mir vorher aber auch noch nie aufgefallen.
Mein Canon LiDE 220 ist einsatzbereit, mit simple-scan oder xsane kann ich scannen, und erhalte bei der Abfrage auch folgende Ausgabe:
MB@MB:~$ systemctl status saned
● saned.service
Loaded: masked (Reason: Unit saned.service is masked.)
Active: inactive (dead)
MB@MB:~$ scanimage -L
device `genesys:libusb:001:006' is a Canon LiDE 220 flatbed scanner
Prüfe mal das Kabel, bei meinem alten LiDE 30 war das defekt, evtl. hast Du Glück und es ist nur das.

mitscherdinger
Beiträge: 204
Registriert: 08.02.2006 00:57:42

Re: saned masked nach Hardware-Ausfall

Beitrag von mitscherdinger » 01.03.2020 18:40:40

Ich hab dasselbe Kabel in meinem Laptop genutzt, bevor ich's ins NAS gesteckt habe. Zudem startet "scanimage >/dev/null" per ssh auf dem NAS lokal einen Scan-Vorgang. Nur über's Netzwerk will's nicht. Dabei habe ich nichts an der Konfiguration geändert. Also, zumindest kann ich mich nicht erinnern, nach dem Defekt etwas geändert zu haben…

Benutzeravatar
orcape
Beiträge: 1402
Registriert: 07.11.2008 18:37:24
Wohnort: 50°36'23.99"N / 12°10'20.66"E

Re: saned masked nach Hardware-Ausfall

Beitrag von orcape » 01.03.2020 19:22:52

Hi mitscherdinger,
ich denke Du hast da ein anderes Problem beim Scannen über das Netzwerk.
Die Aussage des "maskierten Saned.service" hängt wohl mit der
Umstellung auf Systemd zusammen. Schau Dir das mal an....
https://wiki.ubuntu.com/SystemdForUpstartUsers
Es sollte also ganz normal sein, das Dir das als maskiert angezeigt wird. Hier mal zum Vergleich....

Code: Alles auswählen

root@orca:~#systemctl status saned.socket
● saned.socket - saned incoming socket
     Loaded: loaded (/lib/systemd/system/saned.socket; enabled; vendor preset: enabled)
     Active: active (listening) since Sun 2020-03-01 17:00:36 CET; 1h 49min ago
   Triggers: ● saned@0.service
     Listen: [::]:6566 (Stream)
   Accepted: 0; Connected: 0;
      Tasks: 0 (limit: 4582)
     Memory: 44.0K
     CGroup: /system.slice/saned.socket

Mär 01 17:00:36 orca systemd[1]: Listening on saned incoming socket.

root@orca:~#systemctl status saned
● saned.service
     Loaded: masked (Reason: Unit saned.service is masked.)
     Active: inactive (dead)
Entweder ist Dir das vorher noch nicht aufgefallen, Du hast ein neues System aufgespielt oder ein Update hat dann automatisch Systemd autorisiert.
Bei mir funktioniert das so einwandfrei, obwohl ich mit dem HP-Multifunktionsgerät anfangs Probleme hatte es überhaupt zum scannen über das Netzwerk zu bewegen.
Nun dürfte es auch noch ein Unterschied sein, ob der Scanner ein USB-Scanner oder ein Netzwerkscanner ist.
Ist es ein USB-Scanner, so sollte sich auf dem NAS sowohl mit scanimage -L, wie auch mit sane-find-scanner ein Ergebnis erzielen lassen.
Hängt der Scanner im "gleichen" Netzwerk als Netzwerkscanner, dann funktioniert nur scanimage -L bzw. scanimage -A .
Du hast also hier definitiv ein anderes Problem, warum Dein Scanner nicht will und um Dir gezielt helfen zu können, braucht es wohl noch ein paar mehr Infos.
Im übrigen habe ich mit Cannon leider wenig Erfahrung, da bei mir nur HP am Start ist, und das seit Jahren.
Wenn es aber schon einmal ging und am NAS geht es noch, so liegt das Problem wohl entweder im Netzwerk oder an den Clients.
Gruß orcape

AxelMD
Beiträge: 443
Registriert: 15.03.2009 08:02:11

Re: saned masked nach Hardware-Ausfall

Beitrag von AxelMD » 04.04.2020 16:07:35

Hallo TE, hast Du dein Problem lösen könne, wenn ja wie?

MfG

AxelMD

mitscherdinger
Beiträge: 204
Registriert: 08.02.2006 00:57:42

Re: saned masked nach Hardware-Ausfall

Beitrag von mitscherdinger » 06.04.2020 22:49:18

Leider funktioniert's bei mir immer noch nicht. Ich schließe den Scanner an meinem Laptop an, wenn ich ihn brauche. Dabei habe ich allerdings festgestellt, dass er nicht mit jedem USB-Port funktioniert. Ich muss wohl noch ein paar Versuche durchführen, damit ich weiß, was nicht geht. Der Hinweis mit dem defekten Kabel scheint in die richtige Richtung zu gehen: Es liegt wohl nicht an Systemd, dass es nicht funktioniert.
Meine Vermutung ist gerade die, dass durch das Update auf das aktuelle stable im Februar die Power-Einstellungen für den USB-Port verändert wurden und deswegen der Scanner nicht mehr funktioniert, weil er mehr Strom braucht, als ihm zur Verfügung gestellt wird. Dieser Verdacht muss aber erst mal belegt werden.…

Antworten