Live-System findet Scanner nicht

Einrichten des Druckers und des Drucksystems, Scannerkonfiguration und Software zum Scannen und Faxen.
Antworten
rei19
Beiträge: 68
Registriert: 19.03.2020 16:39:19

Live-System findet Scanner nicht

Beitrag von rei19 » 27.03.2020 10:12:43

Ich habe debian 10 mit XFCE installiert und damit findet XSane mein hp-Photosmart C3180 (Drucker, Scanner). Um LXDE auszuprobieren habe ich das als Live-System gestartet, aber damit findet XSane das Gerät nicht.
Würde es auch fest installiert nicht funktionieren? Und habt ihr bitte Tipps, um es zum Laufen zu bringen?

Benutzeravatar
SubOptimal
Beiträge: 1704
Registriert: 10.01.2005 23:25:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: bei Frankfurt

Re: Live-System findet Scanner nicht

Beitrag von SubOptimal » 27.03.2020 12:03:10

Hallo @rei19,

was mir spontant einfällt und du auf dem Live System prüfen kannst.

- Ist der User in der Gruppe scanner?

Code: Alles auswählen

# in der Konsole ausführen
groups
- Wenn der User in dieser Gruppe ist, dann mal schauen was Sane findet.

Code: Alles auswählen

sane-find-scanner
mit Gruß
SubOptimal

rei19
Beiträge: 68
Registriert: 19.03.2020 16:39:19

Re: Live-System findet Scanner nicht

Beitrag von rei19 » 27.03.2020 18:09:40

Der Scanner ist in der Gruppe "user". Er wird aber nur gefunden wenn "sane-find-scanner" als root ausgeführt wird. Was bedeutet das nun? Kann man daran etwas ändern?

Code: Alles auswählen

user@debian:~$ groups
user cdrom floppy audio dip video plugdev netdev bluetooth scanner
user@debian:~$ sane-find-scanner
  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not open USB device 0x0930/0x6545 at 001:004: Access denied (insufficient permissions)
could not open USB device 0x03f0/0x5611 at 001:005: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 005:001: Access denied (insufficient permissions)
could not open USB device 0x413c/0x2011 at 004:003: Access denied (insufficient permissions)
could not open USB device 0x413c/0x1005 at 004:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 003:001: Access denied (insufficient permissions)
could not open USB device 0x0461/0x4d22 at 002:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 002:001: Access denied (insufficient permissions)
  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
user@debian:~$ sudo sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [HP], product=0x5611 [Photosmart C3100 series]) at libusb:001:005
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
user@debian:~$ 

Benutzeravatar
SubOptimal
Beiträge: 1704
Registriert: 10.01.2005 23:25:46
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: bei Frankfurt

Re: Live-System findet Scanner nicht

Beitrag von SubOptimal » 27.03.2020 20:50:25

Der user user ist in der Gruppe scanner. Das ist schonmal gut.

Code: Alles auswählen

user@debian:~$ groups
user cdrom floppy audio dip video plugdev netdev bluetooth scanner
Auf dem Live System wird das Scanner-Device nicht mit den erforderlichen Berechtigungen für die Gruppe scanner eingebunden. Daher ist er sichtbar, wenn Du das Kommando als root ausführst.

Sehr wahrscheinlich wird es auf dem Desktop Rechner mittels einer udev-Regel gelöst. Schau mal in /etc/udev/rules.d/ ob es da eine Datei gibt, die zu diesen gefundenen Werten

Code: Alles auswählen

vendor=0x03f0 [HP], product=0x5611
passt.

könnte z.B. einen Eintrag enthalten, der so ausschaut

Code: Alles auswählen

ATTR{idVendor}=="03f0", ATTR{idProduct}=="5611" ... GROUP="scanner"
Wie man dass dann auf dem Live-System (read-only Filesystem) einstellen könnte, da hab ich grad keine Idee.

mit Gruß
SubOptimal

Benutzeravatar
smutbert
Beiträge: 7085
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Live-System findet Scanner nicht

Beitrag von smutbert » 27.03.2020 21:01:03

sind im Live-System überhaupt die Scanntertreiber installiert?
(für das Gerät vermutlich Debianlibsane-hpaio, das enthält dann auch die udev-Regeln und es braucht eventuell auch Debianhplip um einfach zu funktionieren)

fischic
Beiträge: 422
Registriert: 24.12.2019 12:25:08

Re: Live-System findet Scanner nicht

Beitrag von fischic » 27.03.2020 22:08:09

Wie man dass dann auf dem Live-System (read-only Filesystem) einstellen könnte, da hab ich grad keine Idee.
Ich könnte mir vorstellen, dass es funktioniert, wenn man unter Umgehung von udev die notwendigen Rechte unter /dev/bus/(usb?) selber setzt. Das wäre rauszukriegen und dazu dürfte ein wenig Übung mit der "console" hilfreich sein. :wink:

Bei mir ist das

Code: Alles auswählen

/dev/bus/usb/004
/dev/bus/usb/004/002
Könnte systemischen Erkenntnisgewinn bringen. Ich glaube aber nicht, dass mein Vorschlag akzeptabel erscheint. :wink:

fischic
Beiträge: 422
Registriert: 24.12.2019 12:25:08

Re: Live-System findet Scanner nicht

Beitrag von fischic » 27.03.2020 23:30:54

SubOptimal hat geschrieben:Der user user ist in der Gruppe scanner. Das ist schonmal gut.

Er hatte zwar Subjekt und Objekt anders herum definiert, aber wir hoffen mal, dass er gemeint hat, was du verstanden hast. :wink:

Ich könnte mir vorstellen, dass es funktionieren könnte, wenn man unter Umgehung von udev die notwendigen Rechte unter /dev/bus/(usb?) selber setzt. Das wäre rauszukriegen und dazu dürfte ein wenig Übung mit der "console" hilfreich sein. :wink:

Bei mir ist das z.Z.

Code: Alles auswählen

/dev/bus/usb/004
/dev/bus/usb/004/002
Könnte systemischen Erkenntnisgewinn bringen. Ich glaube aber nicht, dass mein Vorschlag akzeptabel erscheint. :wink:

Benutzeravatar
willy4711
Beiträge: 3714
Registriert: 08.09.2018 16:51:16

Re: Live-System findet Scanner nicht

Beitrag von willy4711 » 28.03.2020 08:50:11

Also in meinem Live-System (Virtualbox mit lxqt-live-iso )ist weder cups noch hplip installiert.
Wie soll das dann gehen :?: :?:
Bild
Edit:
@rei19
Wenn du LXQT dann installiert hast, funktioniert das selbstverständlich genauso wie in Xfce, nachdem Debianhplip installiert ist.

rei19
Beiträge: 68
Registriert: 19.03.2020 16:39:19

Re: Live-System findet Scanner nicht

Beitrag von rei19 » 28.03.2020 17:26:55

smutbert hat geschrieben: ↑ zum Beitrag ↑
27.03.2020 21:01:03
sind im Live-System überhaupt die Scanntertreiber installiert?
(für das Gerät vermutlich Debianlibsane-hpaio, das enthält dann auch die udev-Regeln und es braucht eventuell auch Debianhplip um einfach zu funktionieren)
Die Idee "fehlende Treiber" kam mir gestern auch. Im installierten System sind 7 hp-assoziierte Pakete installiert. Beim Live-System weiß ich nicht, wie ich das nachschauen kann, weil es keine Paketverwaltung hat.

Benutzeravatar
willy4711
Beiträge: 3714
Registriert: 08.09.2018 16:51:16

Re: Live-System findet Scanner nicht

Beitrag von willy4711 » 28.03.2020 17:41:47

rei19 hat geschrieben: ↑ zum Beitrag ↑
28.03.2020 17:26:55
Beim Live-System weiß ich nicht, wie ich das nachschauen kann, weil es keine Paketverwaltung hat.
Wieso hat es die nicht ? Hat sie - kannt bloss nicht ein update /upgrade fahren.

Habe es doch oben vorgemacht

rei19
Beiträge: 68
Registriert: 19.03.2020 16:39:19

Re: Live-System findet Scanner nicht

Beitrag von rei19 » 28.03.2020 19:02:10

willy4711 hat geschrieben: ↑ zum Beitrag ↑
28.03.2020 17:41:47
rei19 hat geschrieben: ↑ zum Beitrag ↑
28.03.2020 17:26:55
Beim Live-System weiß ich nicht, wie ich das nachschauen kann, weil es keine Paketverwaltung hat.
Wieso hat es die nicht ? Hat sie - kannt bloss nicht ein update /upgrade fahren.
Habe es doch oben vorgemacht
Ich schreibe jetzt vom installierten System aus. Mag sein, dass ich "blind" war? Ich habe aber LXDE, und du hast es mit LXQT ausprobiert.

Benutzeravatar
willy4711
Beiträge: 3714
Registriert: 08.09.2018 16:51:16

Re: Live-System findet Scanner nicht

Beitrag von willy4711 » 28.03.2020 19:14:14

rei19 hat geschrieben: ↑ zum Beitrag ↑
28.03.2020 19:02:10
Ich habe aber LXDE, und du hast es mit LXQT ausprobiert.
Aber - ich vermute mal - dass es in LXDE doch auch ein Terminal gibt ?
Brauchst doch einfach nur abschreiben.

Benutzeravatar
rockyracoon
Beiträge: 708
Registriert: 13.05.2016 12:42:18

Re: Live-System findet Scanner nicht

Beitrag von rockyracoon » 28.03.2020 22:05:25

@rei19:
willy4711 mag es imho gerne "forcierend pädagogisch". Er meint sicher mit schlichteren Worten formuliert:
Starte ein Live-System und überprüfe in einem Terminal mit Root-Rechten das Paketsystem (statt mit der graphischen Oberfläche des Synaptic-Paketmanagers).
Im vorliegenden Fall würde dann der Befehl lauten: "dpkg -l hplip", was man in der Abbildung von willy4711 oben sehen und "abschreiben" kann.
Die Grammatik:
dpkg > "Paketsystem" / -l > "liste auf" / hplip > "gesuchter Treiber"

rei19
Beiträge: 68
Registriert: 19.03.2020 16:39:19

Re: Live-System findet Scanner nicht

Beitrag von rei19 » 29.03.2020 09:45:39

@willy4711: Ja, sorry. Ich hatte mir das Bild nicht genauer angeschaut. Ja, bei LXQT sind hplip und cups auch nicht vorhanden.
Dann wird's installiert wohl funktionieren. Ich muss vorher aber noch herausfinden, ob LXDE auch bei debian durch LXQT ersetzt werden soll.

@rockyracoon: Danke für die genauen Erklärungen. Das war aber nicht nötig. Ich bin zwar noch Anfänger, aber das von @willy4711 hatte ich schon verstanden.

Antworten