Server beept in unregelmäßigen Abständen

Alle weiteren Dienste, die nicht in die drei oberen Foren gehören.
Antworten
Benutzeravatar
speefak
Beiträge: 81
Registriert: 27.04.2008 13:54:20

Server beept in unregelmäßigen Abständen

Beitrag von speefak » 13.08.2018 11:14:55

Hallo,

Seit einigen Wochen beept mein Debian 9 Server in unregelmäßigen Abständen ( alle paar Stunden kommt ein einfach "beep"), ohne dass Fehler auftreten. Ich habe die Logs durchgesehen und nach dem ausführen eines beeps gesucht aber nichts gefunden. Temperaturen etc alles im grünen Bereich. Hat jmd ggf, Tipps was es sein könnte oder wo ich noch nach der Ursache suchen sollte ? Kann es sich um eine Warnung vor versagender Hardware handeln ?

MSfree
Beiträge: 3666
Registriert: 25.09.2007 19:59:30

Re: Server beept in unregelmäßigen Abständen

Beitrag von MSfree » 13.08.2018 11:30:29

speefak hat geschrieben: ↑ zum Beitrag ↑
13.08.2018 11:14:55
Ich habe die Logs durchgesehen
Auch die Logs vom BIOS/UEFI?

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21721
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: Server beept in unregelmäßigen Abständen

Beitrag von KBDCALLS » 13.08.2018 12:01:38

Was steht denn im Handbuch des Boards dazu ? Je nach Bios können die Beep-Codes was anderes bedeuten.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Benutzeravatar
speefak
Beiträge: 81
Registriert: 27.04.2008 13:54:20

Re: Server beept in unregelmäßigen Abständen

Beitrag von speefak » 13.08.2018 12:51:02

Es ist eine nicht UEFI installation und der beep kommt im laufenden Betrieb. Der Server läuft 24/7 bisher bin ich von einem System statt Bios Event ausgegangen. Bios Logs finde ich im syslog ?

MSfree
Beiträge: 3666
Registriert: 25.09.2007 19:59:30

Re: Server beept in unregelmäßigen Abständen

Beitrag von MSfree » 13.08.2018 13:57:30

speefak hat geschrieben: ↑ zum Beitrag ↑
13.08.2018 12:51:02
Es ist eine nicht UEFI installation
Das spielt keine Rolle. Moderne Rechner haben kein BIOS mehr, die kommen nur noch mit UEFI und emulieren das alte BIOS bestenfalls.
Es ist eine nicht UEFI installation und der beep kommt im laufenden Betrieb.
Wir hatten hier eine Dell-Workstation, die auch immer mal wieder gepiepst hat. Beim Reboot war auf dem Bildschirm (noch vor dem Startbild des Betriebssystems) zu lesen, daß einer der Lüfter gelegendlich kein Drehzahlsignal liefert.
Bios Logs finde ich im syslog ?
Nein, die Logs hält das BIOS/UEFI selbst in seinem Speicherbereich. Du mußt also direkt ins BIOS/UEFI.

Meinem Gefühl nach handelt sich bei dem Piepsen um Signale von der Hardwareüberwachung des Mainboards und nicht um irgendwelche Ereignisse, die im Linux passieren. Linux würde Fehler auch eher in den Logs protokollieren als zu Piepsen.

Benutzeravatar
Meillo
Moderator
Beiträge: 5130
Registriert: 21.06.2005 14:55:06
Wohnort: Balmora
Kontaktdaten:

Re: Server beept in unregelmäßigen Abständen

Beitrag von Meillo » 13.08.2018 22:52:08

Bei mir war es die USV, die gebeept hat, weil die Akkus schlecht geworden sind. Bist du dir sicher, dass es der Server selbst ist, der beept? ;-)
Use ed(1) once in a while!

Benutzeravatar
niemand
Beiträge: 11976
Registriert: 18.07.2004 16:43:29

Re: Server beept in unregelmäßigen Abständen

Beitrag von niemand » 14.08.2018 05:54:02

Ich hab auch schon von Boards gehört, die unregelmäßig piepsen, wenn die kleine Batterie für die BIOS-Einstellungen langsam leer wird.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

Benutzeravatar
speefak
Beiträge: 81
Registriert: 27.04.2008 13:54:20

Re: Server beept in unregelmäßigen Abständen

Beitrag von speefak » 14.08.2018 11:52:35

Ich bin zu 100% sicher das der Server beept ( mit einem beep via remote shell auf dem server getestet ). Das System läuft komplett passiv ( seit 2 Jahren ) und es gab NIE Probleme, nicht mal während der heißen Tage. CPU Temperatur liegt bei 60°C das restliche System kommt nicht über 40°C , SSD weist auch keine Fehler auf - Plausibel erscheint mir die BIOS Batterie - nach 4-5 Jahren könnte die ggf leer sein.

Jana66
Beiträge: 3946
Registriert: 03.02.2016 12:41:11

Re: Server beept in unregelmäßigen Abständen

Beitrag von Jana66 » 14.08.2018 15:23:32

Musste wohl doch mal den Server neu starten (so lokal). Das BIOS hat vielleicht was zu melden. Im BIOS sogenannte "Post Messages" + lesbare Anzeigedauer (5 sec) einschalten. Die Anzeige kommt vor Start des Betriebssystems. Eventuell Fotoapparat bereitlegen.

Hat dein Server überhaupt eine einfache Grafik/GPU/VGA? Wirst ein lokales Display am Server brauchen.

Ansonsten serielle Konsole mit USB-auf-seriell-Adapter mit PL2303-Chip https://www.amazon.de/s/ref=nb_sb_ss_im ... YTNG6GERWU
und Linux-PC mit Debianminicom oder Debianscreen oder Windows-Pendants wie Debianputty. Ich bin mit UGREEN immer gut (komplettes Kabel) und preiswert gefahren. Das BIOS muss jedoch (Boot-) Ausgaben an serielle Schnittstellen unterstützen, kaum in Consumer-Hardware implementiert.

Sowas wie IPMI (Intel ME) bzw. AMD-Pendant vorhanden? Bei Servern oft spezieller Port, spezielles BIOS, Intel ME unterstützt.
https://www.thomas-krenn.com/de/wiki/IPMI_Grundlagen

Übrigens putziger Server, der piepen kann, also Lautsprecher hat. Eher Consumer-Hardware?

Edit:
Bei meinem Serverlein ("umgewidmeter" Thin Client) hat ein Ersatznetzteil mal Piepse des Servers erzeugt. Nach etlichen Betriebstagen erst, Anlass war (verweigerter) Neustart. Pieps-Folge und zugehörige Blinkfolge der Power-LED stand im Hardware-Manual und stimmte mit Post-Messages überein. Pieps-Folgen hörten nach 4 Zyklen auf, Power-LED-Blinkfolge wurde permanent wiederholt bis zur "Fehlerbeseitigung" (Original-Netzteil). Also Neustart besser im "Wartungsfenster". :wink:
Zuletzt geändert von Jana66 am 14.08.2018 16:24:00, insgesamt 1-mal geändert.
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

r4pt0r
Beiträge: 1226
Registriert: 30.04.2007 13:32:44
Lizenz eigener Beiträge: MIT Lizenz

Re: Server beept in unregelmäßigen Abständen

Beitrag von r4pt0r » 14.08.2018 16:23:43

Wenn es sich wirklich um Serverhardware handelt und ein redundantes Netzteil verbaut ist: Auf gelockertes Netzkabel prüfen! Hatte einen solchen Fall schonmal; das Netzteil gab dann sporadisch ein leises piepsen/kratzen (+ hörbares brutzeln vom Stecker!) von sich.

Falls ein Wechselrahmen bzw backplane verbaut ist: vor allem "prosumer" Geräte haben Temperaturfühler + Buzzer verbaut. Die Fühler sind oft so dämlich angebracht (IcyDock...), dass sich mit der Zeit Staub darauf absetzt und die gemessene Temperatur verfälscht. Der buzzer wird dann sporadisch kurz aktiviert da meistens auch eine hysterese für den Temperaturalarm fehlt.

Benutzeravatar
speefak
Beiträge: 81
Registriert: 27.04.2008 13:54:20

Re: Server beept in unregelmäßigen Abständen

Beitrag von speefak » 30.09.2018 10:54:36

Fehler gefunden : Bios Batterie war leer.

Antworten