[geloest] Dependencies bareos

Alle weiteren Dienste, die nicht in die drei oberen Foren gehören.
Antworten
sharbich
Beiträge: 126
Registriert: 27.09.2013 21:12:40

[geloest] Dependencies bareos

Beitrag von sharbich » 10.01.2019 00:18:39

Hallo Ihr Lieben,
ich möchte auf mein Debian Stretch 9.6 bareos 18.2 installieren. Obwohl ich auf die aktuelle Version in der
/etc/apt/source.lis.d/bareos.list verweise

Code: Alles auswählen

deb http://download.bareos.org/bareos/release/18.2//Debian_9.0 /
wird immer die Version 16.2 installiert. Folgende Dependencies wird mir angezeigt:

Code: Alles auswählen

Reverse Depends: 
  bareos:i386,bareos
Dependencies: 
18.2.4rc2-86.1 - bareos-director (5 18.2.4rc2-86.1) bareos-storage (5 18.2.4rc2-86.1) bareos-client (5 18.2.4rc2-86.1) bareos:i386 (32 (null)) 
16.2.4-3+deb9u2 - bareos-director (5 16.2.4-3+deb9u2) bareos-storage (5 16.2.4-3+deb9u2) bareos-client (5 16.2.4-3+deb9u2) bareos:i386 (32 (null)) 
Provides: 
18.2.4rc2-86.1 - 
16.2.4-3+deb9u2 - 
Reverse Provides: 
Was kann ich machen das die 18.2 Version installiert wird?
Lieben Gruß von Stefan Harbich
Zuletzt geändert von sharbich am 11.01.2019 22:51:58, insgesamt 2-mal geändert.

cronoik
Beiträge: 1712
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Dependencies bareos

Beitrag von cronoik » 10.01.2019 02:12:32

Hat das Repo vielleicht eine niedrigere Prioritaet? Zeig mal bitte:

Code: Alles auswählen

apt-cache policy bareos
Hilf mit unser Wiki zu verbessern!

eggy
Beiträge: 1739
Registriert: 10.05.2008 11:23:50

Re: Dependencies bareos

Beitrag von eggy » 10.01.2019 03:05:07

Die meisten Paketverwaltungstools lassen sich sagen, welche Version sie installieren sollen.
Versuchs mal mit "apt-get/aptitude install paket=version".
Und das // im Pfad sieht etwas komisch aus, aber daran wirds wohl nicht liegen.

sharbich
Beiträge: 126
Registriert: 27.09.2013 21:12:40

Re: Dependencies bareos

Beitrag von sharbich » 10.01.2019 06:43:43

cronoik hat geschrieben: ↑ zum Beitrag ↑
10.01.2019 02:12:32
Hat das Repo vielleicht eine niedrigere Prioritaet? Zeig mal bitte:

Code: Alles auswählen

apt-cache policy bareos

Code: Alles auswählen

stefan.harbich@dsme01:~$ sudo apt-cache policy bareos
bareos:
  Installiert:           (keine)
  Installationskandidat: 16.2.4-3+deb9u2
  Versionstabelle:
     18.2.4rc2-86.1 500
        500 http://download.bareos.org/bareos/release/18.2//Debian_9.0  Packages
     16.2.4-3+deb9u2 700
        700 http://deb.debian.org/debian stretch/main amd64 Packages
Wie kommt das? Wie kann ich die Priorität ändern? Das war vorher nicht so? Okay ich hatte mein Debian Server Stretch von 9.5 auf 9.6 aktuallisiert und da hatte ich Probleme mit dem mariadb-common Paket (Fehlende Abhängigkeiten). Ich hatte dann das mariadb Paket komplett gelöscht und neu installiert. Durch die Abhängigkeiten wurde auch ein Teil der bareos Pakete deinstalliert. Danach hatte ich bei den bareos Paketen das Problem der unterschiedlichen Versionen. Ggf. hängt das irgendwie zusammen?

cronoik
Beiträge: 1712
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Dependencies bareos

Beitrag von cronoik » 10.01.2019 09:55:03

sharbich hat geschrieben: ↑ zum Beitrag ↑
10.01.2019 06:43:43
Wie kommt das? Wie kann ich die Priorität ändern? Das war vorher nicht so? Okay ich hatte mein Debian Server Stretch von 9.5 auf 9.6 aktuallisiert und da hatte ich Probleme mit dem mariadb-common Paket (Fehlende Abhängigkeiten). Ich hatte dann das mariadb Paket komplett gelöscht und neu installiert. Durch die Abhängigkeiten wurde auch ein Teil der bareos Pakete deinstalliert. Danach hatte ich bei den bareos Paketen das Problem der unterschiedlichen Versionen. Ggf. hängt das irgendwie zusammen?
Das hast du geaendert und das muss man sich nun mal konkret ansehen. Zeig mal bitte:
/etc/apt/preferences
und den Inhalt aller Dateien unter /etc/apt/preferences.d/
Hilf mit unser Wiki zu verbessern!

sharbich
Beiträge: 126
Registriert: 27.09.2013 21:12:40

Re: Dependencies bareos

Beitrag von sharbich » 11.01.2019 22:49:46

Hallo ich habe einfach die Pin-Priority für alle Pakete auf 500 gesetzt. Danach wurde die aktuelle Version installiert.
/etc/apt/preferences

Code: Alles auswählen

Package: *
Pin: release a=stable
## Pin-Priority: 700
Pin-Priority: 500

Antworten