Solaar funktioniert nicht

Alle weiteren Dienste, die nicht in die drei oberen Foren gehören.
Antworten
vdvogt
Beiträge: 327
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Solaar funktioniert nicht

Beitrag von vdvogt » 02.01.2020 15:09:54

Hallo,
ich habe eine Logitech K830 Multimedia-Tastatur.
Die hat standardmaessig auf den Fx-Tasten Sonderfunktionen liegen.
Leider muss man, wenn man die F1- bis F12-Tasten druecken will, dazu auch noch die Fn-Taste druecken, was recht umstaendlich ist.
Von logitech gibt es das win-Programm Options, mit dem man dies umkehren kann.
An einem Windoof-Pc habe ich das Programm installiert und dort die Umstellung vorgenommen.
Als ich die Tastatur dann wieder an meinen Debian 10-Rechner gehaengt habe, war wieder alles beim Alten, die Umstellung ist also leider nicht dauerhaft.
Im Internet habe ich dann das Programm solaar gefunden mit dem das auch unter Linux machbar sein soll.
Also habe ich solaar aus den Debian-Repos installiert: Version 0.9.2+dfsg-9
Einige zeitlang hat solaar zwar die Tastatur angezeigt, aber ich habe nirgendwo die Funktion gefunden, wo ich die Fx-Tasten umstellen kann.
Und seit gestern findet solaar meine Tastatur auch nicht mehr.
Was ist da los???
Wer kann mir helfen, dieses Problem zu loesen?
Wer hat auch solche, oder aehnliche Erfahrungen mit solaar gemacht?
Scheinbar ist solaar seit einiger Zeit verwaist. Die letzte Version ist schon sehr alt.
Der urspruengliche Maintainer kuemmert sich wohl nicht mehr darum und es scheint sich auch kein anderer gefunden zu haben, der das Programm weiterpflegt.
Trotzdem ist es noch in den Debian-Repos zu finden.

Viele Gruesse
Veit

pferdefreund
Beiträge: 3657
Registriert: 26.02.2009 14:35:56

Re: Solaar funktioniert nicht

Beitrag von pferdefreund » 03.01.2020 08:06:49

Falls du etwas programmieren kannst, halt den Quellcode besorgen und ein paar Testausgaben einbauen. Oder mal mit strace laufen lassen und schauen, wo es klemmt. Das ist halt der Vorteil von Open Source. Hab mir so auch schon öfter mal geholfen und alte, nicht mehr gepflegte Programme angepasst - wie beispielsweise das Jack-Plugin für den - ja ich nutze den noch xmms Player.

vdvogt
Beiträge: 327
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Solaar funktioniert nicht

Beitrag von vdvogt » 03.01.2020 12:36:08

Hallo,
ich widerrufe alles, was ich vorher gesagt habe;-)))
Ich habe mir in einer Nachtsitzung die Version 1.0.1 installiert und da funktioniert alles so wie es sein soll.

Gruesse
Veit

Benutzeravatar
ingo2
Beiträge: 898
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: Solaar funktioniert nicht

Beitrag von ingo2 » 12.01.2020 22:53:00

Ich hatte auch mit Debiansolaar nach Upgrade von Stretch auf Buster zu kämpfen. War immer Glücksache, wenn es mal korrekt gestartet ist und das Batteriesymbol im XFCE-Panel erschienen ist. Meist gab es die Meldung "keinen Receiver gefunden" mit einem gelben Zahnrad im Panel.

Habe jetzt auch mal die 1.0.1 aus Sid installiert - die scheint anstandslos zu funktionieren, aber:

Das Panel-Icon ist mit viel Fantasie als eine schwarze Batterie auf fast schwarzem Hintergrund zu erahnen.

Weiß Jemand, wie ich das schöne dezente weiß/grüne Batteriesymbol mit transparentem Hintergrund:

Code: Alles auswählen

/usr/share/icons/gnome/24x24/devices/battery.png
wieder hinbekomme?

vdvogt
Beiträge: 327
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Solaar funktioniert nicht

Beitrag von vdvogt » 13.01.2020 12:07:46

Hallo ingo2,
oeffne in /usr/share/applications als root die datei solaar.desktop mit einem Editor Deines Vertrauens.
Dort gibt es die Zeile:

Code: Alles auswählen

Icon=solaar
Diese Zeile kannst du aendern und ein icon einfuegen, das dir gefaellt.
Z.B. hier besorgen:
https://icon-icons.com/de/symbol/solaar/94095
oder
http://www.iconarchive.com/show/flatwok ... -icon.html

Speichere das Icon in einem Ordner deiner Wahl und fuege in diese Zeile den absoluten Pfad zu dieser Icondatei ein.
Z.B.:

Code: Alles auswählen

Icon=/pfad/zu/diesem/icon/solaar.png

Gruesse
Veit

Benutzeravatar
ingo2
Beiträge: 898
Registriert: 06.12.2007 18:25:36
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Wo der gute Riesling wächst

Re: Solaar funktioniert nicht

Beitrag von ingo2 » 13.01.2020 12:26:35

vdvogt hat geschrieben: ↑ zum Beitrag ↑
13.01.2020 12:07:46
Hallo ingo2,
oeffne in /usr/share/applications als root die datei solaar.desktop ...
Das hilft mir leider nicht. Damit kann ich zwar das normale Icon wie es in Menüs und Startern ändern, aber nicht die Batterieanzeige im Systray des XFCE-Panels.

Beim Start erscheint zwar kurz das "solaar-Icon" im Systray, das wird aber, sobald mein Trackball mit Batterie erkannt wurde, durch das Batteriesymbol (von XFCE oder Gnome, oder?) ersetzt - und das ist dunkelgrau auf schwarz :-(

EDIT:
Das Icon ist schwarz auf dunkelgrauem Hintergrund. Ist eine schematische Darstellung einer aufrecht stehenden Batterie mit 3 schwarzen Querbalkenb drin. Die zugehörige "Graphik" habe ich noch nicht gefunden.

EDIT #2:
Habe das Icon gefunden:

Code: Alles auswählen

/usr/share/icons/Adwaita/scalable/status/battery-full-symbolic.svg
EDIT #2:
leider nicht ganz korrekt. Das Solaar-Icon zeigt bei teilweise entladener Batterie auch weniger als 3 Balken an, und wenn die Batterie nur noch 30% hat, sogar zusätzlich ein Ausrufezeichen in der unteren rechten Ecke auf einem kleinen Quadrat mit orangenem Grund.

Antworten