Eigenes Repository, Stretch ignoriert die Release.gpg

Alle weiteren Dienste, die nicht in die drei oberen Foren gehören.
Antworten
Simon74
Beiträge: 61
Registriert: 06.10.2009 22:21:07

Eigenes Repository, Stretch ignoriert die Release.gpg

Beitrag von Simon74 » 02.07.2017 11:54:19

Hallo,

Neue Stretch Clients ignorieren mein eigenes Repository bzw. die Release.gpg.

Code: Alles auswählen

Ign:1 http://repo.myrepo.work ./ InRelease
OK:2 http://security.debian.org/debian-security stretch/updates InRelease
OK:3 http://repo.myrepo.work ./ Release
Holen:4 http://repo.myrepo.work ./ Release.gpg [473 B]
Ign:4 http://repo.myrepo.work ./ Release.gpg
Ign:5 http://mirror.myaptcacher.net:8080/debian stretch InRelease
OK:6 http://mirror.myaptcacher.net:8080/debian stretch-updates InRelease
OK:7 http://mirror.myaptcacher.net:8080/debian stretch Release
Es wurden 473 B in 1 s geholt (298 B/s).
Paketlisten werden gelesen... Fertig
W: GPG-Fehler: http://repo.myrepo.work ./ Release: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY D523BBF6D24CC66E
W: The repository 'http://repo.myrepo.work ./ Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Ich habe also einen neuen Public Key erzeugt, vor der Erstellung habe ich auf dem Jessie Reposerver die gpg.conf um folgende Zeilen erweitert:

Code: Alles auswählen

default-preference-list SHA512 SHA384 SHA256 SHA224 AES256 AES192 AES CAST5 BZIP2 ZLIB ZIP Uncompressed
cert-digest-algo SHA512
personal-digest-preferences SHA512 SHA384 SHA256

Neuen Schlüssel generiert, Pubkey exportiert und im Repository gespeichert, danach den neuen Public Key auf den Client geholt und ein apt-get update, hilft leider jedoch nicht, es kommt wieder selbige Ausgabe wie oben.

Code: Alles auswählen

wget -O - http://repo.myrepo.work/key.asc | apt-key add -

Was mache ich falsch, oder übersehe ich :?:

Simon74
Beiträge: 61
Registriert: 06.10.2009 22:21:07

Re: Eigenes Repository, Stretch ignoriert die Release.gpg

Beitrag von Simon74 » 03.07.2017 10:24:33

Ich darf die Lösung selbst hier reinschreiben :D

Lösung:
Verwenden von gpg2 anstatt gpg auf dem Debian Jessie Repository Server !

Also zum den Publickey zu erzeugen:
ALT:
gpg --armor --export "Mein Name" > key.asc
NEU:
gpg2 --armor --export "Mein Name" > key.asc

Und zum erzeugen der Release Datei zb. im Script..
ALT:
gpg2 --batch --no-tty --passphrase=blabla --output Release.gpg -ba Release
NEU:
gpg2 --batch --no-tty --passphrase=blabla --output Release.gpg -ba Release


Danach musste ich am Stretch Client nur noch den Publikey neu abholen und alles wird gut..
wget -O - http://repo.myrepo.work/key.asc | apt-key add -

Antworten