Asterisk, IAXModem, Hylafax oder doch Provider Problem?

Alle weiteren Dienste, die nicht in die drei oberen Foren gehören.
Antworten
dmant
Beiträge: 100
Registriert: 09.10.2017 10:28:29

Asterisk, IAXModem, Hylafax oder doch Provider Problem?

Beitrag von dmant » 24.10.2017 23:21:55

Hallo,

Ich habe hier einen laufenden Asterisk Server. Das Telefonieren lokal ist kein Problem. Mailboxabfrage und Echotest sind ebenfalls erfolgreich.

Das Telefonieren nach Extern und das erhalten von externen anrufen funktioniert ebenfalls. Eingehende Anrufe werden anhand der Rufnummer unterschieden und zugewiesen.

Ich habe sodann für den Fax Betrieb über Hylafax ein iaxmodem erstellt und konfiguriert. Bei Hylafax das Modem mittels faxaddmodem eingerichtet und das iaxmodem mit asterisk konfiguriert.

Das empfangen von Faxen funktioniert problemlos und auch die Zustellung per Email mittels FaxDispatch.

Das versenden von Faxen funktioniert hingegen nicht. Hier bekomme ich immer

Code: Alles auswählen

 No carrier Detected
Das empfangsgerät ist frei und kann faxen entgegen nehmen. Auch klingelt es und nimmt an. Danach kommt dann der Fehler. Wenn ich auf ein Telefon faxen und abnehme höre ich auch nicht die komischen Töne wie bei einem Fax sondern alle 2-3 Sekunden ein etwa 1/2 Sekunde langes "tuten". Und das so lange bis man auflegt. Also ob der nur anrufen aber nicht erkennt das abgenommen und das Fax gesendet werden kann.

Hier meine configs

sip.conf
https://nopaste.dmant.ovh/?v=Eej5quoosoo4

extensions.conf
https://nopaste.dmant.ovh/?v=oox5Ohr7ahy7

iax.conf
https://nopaste.dmant.ovh/?v=ei0Aiceubeiv

ttyIAX0
https://nopaste.dmant.ovh/?v=thaiya8OuL2s

config.ttyIAX0
https://nopaste.dmant.ovh/?v=Joh8it2aiboo

Vielleich weiß ja jemand weiter.

Benutzeravatar
bluestar
Beiträge: 326
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: Asterisk, IAXModem, Hylafax oder doch Provider Problem?

Beitrag von bluestar » 20.11.2017 17:00:58

So ähnliche Probleme hatte ich in der Konstellation auch ... Ich würde dir empfehlen nicht mehr IAXmodem und Hylafax zu setzen, sondern stattdessen den Faxempfang und Fax-Versand (falls nötig) direkt in Asterisk zu realisieren.

in etwa so:

Code: Alles auswählen

[from-ankommend]
exten => 0049237256XXX,1,Goto(fax-receive,${EXTEN},1)

[fax-receive]
exten => _X.,1,NoOp(Faxempfang)
exten => _X.,n,Set(FAXID=${UNIQUEID})
exten => _X.,n,Set(FAXNUMMER=${EXTEN})
exten => _X.,n,LOG(VERBOSE,"Faxempfang-Start: ${FAXID} CallerID ${CALLERID(num)} an ${FAXNUMMER} gestartet")
exten => _X.,n,Set(DATUM=${STRFTIME(${EPOCH},Europe/Berlin,%Y/%m/%d)})
exten => _X.,n,TrySystem(/bin/mkdir -p /var/spool/asterisk/fax/received/${DATUM} >/dev/null 2>&1)
exten => _X.,n,Set(FAXFILE=/var/spool/asterisk/fax/received/${DATUM}/${FAXID}.tiff)
exten => _X.,n,Set(CHANNEL(transfercapability)=3K1AUDIO)
exten => _X.,n,Answer()
exten => _X.,n,ReceiveFAX(${FAXFILE})
exten => _X.,n,Hangup()
exten => h,1,LOG(VERBOSE,"Faxempfang-Ende: ${FAXID} CallerID ${CALLERID(num)} an ${FAXNUMMER} beendet, Status: ${FAXSTATUS}")
exten => h,n,GotoIf($["${FAXSTATUS}" = "SUCCESS"]?h-SUCCESS,1)
exten => h,n,GotoIf($["${FAXSTATUS}" != "SUCCESS"]?h-FAILED,1)
exten => h-SUCCESS,1,System(/usr/local/bin/asterisk-fax-received.sh "${FAXFILE}" "${CALLERID(num)}" "${FAXNUMMER}" "${FAXPAGES}")
exten => h-FAILED,1,System(/usr/local/bin/asterisk-fax-received-failed.sh "${FAXNUMMER}" "${CALLERID(num)}" "${FAXSTATUSSTRING}")

Antworten