Bildschirm schwarz mit Kernel 4.9.0.3

Welches Modul/Treiber für welche Hardware, Kernel compilieren...
Antworten
Benutzeravatar
subson
Beiträge: 382
Registriert: 13.09.2005 10:14:04

Bildschirm schwarz mit Kernel 4.9.0.3

Beitrag von subson » 21.07.2017 17:48:04

Hallo,

installiert war Debian 8 mit dem 3.16er Kernel. Damit habe ich das Upgrade auf Debian 9 gemacht. Der Kernel war geblieben, hat nicht auf 4.9.0.3 aktualisiert.

Manuell habe ich dann linux-image-4.9.0-3-amd64 und die linux-headers-4.9.0-3-amd64 installiert. Die Installation lief problemlos durch. Wenn ich dann mit diesem Kernel starte, bekomme ich nach dem Anmelden auf KDE nur einen schwarzen Bildschirm, die Maus kann ich aber sehen.

Mit dem 3.16er Kernel und den Headers funktioniert alles. Ich habe öfter schon gelesen, das man die headers nicht braucht, ich meine aber früher mal gelesen zu haben, das opengl das benötigt. Das gefällt mir bei der Diashow bei Gwenview.

Das System ist ein Asus Laptop mit integrierter Intel Grafik.
hwinfo --gfxcard
09: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: _Znp.ZapTENYp3R0
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: "Intel 3rd Gen Core processor Graphics Controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x0156 "3rd Gen Core processor Graphics Controller"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x14c7
Revision: 0x09
Driver: "i915"
Driver Modules: "drm"
Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xf03f (rw)
IRQ: 42 (221260 events)
Module Alias: "pci:v00008086d00000156sv00001043sd000014C7bc03sc00i00"
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: "modprobe i915"
Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #9
Gruß subson

##########

Ich bin weg vom Fenster !

stillebucht
Beiträge: 20
Registriert: 30.10.2013 11:13:19

Re: Bildschirm schwarz mit Kernel 4.9.0.3

Beitrag von stillebucht » 27.07.2017 14:19:50

Das Problem liegt womöglich am verwendeten Intel-Grafiktreiber. Zwischen Debian 8 und 9 gibt es diesbezüglich eine wichtige Änderung: Ab Debian 9 wird für die meisten Intel-Grafikeinheiten der sog. kernel modesetting driver verwendet und nicht mehr wie bisher der Intel Treiber i915. Da bei deinem Upgrade der Kernel nicht aktualisiert wurde, blieb bei der manuellen Nachinstallation des neuen Kernels wohl etwas auf der Strecke, sei es die Konfiguration oder oder ein fehlendes Paket. Da ich selbst keine Intel-Grafik unter Debian nutze, kann ich nur raten, aber ich würde mal folgendes versuchen:

1) Das Kernel Modul i915 blacklisten
2) Schauen, ob du in der xorg Konfiguration einen Treiber angeben musst und xorg nicht versucht, weiter den i915 Treiber zu nutzen (da hab ich mich nie mit befasst, weil ich bisher mit den defaults nie Probleme hatte)

Benutzeravatar
subson
Beiträge: 382
Registriert: 13.09.2005 10:14:04

Re: Bildschirm schwarz mit Kernel 4.9.0.3

Beitrag von subson » 31.07.2017 17:55:41

Hallo, danke für den Hinweis.

Folgendes Paket war installiert: Debianxserver-xorg-video-intel

Dort steht ja
Von der Nutzung dieses Treibers wird abgeraten, wenn Ihre Hardware hinreichend aktuell ist (ca. 2007 und neuer). Sie können versuchsweise diesen Treiber deinstallieren und stattdessen den Server seinen eingebauten »modesetting«-Treiber nutzen lassen.
Wie lasse ich denn den eingebauten Treiber nutzen?

In der Debian-Referenz steht
Aktuelle Linux-Kernel enthalten gute Unterstützung für Grafikkarten und Eingabegeräte unter Nutzung von DRM, KMS und udev. Der X-Server wurde angepasst, um diese zu verwenden. Daher ist "/etc/X11/xorg.conf" üblicherweise auf Ihrem System auch nicht mehr vorhanden. Diese Parameter werden durch den Kernel konfiguriert.
Gruß subson

##########

Ich bin weg vom Fenster !

gordix
Beiträge: 1
Registriert: 05.04.2016 07:21:50

Re: Bildschirm schwarz mit Kernel 4.9.0.3

Beitrag von gordix » 10.08.2017 22:13:30

Hallo,
habe hier auch ein Asus-Laptop (UX305) mit ähnlichem Problem.
Nach einem Update auf Kernel 4.11.02 biieb der Monitor schwarz
Mit einem älteren Kernel (4.9.0.2) läuft aber das System.
Einem hilfreichen Hinweis habe ich hier gefunden:
https://bbs.archlinux.org/viewtopic.php ... 3#p1726023

Dananch funktioniert der Monitor bei mir wieder wieder.

Hier der hilfreiche Hinweis:
Enabling CSM in the BIOS solved the issue

Benutzeravatar
subson
Beiträge: 382
Registriert: 13.09.2005 10:14:04

Re: Bildschirm schwarz mit Kernel 4.9.0.3

Beitrag von subson » 11.08.2017 22:09:48

Also CSM war bei mir schon aktiviert.

Auch der 4.11 funktioniert bei mir nicht. Debianxserver-xorg-video-intel habe ich deinstalliert. Wie da ja steht, soll man
stattdessen den Server seinen eingebauten »modesetting«-Treiber nutzen lassen
Wie mache ich das?

Aufgefallen war mir beim Test mit dem 4.11. was interessantes:

nach dem Anmelden kommt die KDE Animation, das Bild blieb danach wie dann üblich schwarz, nur startete hier (zufällig ?) das Fenster vom KDE-Mixer, das konnte man sehen. Die Maus ist ja auch immer sichtbar, aber es lässt sich sonst nichts einblenden, weder re. Maus, noch die Kontrollleiste. Zum Glück geht das Abmeldemenü.
Gruß subson

##########

Ich bin weg vom Fenster !

Benutzeravatar
subson
Beiträge: 382
Registriert: 13.09.2005 10:14:04

Re: Bildschirm schwarz mit Kernel 4.9.0.3

Beitrag von subson » 17.08.2017 23:10:52

Ich habe noch mal den 4.11 er Kernel mit den headers installiert.

Die xorg.conf besteht ja nicht mehr. Stattdessen soll für xorg eine 20-intel.conf erstellt werden:

Code: Alles auswählen

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
EndSection
Diese habe ich in usr/share/X11/xorg.conf.d/ erstellt. Damit ist noch nicht mal der XServer (SDDM) gestartet. Also habe ich die 20-intel.conf wieder gelöscht. Interessanterweise startet debian jetzt mit dem 4.11 er Kernel, den 4.9 er werde ich auch noch testen. Warum das jetzt funktioniert, keine Ahnung, aber hauptsache es geht. Vielleicht muß bei Driver i915 rein?
hwinfo --gfxcard
13: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: _Znp.ZapTENYp3R0
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: "Intel 3rd Gen Core processor Graphics Controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x0156 "3rd Gen Core processor Graphics Controller"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x14c7
Revision: 0x09
Driver: "i915"
Driver Modules: "i915"
Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xf03f (rw)
Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
IRQ: 26 (6917 events)
Module Alias: "pci:v00008086d00000156sv00001043sd000014C7bc03sc00i00"
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: "modprobe i915"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Gruß subson

##########

Ich bin weg vom Fenster !

Benutzeravatar
subson
Beiträge: 382
Registriert: 13.09.2005 10:14:04

Re: Bildschirm schwarz mit Kernel 4.9.0.3

Beitrag von subson » 24.08.2017 22:50:11

Also irgendwas ist da komisch, irgendwo muss da noch was klemmen.

Der 4.9 er Kernel ging auch.

Nun habe ich es manchmal das beide, der 4.9 und 4.11 doch nicht funktionieren, manchmal ging es mit ab und wieder anmelden von KDE.

So langsam nervt das.
Gruß subson

##########

Ich bin weg vom Fenster !

Antworten