compilieren eines programmes scheitert wegen xproto

Welches Modul/Treiber für welche Hardware, Kernel compilieren...
Antworten
Benutzeravatar
Bloodrayne
Beiträge: 10
Registriert: 06.04.2007 15:24:23

compilieren eines programmes scheitert wegen xproto

Beitrag von Bloodrayne » 05.06.2018 17:43:11

Hallo, ich hoffe hier kann mir wer helfen, ich wollte ein Programm aus github compilieren, dies hab ich schon des öffteren gemacht aber aktuell hab ich folgendes Problem und weis nicht weiter

Code: Alles auswählen

checking for XAU... configure: error: Package requirements (xproto) were not met:
No package 'xproto' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables XAU_CFLAGS
and XAU_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
es steht zwar da was ich machen kann aber ich habe keine ahnung wie das geht was ich machen muss, soweit reichen meine Kenntnisse nicht und ich brauch das tool dringend, ich habe es unter Debian stretch und Ubuntu server probiert, bei beiden Systemen das gleiche,
hat zufällig jemand eine Ahnung was ich genau eingeben muss damit ich das Problem lösen kann?

folgende Pakete hab ich schon alles installiert, theoretisch müsste xproto dabei sein aber scheinbar fehlen wirklich irgend wo die Variablen, aber davon hab ich 0 plan :(

Code: Alles auswählen

apt-get install mc gcc git make intltool perl build-essential checkinstall cvs subversion git-core mercurial libgtkmm-3.0-dev
apt-get install xorg x11proto-core-dev libpthread-stubs0-dev libx11-dev libcairo2-dev xserver-xorg-dev qt5-default x11proto-bigreqs-dev
apt-get install libusbmuxd-dev libplist-dev  libplist++-dev libgnutls-dev libssl-dev python-dev
apt-get install usbmuxd automake autoconf libtool pkg-config cython doxygen
apt-get install xorg-dev
apt-get install pkg-config make xutils-dev libtool xserver-xorg-dev libx11-dev libxi-dev libxrandr-dev libxinerama-dev libudev-dev
apt-get install pkg-config make xutils-dev libtool xserver-xorg-dev-lts-vivid libx11-dev libxi-dev libxrandr-dev libxinerama-dev libudev-dev
Vielen Dank schonmal
BB
Milena

tobo
Beiträge: 513
Registriert: 10.12.2008 10:51:41

Re: compilieren eines programmes scheitert wegen xproto

Beitrag von tobo » 05.06.2018 20:17:33

Was man so liest, würde ich mal nach der Datei xproto.pc suchen und dann das Verzeichnis von xproto.pc nach PKG_CONFIG_PATH exportieren. Also in etwa sowas:

Code: Alles auswählen

$ export PKG_CONFIG_PATH="$(find / -name xproto.pc -exec dirname {} \; 2>/dev/null)"
Danach solltest du noch mit

Code: Alles auswählen

$ echo $PKG_CONFIG_PATH
schauen, ob genau ein Eintrag vorhanden ist. Danach kannst du Compilierungsprozess "in dieser Shell" neu anstoßen.

Benutzeravatar
Bloodrayne
Beiträge: 10
Registriert: 06.04.2007 15:24:23

Re: compilieren eines programmes scheitert wegen xproto

Beitrag von Bloodrayne » 07.06.2018 22:09:59

Halo, hab ich gemacht, hat aber leider auch nichts funktioniert.

hier mal was ich gemacht habe:

frisch aufgesetztes Debian 9 und ein frisch aufgesetztes Ubuntu Server

Code: Alles auswählen

apt-get install mc gcc git make intltool perl build-essential checkinstall cvs subversion git-core mercurial libgtkmm-3.0-dev meson gawk curl libtext-glob-perl node-glob libreadline-dev sudo libelf-dev
apt-get install xorg x11proto-core-dev libpthread-stubs0-dev libx11-dev libcairo2-dev xserver-xorg-dev qt5-default x11proto-bigreqs-dev xorg-dev  pkg-config xutils-dev xserver-xorg-dev
apt-get install libusbmuxd-dev libplist-dev  libplist++-dev libssl-dev python-dev usbmuxd automake autoconf libtool pkg-config cython doxygen libx11-dev libxi-dev libxrandr-dev libxinerama-dev libudev-dev
danach

Code: Alles auswählen

git clone git://github.com/escalade/LibreELEC.tv.git /LibreELEC
cd LiebreELEC
./scripts/create_addon makemkv
hat bisher immer alles funktioniert, der Escalade hat mir folgendes geschrieben gehabt:
Try adding "xorgproto" to the PKG_BUILD_DEPENDS
danach
You need to build from my tree.
aber irgendwie konnte ich mit seiner ersten aussage nichts anfangen mit der 2. hab ich dann versucht das ganze paket zu compilieren mit ./scripts/release image
kam dann aber irgendwann nen fehler dass das gzip keine gültiges format wäre.

das lustige ist, es ist auf beiden Systemen exakt die selben Meldungen bei Ubuntu und debian

hab schon endlos gegoogelt aber nicht wirklich was gefunden womit ich weiter komme :(

tobo
Beiträge: 513
Registriert: 10.12.2008 10:51:41

Re: compilieren eines programmes scheitert wegen xproto

Beitrag von tobo » 08.06.2018 00:30:08

Also bei mir hat das Ding ewig compiliert, bevor irgendwann (~8 min) irgendein perl Modul fehlte. Völlig aus dem Stehgreif und ohne irgendeine Veränderung an irgendwas vorzunehmen (genau wie du es hingeschrieben hast). Ausnahme: als normaler Benutzer und nicht als root (das ist dir auch ganz dringend anzuraten) und mit geändertem Verzeichnis zum git-Download und anschließendem cd. Das hier kennst du:
https://libreelec.wiki/compile
Dort ist die Vorgehensweise eine etwas andere aber ebenfalls als normaler Benutzer und die haben zu Beginn noch zusätzlich und als diff zu deiner Liste

Code: Alles auswählen

# apt-get install unzip wget xz-utils
installiert. Bei dir ist doch der Abbruch des Kompiliervorgangs relativ frühzeitig gekommen oder habe ich da was falsch verstanden?

Benutzeravatar
Bloodrayne
Beiträge: 10
Registriert: 06.04.2007 15:24:23

Re: compilieren eines programmes scheitert wegen xproto

Beitrag von Bloodrayne » 08.06.2018 16:20:17

Nein ich denke eher ziemlich kurz vor dem ende,
nun diese Pakete waren schon installiert,
bei mir hat der auch ehwig gearbeitet und beim ./scrips/image release
kommt nach ehwig langer Zeit folgende Meldung
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
das Problem das offizielle kann ich nicht nehmen weil ich das makemkv plugin benötige für die BD und BD4k Widergabe

und wenn ich nur das addon erstellen möchte bekomme ich immer diese Meldung und ich hab xproto schon mal manuell gedownloadet und compiliert aber hat auch nichts geholfen

Code: Alles auswählen

checking whether ln -s works... yes
checking for pathconf... yes
checking for XAU... configure: error: Package requirements (xproto) were not met:

No package 'xproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XAU_CFLAGS
and XAU_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

ich werd das mal so versuchen wie es in demlink steht evtl hab ich adnn ja mehr glück

tobo
Beiträge: 513
Registriert: 10.12.2008 10:51:41

Re: compilieren eines programmes scheitert wegen xproto

Beitrag von tobo » 08.06.2018 22:38:52

Mit

Code: Alles auswählen

./scripts/checkdeps
kannst du dir die fehlenden Abhängigkeiten anzeigen lassen. Das ändert allerdings nichts an der xproto-Geschichte. Auch nicht, wenn man mit "make clean" aufräumt und nochmal übersetzt. Habe da ein bisschen was probiert, habe aber letztendlich keine Ahnung, wie das mit "deinem Weg" funktionieren soll. Weder mit Setzen von PKG_CONFIG_PATH, noch über XAU_CFLAGS und XAU_LIBS. Bei den beiden letzten ging's dann kurzfristig weiter, aber das war auch eher geraten als gewusst. Ich würde an deiner Stelle den Weg gehen, den die Jungs empfehlen...

PS.: War aber ganz schön clever nicht zu erwähnen, dass 8 Minuten nur ein verschwindend kleiner Teil der Zeit ist, die der Prozess zum Compilieren unter Volllast benötigt!?

Benutzeravatar
Bloodrayne
Beiträge: 10
Registriert: 06.04.2007 15:24:23

Re: compilieren eines programmes scheitert wegen xproto

Beitrag von Bloodrayne » 09.06.2018 05:30:46

also nach dem offiziellen weg erhalte ich ebenfalls folgende Meldung

Code: Alles auswählen

  UNPACK   popt

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Makefile:12: die Regel für Ziel „image“ scheiterte
make: *** [image] Fehler 2
abhänigkeiten fehlen keine, das script wo der nicht findet hab ich auf die neue version geändert

Code: Alles auswählen

LibreELEC.tv/packages/devel/ncurses/package.mk
PKG_VERSION="6.1-20180129"

Version changed to

PKG_VERSION="6.1-20180203"
aber letztlich egal was ich mache komme ich bei keiner möglichkeit weiter.
Ich weis nicht wielange der gebraucht hat, hab den gestartet und einfach laufen lassen, irgendwann hab ich wider nachgeschaut und entweder weiter gemacht oder weiter laufen lassen

was hast du denn gemacht dass es weiter gegangen ist? wiegesagt der offizielle weg geht auch nicht, und wiegesagt das offizielle repo bringt mir nichts weil da das assodn fehlt

tobo
Beiträge: 513
Registriert: 10.12.2008 10:51:41

Re: compilieren eines programmes scheitert wegen xproto

Beitrag von tobo » 09.06.2018 13:22:49

Wie gesagt, das war erheblich mehr raten als Wissen und es dauerte keine Sekunde länger, bis der Abbruch kam. Es waren mehrere Versuche, genau weiß ich das auch nicht mehr, aber ungefähr

Code: Alles auswählen

export XAU_CFLAGS="-I..."
export XAU_LIBS="-L..."
und für die Punkte dann verschiedene Pfade eingesetzt, was mir da so halbwegs logisch erschien!? Das war alles irgendwie gleich falsch. Und auch beim Setzen von PKG_CONFIG_PATH macht das Teil ja überhaupt keine Anstalten, da irgendwas zu respektieren!? Da waren ja dann 3x xproto.pc im Entwicklungspfad und dann noch eine bei mir - lokal oder global gesetzt, alles komplett egal.

Was ich gelesen habe ist, dass dieses Teil ja auch kein offiziell unterstütztes Addon von denen ist?! Irgendwo habe ich ebenfalls gelesen, dass als versteckte Abhängigkeit für den Build unter Linux eine komplette Java-Installation vorausgesetzt wird. Ob das stimmt, weiß ich nicht und ob damit gemeint ist, dass die vom Script angedachte jre eigentlich eine jdk sein sollte, weiß ich auch nicht!?
Ich nehme mal an, dass du diesie Seiten kennst:
https://wiki.ubuntuusers.de/MakeMKV/
http://www.makemkv.com/forum2/
Ich kann dir da nicht weiterhelfen...

Antworten