gelöst Nach boot reagiert System träge

Welches Modul/Treiber für welche Hardware, Kernel compilieren...
Antworten
Benutzeravatar
Taomon
Beiträge: 603
Registriert: 08.03.2011 16:34:38
Lizenz eigener Beiträge: GNU Free Documentation License

gelöst Nach boot reagiert System träge

Beitrag von Taomon » 11.04.2019 13:00:06

Code: Alles auswählen

root@Taomon:/home/alex# lsb_release -rd
Description:	Debian GNU/Linux 9.8 (stretch)
Release:	9.8
root@Taomon:/home/alex# 
Seit längerer Zeit fällt mir auf, das debian nach einem Neustart oder Reboot sehr langsam reagiert.

Ich habe mir htop installiert und mal geguckt. Alle 4 Kerne sind zu 100% ausgelastet. Da fand ich einem make Befehl den ich mir nicht erklären kann. Leider zu schnell weg um zu sehen was das kompiliert werden soll.

Die Installation lief mal in einem anderen Notebook mit nvidia-Karte und dem unfreien Treiber. Ich bilde mir ein nvidia-treiber und auch virtualbox-ose vor dem Umbau deinstalliert zu haben.

Code: Alles auswählen

root@Taomon:/home/alex# ls -al /usr/src/
insgesamt 60
drwxr-xr-x 15 root root 4096 Apr 11 12:46 .
drwxr-xr-x 11 root root 4096 Mär 30  2014 ..
drwxr-xr-x 29 root root 4096 Jun  2  2013 alsa-driver-1.0.24
drwxr-xr-x  3 root root 4096 Jul 21  2018 libdvd-pkg
lrwxrwxrwx  1 root root   37 Aug  9  2016 linux -> /usr/src/linux-headers-3.16.0-4-amd64
drwxr-xr-x  3 root root 4096 Aug 14  2017 linux-headers-3.16.0-4-amd64
drwxr-xr-x  4 root root 4096 Jan 18 09:36 linux-headers-4.19.0-0.bpo.1-amd64
drwxr-xr-x  4 root root 4096 Jan 18 09:35 linux-headers-4.19.0-0.bpo.1-common
drwxr-xr-x  4 root root 4096 Feb 14 09:25 linux-headers-4.19.0-0.bpo.2-amd64
drwxr-xr-x  4 root root 4096 Feb 14 09:25 linux-headers-4.19.0-0.bpo.2-common
drwxr-xr-x  4 root root 4096 Apr 10 19:56 linux-headers-4.19.0-0.bpo.4-amd64
drwxr-xr-x  4 root root 4096 Apr 10 19:56 linux-headers-4.19.0-0.bpo.4-common
drwxr-xr-x  4 root root 4096 Feb 25 11:05 linux-headers-4.9.0-8-amd64
drwxr-xr-x  4 root root 4096 Feb 25 11:05 linux-headers-4.9.0-8-common
lrwxrwxrwx  1 root root   24 Dez 30 22:13 linux-kbuild-4.19 -> ../lib/linux-kbuild-4.19
lrwxrwxrwx  1 root root   23 Aug  6  2017 linux-kbuild-4.9 -> ../lib/linux-kbuild-4.9
drwxr-xr-x  3 root src  4096 Dez 14  2015 modules
drwxr-xr-x  3 root root 4096 Jan 19  2017 nvidia-legacy-340xx-340.101
lrwxrwxrwx  1 root root   32 Jan 25 21:41 vboxhost-5.2.26 -> ../share/virtualbox/src/vboxhost
Sieht nach Resten aus.

Code: Alles auswählen

root@Taomon:/home/alex# dpkg -l | egrep 'virtualbox|nvidia|dkms'
ii  virtualbox-5.2                                              5.2.26-128414~Debian~stretch                amd64        Oracle VM VirtualBox
root@Taomon:/home/alex# 


Was kann gefahrlos gelöscht werden.

Gruß Taomon
Zuletzt geändert von Taomon am 12.04.2019 12:45:45, insgesamt 1-mal geändert.
Bitte gelegentliche Schreibfehler übersehen. Ich habe ADHS. Danke.

Benutzeravatar
willy4711
Beiträge: 1342
Registriert: 08.09.2018 16:51:16

Re: Nach boot reagiert System träge

Beitrag von willy4711 » 11.04.2019 20:52:02

Was kann gefahrlos gelöscht werden.
Interessanter wäre ob sich die Kernel dazu noch in /boot herumtreiben

Code: Alles auswählen

ls -al /boot
erst dann kann man sehen, was gelöscht werden kann. Der Grund für die Verzögerungen ist das sicher nicht.

wo du virtualbox-5.2.26-128414 her hast ?
Aktuell in den Backports ist 5.2.24-1~bpo9+2: all
Ich würde das erstmal deinstallieren
Bei Oracle ist virtualbox-6.0_6.0.4-128413~Debian~stretch aktuell.

Aber alles (wahrscheinlich) nicht der Grund für dein Problem.

Hast du Debianhaveged installiert ?
Erklärung : viewtopic.php?f=12&t=170637#p1182743

Ansonsten wäre mal interessant:

Code: Alles auswählen

systemd-analyze blame

Benutzeravatar
Taomon
Beiträge: 603
Registriert: 08.03.2011 16:34:38
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Nach boot reagiert System träge

Beitrag von Taomon » 11.04.2019 21:13:54

Der boot läuft normal. Aber wenn ich mich anmelde bei lightdm und in mate ein Programm starte, geh ich überspitz formuliert erst mal eine Tasse Kaffee aufbrühen, bis das Programm nutzbar ist.

Code: Alles auswählen

ls -al /media/alex/88411b09-1aaa-4775-9fc7-f60041049d6c/boot/
insgesamt 127376
drwxr-xr-x  6 root root     4096 Apr 10 19:57 .
drwxr-xr-x 25 root root     4096 Apr 10 19:56 ..
-rw-r--r--  1 root root   206399 Dez 30 22:13 config-4.19.0-0.bpo.1-amd64
-rw-r--r--  1 root root   206433 Feb  7 22:46 config-4.19.0-0.bpo.2-amd64
-rw-r--r--  1 root root   206141 Mär 27 23:05 config-4.19.0-0.bpo.4-amd64
-rw-r--r--  1 root root   186589 Feb 19 10:05 config-4.9.0-8-amd64
drwxr-xr-x  3 root root     4096 Apr  5  2016 extlinux
drwxr-xr-x  5 root root     4096 Apr 10 19:57 grub
drwxr-xr-x  2 root root     4096 Okt  2  2017 images
-rw-r--r--  1 root root 24904252 Jan 18 09:29 initrd.img-4.19.0-0.bpo.1-amd64
-rw-r--r--  1 root root 24923263 Mär 24 00:36 initrd.img-4.19.0-0.bpo.2-amd64
-rw-r--r--  1 root root 25482833 Apr 10 19:57 initrd.img-4.19.0-0.bpo.4-amd64
-rw-r--r--  1 root root 20861886 Feb 25 11:05 initrd.img-4.9.0-8-amd64
-rw-r--r--  1 root root    26664 Okt  1  2017 memdisk
-rw-r--r--  1 root root    98964 Jun 25  2015 memtest86.bin
-rw-r--r--  1 root root   182704 Jun 25  2015 memtest86+.bin
-rw-r--r--  1 root root   184840 Jun 25  2015 memtest86+_multiboot.bin
drwxr-xr-x  2 root root     4096 Mai 23  2017 mint
-rw-r--r--  1 root root  3278325 Dez 30 22:13 System.map-4.19.0-0.bpo.1-amd64
-rw-r--r--  1 root root  3278882 Feb  7 22:46 System.map-4.19.0-0.bpo.2-amd64
-rw-r--r--  1 root root  3299164 Mär 27 23:05 System.map-4.19.0-0.bpo.4-amd64
-rw-r--r--  1 root root  3196808 Feb 19 10:05 System.map-4.9.0-8-amd64
-rw-r--r--  1 root root  5184800 Dez 30 22:13 vmlinuz-4.19.0-0.bpo.1-amd64
-rw-r--r--  1 root root  5188896 Feb  7 22:46 vmlinuz-4.19.0-0.bpo.2-amd64
-rw-r--r--  1 root root  5225712 Mär 27 23:05 vmlinuz-4.19.0-0.bpo.4-amd64
-rw-r--r--  1 root root  4241184 Feb 19 10:05 vmlinuz-4.9.0-8-amd64
alex@beelzemon:~$ 
bin grad im 2 System, daher kann ich nicht abfragen woher virtualbox-5.2 stammt, denke aber von Oracle. haved ist installiert. Ich mich mit locate durch System gehangelt und noch reste von nvidia sowie den alten alsa-driver gefunden, die ich in squeeze selbst übersetzen mußte.

Also

Code: Alles auswählen

drwxr-xr-x 29 root root 4096 Jun  2  2013 alsa-driver-1.0.24
hier und unter /usr/src/modules habe ich noch einen Ordner von nvidia gefunden. Beides habe ich mal "mutig" gelöscht. Morgen werde ich sehen ob damit der obscure make prozeß verschwunden ist; und ob das meine Kerne so stark ausgelastet hat.

Gruß Taomon
Bitte gelegentliche Schreibfehler übersehen. Ich habe ADHS. Danke.

Benutzeravatar
willy4711
Beiträge: 1342
Registriert: 08.09.2018 16:51:16

Re: Nach boot reagiert System träge

Beitrag von willy4711 » 11.04.2019 21:29:40

Du hast jede Menge Backports Kernels installiert.

Warum fährst du dann den Default- Kernel von Stretch ?

Was hast du denn noch alles aus den Backports installiert ?

Bitte nachreichen:

Code: Alles auswählen

systemd-analyze blame

Benutzeravatar
Taomon
Beiträge: 603
Registriert: 08.03.2011 16:34:38
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Nach boot reagiert System träge

Beitrag von Taomon » 11.04.2019 21:41:10

Code: Alles auswählen

alex@Taomon:~$ systemd-analyze 
Startup finished in 11.839s (kernel) + 16.183s (userspace) = 28.023s
Ja, ich sollte mal wieder ein auto remove ausführen.

Code: Alles auswählen

alex@Taomon:~$ apt-show-versions | grep backport
linux-compiler-gcc-6-x86:amd64/stretch-backports 4.19.28-2~bpo9+1 uptodate
linux-headers-4.19.0-0.bpo.2-amd64:amd64/stretch-backports 4.19.16-1~bpo9+1 uptodate
linux-headers-4.19.0-0.bpo.2-common:all/stretch-backports 4.19.16-1~bpo9+1 uptodate
linux-headers-4.19.0-0.bpo.4-amd64:amd64/stretch-backports 4.19.28-2~bpo9+1 uptodate
linux-headers-4.19.0-0.bpo.4-common:all/stretch-backports 4.19.28-2~bpo9+1 uptodate
linux-headers-amd64:amd64/stretch-backports 4.19+104~bpo9+1 uptodate
linux-image-4.19.0-0.bpo.2-amd64:amd64/stretch-backports 4.19.16-1~bpo9+1 uptodate
linux-image-4.19.0-0.bpo.4-amd64:amd64/stretch-backports 4.19.28-2~bpo9+1 uptodate
linux-image-amd64:amd64/stretch-backports 4.19+104~bpo9+1 uptodate
linux-kbuild-4.19:amd64/stretch-backports 4.19.28-2~bpo9+1 uptodate
alex@Taomon:~$ 
so der make Prozeß war weg und nur noch 1 Kern stark ausgelastet. Das System hat schneller Eingaben entgegen genommen. (Passwort in thunderbird) sonst mußte ich immer warten.
Generell fühlen sich thunderbird und firefox-esr ein bißchen langsam an. aber das Grund-Problem scheint weg zu sein.

Gruß Taomon
Bitte gelegentliche Schreibfehler übersehen. Ich habe ADHS. Danke.

Antworten