ACPI Error: No handler for Region

Welches Modul/Treiber für welche Hardware, Kernel compilieren...
Antworten
silizium
Beiträge: 6
Registriert: 16.06.2018 12:44:09

ACPI Error: No handler for Region

Beitrag von silizium » 17.11.2020 18:15:24

So ich habe ein kleines Problem, vielleicht könnt ihr mir helfen. Ich weis das es nur ein kosmetischer Fehler ist, aber ich bekam die Meldung schon mal weg, duch einen eigenen Kernel, nur weis ich das Setting nicht mehr. Ich weis auch dass man acpi=off einstellen kann, aber ich möchte eine Lösung finden.
Mein System:
Dell EMC T40
Intel Xeon E-2224G
64 GB RAM
OS: Debian Buster 10 (KDE)
Kernel: 5.9.8
Also was ich schon probiert habe:
Andere Kernel Versionen = gleicher Fehler
Bios Update = gleicher Fehler
Bios umgestellt = gleicher Fehler
Im Internet findet man schon einiges darüber, aber alle sagen einfach ignorieren. Wäre sehr nett wenn mir jemand weiterhelfen könnte.


Hier meine dmesg Ausgabe:
[ 4.821473] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[ 4.822544] ACPI: Enabled 11 GPEs in block 00 to 7F
[ 4.822704] ACPI Error: No handler for Region [WST1] (00000000fd7b95be) [GenericSerialBus] (20200717/evregion-132)
[ 4.822709] ACPI Error: Region GenericSerialBus (ID=9) has no handler (20200717/exfldio-265)
[ 4.822712] ACPI Error: Aborting method \_SB.PCI0.I2C0.PAS1 due to previous error (AE_NOT_EXIST) (20200717/psparse-531)
[ 4.822717] ACPI Error: Aborting method \_GPE._L20 due to previous error (AE_NOT_EXIST) (20200717/psparse-531)
[ 4.822722] ACPI Error: AE_NOT_EXIST, while evaluating GPE method [_L20] (20200717/evgpe-515)

Wäre sehr Hilfreich wenn mir jemand helfen könnte.
Finde einfach keine Lösung dazu und steh voll auf dem Schlauch.

Danke im voraus.

LG

OrangeJuice
Beiträge: 292
Registriert: 12.06.2017 15:12:40

Re: ACPI Error: No handler for Region

Beitrag von OrangeJuice » 17.11.2020 20:01:54

Ich denke da wird der Mainboardhersteller etwas korrigieren müssen. Der Kernel geht die ACPI Tabelle durch, wenn etwas nicht stimmt, dann erscheint solch eine Meldung. Wenn alles funktioniert, sollte es so okay sein. Ansonsten den Hersteller mal anschreiben. Mir fallen dann nur diese Kernelparameter noch ein "acpi_osi=Linux acpi=noirq" oder "acpi=strict", "acpi=force"... du kannst die mal testen.
Wegen Fehlern in der ACPI-Implementierung vieler Hardwarekomponenten muss das Betriebssystem dieses undokumentierte Verhalten mit verschiedenen Methoden korrigieren. Das Betriebssystem Linux gibt sich dem BIOS gegenüber als Windows aus, um den besser getesteten Windows-Modus zu erhalten.
Quelle:Wikipedia
Ich habe die Fehler auch. Bei den Ryzen waren diese aber bei meinem System noch viel mehr vorhanden. Noch so eine Windows-Sache die bei meinen Asus Rechner nicht lief bzw. komisch funktionierte, war WMI(Link). Da wurden Module geladen, die im Prinzip nicht benötigt wurden. Also habe ich WMI auf die Blacklist gesetzt. ;)

silizium
Beiträge: 6
Registriert: 16.06.2018 12:44:09

Re: ACPI Error: No handler for Region

Beitrag von silizium » 20.11.2020 13:42:25

1.Bios update gemacht
2. Treiber von Github installiert aus folgender Quelle:

git https://git.kernel.org/pub/scm/linux/ke ... rmware.git

Trotzdem habe ich immer die gleichen Fehler.
Der Kernel erkennt die GPU nicht richtig!

Es steht dran "device 3e96"

meine GPU ist Intel(R) HD Graphics (Coffeelake 3x8 GT2)

Ich weiß nicht mehr weiter der Fehler tritt immer auf und teilweise auch sporadisch ganz setlsam, vielleicht ein Kernel Problem?
Kennt sich keiner besser damit aus?
Wo sind die Kernel-Experten die sich Menuconfig auskennen?

Bitte ein Ansatz für eine Lösung wäre sehr schön.

Wünsche euch ein schönes Wochenende :)

Benutzeravatar
towo
Beiträge: 3703
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: ACPI Error: No handler for Region

Beitrag von towo » 20.11.2020 14:28:22

1. Die "Fehler" sind harmlos und beeinträchtigen in keinster Weise die Funktion.
2. Was auch immer Du denkst, mittels einer Config Option im Kernel lassen sich diese Meldungen nicht beheben. Man könnte maximal den Loglevel so weit runter schrauben, dass man die Meldungen nicht mehr zu sehen bekommt.

Benutzeravatar
kalle123
Beiträge: 1143
Registriert: 28.03.2015 12:27:47
Wohnort: Mönchengladbach

Re: ACPI Error: No handler for Region

Beitrag von kalle123 » 20.11.2020 16:52:33

towo hat geschrieben: ↑ zum Beitrag ↑
20.11.2020 14:28:22
Man könnte maximal den Loglevel so weit runter schrauben, dass man die Meldungen nicht mehr zu sehen bekommt.
Näheres dazu findet sich z.B. hier

viewtopic.php?f=33&t=174206#p1212685

cu KH
ASUS PRIME X370-A + AMD Ryzen 5-2600, GeForce GT1030, 16GB, DEBIAN Buster Xfce
ASUS P5QL + Intel Core2 Duo E6750, GeForce GT710, 8GB, DEBIAN Testing Xfce
Lenovo Thinkpad T450s, DEBIAN Buster Xfce

silizium
Beiträge: 6
Registriert: 16.06.2018 12:44:09

Re: ACPI Error: No handler for Region

Beitrag von silizium » 21.11.2020 19:36:07

:mrgreen:
Also der Fehler ist nach wie vor habe die Anleitung vom Link befolgt.
jetzt werden gar keine Meldungen angezeigt beim booten außer die Fehlermeldung vor Luk2 Verschlüsselung.

Zitat Anfang aus der Verlinkung:
"
edit:
Ansonsten habe ich nur in »/etc/systemd/system.conf«
CODE: ALLES AUSWÄHLEN

ShowStatus=no
und
CODE: ALLES AUSWÄHLEN

update-initramfs -u
laufen lassen, damit die Meldungen beim Herunterfahren verschwinden.

An den printk-Werten musste ich direkt nie etwas ändern, Die Meldungen werden ja wahrscheinlich außerdem zumindest zum Teil noch ausgegeben während das /-Dateisystem noch gar nicht gemountet ist und nur die initrd geladen ist. Das bedeutet, dass Änderungen in /etc/sysctl(.d) oder /etc/sysf
"
Zitat Ende

Ich mache es lieber wieder Rückgängig möchte schon sehen was er beim Booten alles ladet und die Übersicht für Fehler noch zu haben ;).

Ps. Habe auch nochmals einen Kernel kompiliert mit voller ACPI unterstüztung und auch dies hat den Fehler nicht behoben.
Ich lasse es in Ruhe, glaub keiner kennt die Ursache außer Dell oder der Kernel-Entwickler.

Benutzeravatar
Tintom
Beiträge: 2140
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: ACPI Error: No handler for Region

Beitrag von Tintom » 21.11.2020 21:45:17

silizium hat geschrieben: ↑ zum Beitrag ↑
21.11.2020 19:36:07
Ich lasse es in Ruhe, glaub keiner kennt die Ursache außer Dell oder der Kernel-Entwickler.
Letzterer (welcher Entwickler?) wohl auch nicht, sonst gäbe es die Meldung in der Form nicht. Dell hingegen sagt genau das, was towo auch schon gesagt hat:

silizium
Beiträge: 6
Registriert: 16.06.2018 12:44:09

Re: ACPI Error: No handler for Region

Beitrag von silizium » 22.11.2020 13:12:40

ja eben.
Ich will aber Debian nutzen also ignoriere ich die Meldung alles läuft ja sonst.

Antworten