[gelöst] Neuer Kernel wird nicht genutzt

Welches Modul/Treiber für welche Hardware, Kernel compilieren...
spun
Beiträge: 23
Registriert: 10.10.2014 23:24:32
Wohnort: Berlin

[gelöst] Neuer Kernel wird nicht genutzt

Beitrag von spun » 25.11.2017 12:20:49

Hey,

ich nutze ein Debian9 Stretch.
Vor kurzen erhielt ich über die Updates den Kernel linux-headers-4.13.0-0.bpo.1-amd64:amd64.

Diesen und vor allem die neuen Grafiktreiber möchte ich natürlich nutzen. Jedoch wird nach dem Neustart weiterhin der alte genutzt. Wie kann ich den neuen Kernel und vor allem die neuen Grafiktreiber nutzen?

Einen reinstall habe ich bereits erfolglos versucht.
Zuletzt geändert von spun am 25.11.2017 20:05:57, insgesamt 1-mal geändert.

MSfree
Beiträge: 3423
Registriert: 25.09.2007 19:59:30

Re: Neuer Kernel wird nicht genutzt

Beitrag von MSfree » 25.11.2017 12:33:06

spun hat geschrieben: ↑ zum Beitrag ↑
25.11.2017 12:20:49
Vor kurzen erhielt ich über die Updates den Kernel linux-headers-4.13.0-0.bpo.1-amd64:amd64.
Das ist nicht der Kernel selbst sondern nur die Programmierschnittstelle für den Kenel 4.13.

spun
Beiträge: 23
Registriert: 10.10.2014 23:24:32
Wohnort: Berlin

Re: Neuer Kernel wird nicht genutzt

Beitrag von spun » 25.11.2017 12:37:09

Okay, Danke.

Das heißt, ich muss mich noch gedulden bis er verfügbar sein wird? Bin bei Kernelfragen etwas überfragt.
Danke jedoch für Deine info.

guennid
Beiträge: 11844
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: Neuer Kernel wird nicht genutzt

Beitrag von guennid » 25.11.2017 12:44:18

Was hat der denn da überhaupt wie gekriegt? Ich kenne sowas nicht. Wird's standardmäßiger vielleicht immer windowsiger?

Grüße, Günther

geier22

Re: Neuer Kernel wird nicht genutzt

Beitrag von geier22 » 25.11.2017 12:47:11

Arrgggg - Das ist ja Stable - und ich hab Testing - Also ist mein Beitrag zu ignorieren. :facepalm:
Aber hab mich trotzdem gewundert. 8O
Stimmt - habe mich auch gewundert, dass sich in /boot/ nichts sichtbares Verändert hat. anscheinend wurde
da einfach überschrieben, hatte schon überlegt, ob ich das Update überhaupt mache, da gleichzeitig der Kernel und Nvidia upgedatet wurden, was an sich in die Hose gehen sollte. aber funktioniert hat.
Vorher:

Code: Alles auswählen

$ uname -a
Linux sparkycinnamon 4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) x86_64 GNU/Linux
Nachher:

Code: Alles auswählen

$ uname -a
Linux sparkyxfce 4.13.0-1-amd64 #1 SMP Debian 4.13.13-1 (2017-11-16) x86_64 GNU/Linux

Code: Alles auswählen

ls -al /boot/
insgesamt 50532
drwxr-xr-x  4 root root     4096 Nov 24 07:52 .
drwxr-xr-x 23 root root     4096 Okt 17 15:34 ..
-rw-r--r--  1 root root   196564 Nov 16 22:04 config-4.13.0-1-amd64
drwxr-xr-x  3 root root     4096 Jul 24  2014 extlinux
drwxr-xr-x  6 root root     4096 Nov 22 12:28 grub
-rw-r--r--  1 root root 44061233 Nov 24 07:52 initrd.img-4.13.0-1-amd64
-rw-r--r--  1 root root  2998208 Nov 16 22:04 System.map-4.13.0-1-amd64
-rw-r--r--  1 root root  4466448 Nov 16 22:04 vmlinuz-4.13.0-1-amd64

Code: Alles auswählen

Start-Date: 2017-11-22  12:27:40
Commandline: /usr/bin/apt-get --show-upgraded dist-upgrade
Install: apparmor:amd64 (2.11.1-3, automatic)
Upgrade: libgles2-mesa:amd64 (17.2.4-1+b1, 17.2.5-1), nvidia-support:amd64 (20151021+4, 20151021+6), 
nvidia-kernel-common:amd64 (20151021+4, 20151021+6), linux-libc-dev:amd64 (4.13.4-2, 4.13.13-1), 
libegl-mesa0:amd64 (17.2.4-1+b1, 17.2.5-1), update-glx:amd64 (0.8.0, 0.8.1), linux-headers-4.13.0-1-amd64:amd64 (4.13.4-2, 4.13.13-1),
libglapi-mesa:amd64 (17.2.4-1+b1, 17.2.5-1), libglapi-mesa:i386 (17.2.4-1+b1, 17.2.5-1), 
nvidia-modprobe:amd64 (375.26-1, 384.98-1), 
linux-headers-4.13.0-1-common:amd64 (4.13.4-2, 4.13.13-1), 
nvidia-xconfig:amd64 (375.26-1, 375.82-1), libxatracker2:amd64 (17.2.4-1+b1, 17.2.5-1), 
libegl1-mesa:amd64 (17.2.4-1+b1, 17.2.5-1), glx-alternative-nvidia:amd64 (0.8.0, 0.8.1),
linux-compiler-gcc-6-x86:amd64 (4.13.4-2, 4.13.13-1), libgbm1:amd64 (17.2.4-1+b1, 17.2.5-1), 
libodbc1:amd64 (2.3.4-1, 2.3.4-1.1), libwayland-egl1-mesa:amd64 (17.2.4-1+b1, 17.2.5-1), glx-diversions:amd64 (0.8.0, 0.8.1), 
yad:amd64 (0.39.0-1, 0.40.0-1), libgl1-mesa-dri:amd64 (17.2.4-1+b1, 17.2.5-1), libgl1-mesa-dri:i386 (17.2.4-1+b1, 17.2.5-1), 
linux-image-4.13.0-1-amd64:amd64 (4.13.4-2, 4.13.13-1), nvidia-persistenced:amd64 (375.26-2, 384.98-1), 
libgl1-mesa-glx:amd64 (17.2.4-1+b1, 17.2.5-1), nvidia-installer-cleanup:amd64 (20151021+4, 20151021+6), linux-kbuild-4.13:amd64 (4.13.4-2, 4.13.13-1), mesa-vdpau-drivers:amd64 (17.2.4-1+b1, 17.2.5-1), 
glx-alternative-mesa:amd64 (0.8.0, 0.8.1), mediacenter23:amd64 (23.0.81, 23.0.84), libglx-mesa0:amd64 (17.2.4-1+b1, 17.2.5-1), libglx-mesa0:i386 (17.2.4-1+b1, 17.2.5-1)
End-Date: 2017-11-22  12:29:06

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21579
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: Neuer Kernel wird nicht genutzt

Beitrag von KBDCALLS » 25.11.2017 14:36:29

spun hat geschrieben: ↑ zum Beitrag ↑
25.11.2017 12:20:49
Hey,

ich nutze ein Debian9 Stretch.
Vor kurzen erhielt ich über die Updates den Kernel linux-headers-4.13.0-0.bpo.1-amd64:amd64.


Dann muß aber auch der Kernel vorhanden sein.

Code: Alles auswählen

matthias@hannelore:~$ rmadison linux-image-4.13.0-0.bpo.1-amd64
linux-image-4.13.0-0.bpo.1-amd64 | 4.13.13-1~bpo9+1 | stretch-backports | amd64
Was ergibt

Code: Alles auswählen

uname -a
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Benutzeravatar
orcape
Beiträge: 1332
Registriert: 07.11.2008 18:37:24
Wohnort: 12°10'08,01"E / 50°36'28,15"N
Kontaktdaten:

Re: Neuer Kernel wird nicht genutzt

Beitrag von orcape » 25.11.2017 15:09:38

Hi,
wenn der Neue Kernel bei....

Code: Alles auswählen

uname -a
...nicht angezeigt wird, ist der wohl kaum geladen.
Wird denn der Neue Kernel im Boot-Manager beim Systemstart überhaupt angezeigt?
Wenn nicht, würde wohl vielleicht ein....

Code: Alles auswählen

update-grub
...helfen, wenn das Image vorhanden ist.
Gruß orcape

spun
Beiträge: 23
Registriert: 10.10.2014 23:24:32
Wohnort: Berlin

Re: Neuer Kernel wird nicht genutzt

Beitrag von spun » 25.11.2017 15:15:39

Laut Log habe ich den neuen auch runtergeladen. Jedoch wurden Grafiktreiber teilweise wieder gelöscht.

Code: Alles auswählen

:~# uname -a
Linux thc 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux
Wie kann ich alles nochmal löschen und neu laden?

EDIT:

Code: Alles auswählen

update-grub
hat den alten gefunden.

Benutzeravatar
orcape
Beiträge: 1332
Registriert: 07.11.2008 18:37:24
Wohnort: 12°10'08,01"E / 50°36'28,15"N
Kontaktdaten:

Re: Neuer Kernel wird nicht genutzt

Beitrag von orcape » 25.11.2017 15:44:39

Code: Alles auswählen

update-grub
hat den alten gefunden.

Code: Alles auswählen

root@orca:/#aptitude search linuximage linux-headers
p   linux-headers-4.13.0-1-686:i386                  - Header files for Linux 4.13.0-1-686                        
p   linux-headers-4.13.0-1-686-pae:i386              - Header files for Linux 4.13.0-1-686-pae                    
p   linux-headers-4.13.0-1-all                       - All header files for Linux 4.13 (meta-package)             
p   linux-headers-4.13.0-1-all:i386                  - All header files for Linux 4.13 (meta-package)             
p   linux-headers-4.13.0-1-all-amd64                 - All header files for Linux 4.13 (meta-package)             
p   linux-headers-4.13.0-1-all-i386:i386             - All header files for Linux 4.13 (meta-package)             
i A linux-headers-4.13.0-1-amd64                     - Header files for Linux 4.13.0-1-amd64                      
i A linux-headers-4.13.0-1-common                    - Common header files for Linux 4.13.0-1                     
v   linux-headers-4.13.0-1-common:i386               -                                                            
i   linux-headers-4.9.0-2-common                     - Common header files for Linux 4.9.0-2                      
i   linux-headers-4.9.0-4-amd64                      - Header files for Linux 4.9.0-4-amd64                       
i A linux-headers-4.9.0-4-common                     - Common header files for Linux 4.9.0-4                      
p   linux-headers-686:i386                           - Header files for Linux 686 configuration (meta-package)    
p   linux-headers-686-pae:i386                       - Header files for Linux 686-pae configuration (meta-package)
i   linux-headers-amd64                              - Header files for Linux amd64 configuration (meta-package)
...wenn nicht installiert, "apt-get install".
Ob dann die NVIDIA-Karte noch unterstützt wird, wirst Du sehen.
Gruß orcape

Benutzeravatar
orcape
Beiträge: 1332
Registriert: 07.11.2008 18:37:24
Wohnort: 12°10'08,01"E / 50°36'28,15"N
Kontaktdaten:

Re: Neuer Kernel wird nicht genutzt

Beitrag von orcape » 25.11.2017 16:01:22

Sorry, bei Linux-image fehlte der Bindestrich. Dann kommen auch möglichen Images mit.

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 21579
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Re: Neuer Kernel wird nicht genutzt

Beitrag von KBDCALLS » 25.11.2017 16:34:13

Alternativ

Code: Alles auswählen

COLUMNS=170 dpkg -l linux*
oder

Code: Alles auswählen

aptitude search ^linux- |grep -v ^v
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

geier22

Re: Neuer Kernel wird nicht genutzt

Beitrag von geier22 » 25.11.2017 16:46:49

Aufschlussreich wäre auch:

Code: Alles auswählen

ls -al /boot/

spun
Beiträge: 23
Registriert: 10.10.2014 23:24:32
Wohnort: Berlin

Re: Neuer Kernel wird nicht genutzt

Beitrag von spun » 25.11.2017 17:06:34

Danke für eure Antworten und Hilfe. Jedoch bin ich jetzt etwas raus.
Was soll ich machen?

Ziel ist es, möglichst den aktuellen Kernel und vor allem jedoch, die aktuellen Grafiktreiber nutzen zu können. Erschwerend hinzu kommt das ich eine AMD Grafikkarte nutze, welche mir schon eine Menge Probleme bereitet, daher die Freude über das Update.

Aktuell läuft wie gesagt:

Code: Alles auswählen

uname -a
Linux thc 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux

Code: Alles auswählen

aptitude update && aptitude full-upgrade
bringt aktuell nichts. Es wurde nichts neues gefunden und es muss auch nichts aktualisiert werden.

Was ist jetzt am sinnvollsten?

Benutzeravatar
orcape
Beiträge: 1332
Registriert: 07.11.2008 18:37:24
Wohnort: 12°10'08,01"E / 50°36'28,15"N
Kontaktdaten:

Re: Neuer Kernel wird nicht genutzt

Beitrag von orcape » 25.11.2017 17:22:01

Hast Du denn überhaupt die /etc/apt/sources.list so angepasst, das er die Backports überhaupt findet?
Wenn nicht, solltest Du das tun oder Du nutzt gleich die Quellen von testing/buster.
Was die Grafikkarte angeht, da gibt es wohl nicht nur bei AMD Probleme sonder auch mit NVIDIA. Notfalls musst Du auf einen Nouveau-Treiber ausweichen.

Jana66
Beiträge: 3799
Registriert: 03.02.2016 12:41:11

Re: Neuer Kernel wird nicht genutzt

Beitrag von Jana66 » 25.11.2017 17:29:48

spun hat geschrieben: ↑ zum Beitrag ↑
25.11.2017 17:06:34
Erschwerend hinzu kommt das ich eine AMD Grafikkarte nutze ...
Welche genau ist Geheime Verschlusssache?
Zuletzt geändert von Jana66 am 25.11.2017 17:30:43, insgesamt 1-mal geändert.
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

Antworten