awk klappt nur als root (Debian 8.6 armhf) <obsolet>

Vom einfachen Programm zum fertigen Debian-Paket, Fragen rund um Programmiersprachen, Scripting und Lizenzierung.
scheisssystemd

awk klappt nur als root (Debian 8.6 armhf) <obsolet>

Beitrag von scheisssystemd » 03.01.2017 21:43:06

ich habe das system mittels debootstrap installiert.

eines der Probleme die sich presentieren ist das awk derzeit nicht als normal-User läuft

siehe test:

winfried@jessie-A80:~$ echo " 1 2 3 4 5 6">test
winfried@jessie-A80:~$ awk '{print $3 " " $6}' test
Getötet

als root klappts:

root@jessie-A80:~# awk '{print $3 " " $6}' /home/winfried/test
3 6


root@jessie-A80:~# l /usr/bin/awk
5252639 0 lrwxrwxrwx 1 root root 21 Jan 1 1970 /usr/bin/awk -> /etc/alternatives/awk

4064951 0 lrwxrwxrwx 1 root root 13 Jan 1 1970 /etc/alternatives/awk -> /usr/bin/mawk

5251934 72 -rwsr-xr-x 1 root root 69928 Mär 24 2012 /usr/bin/mawk

Wat nu??
Zuletzt geändert von scheisssystemd am 07.01.2017 14:17:06, insgesamt 1-mal geändert.

Benutzeravatar
whisper
Beiträge: 2078
Registriert: 23.09.2002 14:32:21
Lizenz eigener Beiträge: GNU Free Documentation License
Kontaktdaten:

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von whisper » 04.01.2017 06:34:12

mach mal als user

Code: Alles auswählen

ldd /usr/bin/mawk
Nicht, dass da eine Lib nicht gefunden wird.
Welche anderen Probleme denn?

dufty2
Beiträge: 1337
Registriert: 22.12.2013 16:41:16

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von dufty2 » 04.01.2017 17:53:05

Da ist scheinbar das setuid gesetzt (rws). Weiss nicht, ob das normal ist (unter armhf)?

scheisssystemd

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von scheisssystemd » 04.01.2017 22:05:11

whisper hat geschrieben:mach mal als user

Code: Alles auswählen

ldd /usr/bin/mawk
Nicht, dass da eine Lib nicht gefunden wird.
Welche anderen Probleme denn?
hast recht

ldd /usr/bin/mawk
das Programm ist nicht dynamisch gelinkt

ich denke das das am installieren mit debootstrap armhf und jessie liegt ( habe auch ne Platte mit wheezy so hochgezogen (vinit) dort gibt es keinerlei Probleme auf den armhf Platformen getestet A10, A20, A80)

da muß einiges nachgearbeitet werden

als Root wird es richtig registriert
# ldd /usr/bin/mawk
libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xb6ea3000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6db2000)
/lib/arm-linux-gnueabihf/ld-linux.so.3 => /lib/ld-linux-armhf.so.3 (0xb6f2d000)




wie bekomme ich denn die lib für solche Probleme für einen "normaluser" hin ohne das "die Tore weit" gestaltet wird?

ein weiteres Problem ist das evolution mit nem libEGL warning: DRI2: failed to authenticate .. Unable to eglMakeCurrent with no surface quitiert wird
hab das aber schon in der da für zuständigen Rubrik gepostet.

scheisssystemd

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von scheisssystemd » 04.01.2017 22:07:00

dufty2 hat geschrieben:Da ist scheinbar das setuid gesetzt (rws). Weiss nicht, ob das normal ist (unter armhf)?
zumindest wenn mit jessie mit debootstap installiert wird

Benutzeravatar
niemand
Beiträge: 10318
Registriert: 18.07.2004 16:43:29

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von niemand » 05.01.2017 04:21:39

zumindest wenn mit jessie mit debootstap installiert wird
Warum sollte bei der Installation via deboostrap unter armhf was anderes rauskommen, als unter amd64? Dort ist’s jedenfalls nicht der Fall.
Du möchtest schnell und unkompliziert auf meine Ignore-Liste? Schreibe einfach „Gesendet von meinem … mit Tapatalk“ unter deinen Beitrag, oder poste Textausgaben als Bild
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

Benutzeravatar
sbruder
Beiträge: 325
Registriert: 24.06.2016 13:54:36
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Wallmersbach

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von sbruder » 05.01.2017 12:01:04

Auf meinem armhf-System ist das nicht der Fall:

Code: Alles auswählen

vollkorn ~ % ls -lh /usr/bin/mawk
-rwxr-xr-x 1 root root 93K Apr  8  2012 /usr/bin/mawk
vollkorn ~ % uname -a
Linux vollkorn 4.4.34-v7+ #930 SMP Wed Nov 23 15:20:41 GMT 2016 armv7l GNU/Linux

scheisssystemd

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von scheisssystemd » 05.01.2017 20:48:10

sbruder hat geschrieben:Auf meinem armhf-System ist das nicht der Fall:

Code: Alles auswählen

vollkorn ~ % ls -lh /usr/bin/mawk
-rwxr-xr-x 1 root root 93K Apr  8  2012 /usr/bin/mawk
vollkorn ~ % uname -a
Linux vollkorn 4.4.34-v7+ #930 SMP Wed Nov 23 15:20:41 GMT 2016 armv7l GNU/Linux
schön

egal ob mod 0755 oder wie derzeit 4755 es klappt nicht

die Rechte vom File selbst haben auch nichts damit zu tun, ob der user auf die registrierung der lib's zugreifen darf . (idconf)

wann hast Du denn installiert ?

wie ich sehe hast Du einen raspi also warscheinlich nen system war bereits installmäßig angepasst ist.

wäre schön zu wissen wie man das händisch hin bekommt ohne das man gleich alle installationsroutienen der speziellen rpi-distr durcharbeiten muß um zu schauen was die bei der Standart jessie-distr anders machen.




auch mittels debootstrap oder nen fertiges Image ?
Zuletzt geändert von scheisssystemd am 05.01.2017 21:10:33, insgesamt 1-mal geändert.

Benutzeravatar
sbruder
Beiträge: 325
Registriert: 24.06.2016 13:54:36
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Wallmersbach

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von sbruder » 05.01.2017 20:51:58

scheisssystemd hat geschrieben: wann hast Du denn installiert ?
Mitte Februar 2016.
auch mittels debootstrap oder nen fertiges Image ?
Fertiges Image

Benutzeravatar
niemand
Beiträge: 10318
Registriert: 18.07.2004 16:43:29

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von niemand » 06.01.2017 03:32:43

wie ich sehe hast Du einen raspi also warscheinlich nen system war bereits installmäßig angepasst ist.
Gerade in einem alten Backup-Image von meinem Pi nachgeschaut: dort ist es ebenfalls ohne suid. Es handelte sich um ein gedebootstrapptes Jessie (allerdings armel). Auf einem gedeboostrappten Wheezy auf armhf ist’s ebenfalls ohne das. Gedebootstrapptes Jessie auf amd64 auch, wie schon geschrieben. Und in dem Paket lässt sich ebenfalls kein Hinweis darauf finden, dass das Flag gesetzt würde.

Die Frage ist also nun: warum weicht dein mawk von dem normalen Zustand ab? Ist das Flag das Einzige, was damit verkehrt ist, oder ist vielleicht gar das Binary kaputt, und es kommt deswegen zu diesem Fehler? Könntest du mal auf die aktuelle Version updaten, prüfen, ob der Fehler weiterhin auftritt, und wenn ja, einen als User erstellten Hash (md5, sha1, sha256 – für diesen Zweck egal, selbst eine CRC-Summe würde reichen) des Binaries posten (oder selbst mit der des Binaries aus dem Paket unter o.g. Link vergleichen)? Wenn dort alles okay ist, wäre auch mal die Ausgabe von strace von Interesse.


OT: dein Nick wird einige abhalten, dir überhaupt (ernsthaft) zu antworten. Nicht mal, weil du systemd nicht magst – davon gibt es hier einige, das ist kein Problem – sondern weil manche mit Fäkalsprache und unnötiger Provokation ihre Probleme haben (ich find’s auch nicht schön, btw.). Soll das so?
Du möchtest schnell und unkompliziert auf meine Ignore-Liste? Schreibe einfach „Gesendet von meinem … mit Tapatalk“ unter deinen Beitrag, oder poste Textausgaben als Bild
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

Benutzeravatar
Meillo
Moderator
Beiträge: 4608
Registriert: 21.06.2005 14:55:06
Wohnort: Balmora
Kontaktdaten:

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von Meillo » 06.01.2017 11:38:09

scheisssystemd hat geschrieben: ldd /usr/bin/mawk
das Programm ist nicht dynamisch gelinkt

ich denke das das am installieren mit debootstrap armhf und jessie liegt ( habe auch ne Platte mit wheezy so hochgezogen (vinit) dort gibt es keinerlei Probleme auf den armhf Platformen getestet A10, A20, A80)

da muß einiges nachgearbeitet werden

als Root wird es richtig registriert
# ldd /usr/bin/mawk
libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xb6ea3000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6db2000)
/lib/arm-linux-gnueabihf/ld-linux.so.3 => /lib/ld-linux-armhf.so.3 (0xb6f2d000)
Moment mal ... auf dem gleichen System die gleiche Executable wird einmal als statisch und einmal als dynamisch gelinkt angezeigt?

Mach mal bitte noch ein `file' darauf.

Und bist du dir sicher, dass du mit beiden Usern auf dem gleiche System arbeitest? Nicht dass die root-Session lokal laeuft und die User-Session woanders via ssh. (Das ist alles schon vorgekommen.)

Und dann wuerde mich unter beiden Usern noch ein `which -a awk' interessieren, denn AFAICS wurde noch nicht sichergestellt, dass beide User auch die gleiche Datei ausfuehren. Du kannst awk auch explizit mit vollem Pfad aufrufen, dann waere diese Unsicherheit eliminiert.


AWK muss jedenfalls nicht suid sein und ich wuesste auch nicht, dass es irgendwo so eingestellt waere.
Use ed(1) once in a while!

scheisssystemd

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von scheisssystemd » 06.01.2017 23:29:45

>Moment mal ... auf dem gleichen System die gleiche Executable wird einmal als statisch und einmal als dynamisch gelinkt angezeigt?

>Mach mal bitte noch ein `file' darauf.

winfried@jessie-A80:~$ file /usr/bin/awk
/usr/bin/awk: symbolic link to /etc/alternatives/awk
winfried@jessie-A80:~$ file /etc/alternatives/awk
/etc/alternatives/awk: symbolic link to /usr/bin/mawk
winfried@jessie-A80:~$ file /usr/bin/mawk
/usr/bin/mawk: setuid ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/arm-linux-gnueabihf/ld-linux.so.3, for GNU/Linux 2.6.26, BuildID[sha1]=90c51cf690474b8193f4a6bc7c03dfee334600a3, stripped

##### root#

root@jessie-A80:~# file /usr/bin/awk
/usr/bin/awk: symbolic link to /etc/alternatives/awk
root@jessie-A80:~# file /etc/alternatives/awk
/etc/alternatives/awk: symbolic link to /usr/bin/mawk
root@jessie-A80:~# file /usr/bin/mawk
/usr/bin/mawk: setuid ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/arm-linux-gnueabihf/ld-linux.so.3, for GNU/Linux 2.6.26, BuildID[sha1]=90c51cf690474b8193f4a6bc7c03dfee334600a3, stripped
root@jessie-A80:~#



Und bist du dir sicher, dass du mit beiden Usern auf dem gleiche System arbeitest? Nicht dass die root-Session lokal laeuft und die User-Session woanders via ssh. (Das ist alles schon vorgekommen.)

so wat von sicher! ist nicht mein Server sondern ne A80 TV-BOX die als Desktop dienen soll

> Und dann wuerde mich unter beiden Usern noch ein `which -a awk' interessieren, denn AFAICS wurde noch nicht sichergestellt, dass beide User auch die gleiche Datei ausfuehren.

winfried@jessie-A80:~$ which -a awk
/usr/bin/awk

root@jessie-A80:~# which -a awk
/usr/bin/awk


>Du kannst awk auch explizit mit vollem Pfad aufrufen, dann waere diese Unsicherheit eliminiert.

winfried@jessie-A80:~$ /usr/bin/awk '{print $3 " " $6}' test
Getötet
winfried@jessie-A80:~$ /usr/bin/mawk '{print $3 " " $6}' test
Getötet




>AWK muss jedenfalls nicht suid sein und ich wuesste auch nicht, dass es irgendwo so eingestellt waere.
da stimme ich Dir 100 % zu aber das behebt den effeckt nicht
im übrigen klappt der Standard telnet (link zu /usr/bin/telnet.netkit) auch nicht als normaluser. gleiche Meldung.

ich denke das ist die systemd usermanager zu tun. habe aber nicht mal im Ansatz Ahnung was das Teil diesbez macht.

ich hatte schon mal debootstap vor 1 Jahr mit jessie armhf versucht, da klappte so gut wie gar nix. nicht mal ne xsession


Benutzeravatar
niemand
Beiträge: 10318
Registriert: 18.07.2004 16:43:29

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von niemand » 07.01.2017 06:52:11

Die Hashes und die Ausgaben von strace hast du leider vergessen – könntest du die noch nachliefern?
ich denke das ist die systemd usermanager zu tun. habe aber nicht mal im Ansatz Ahnung was das Teil diesbez macht.
Was systemd damit zu tun hat, ist schnell erklärt: gar nichts.



OT: Dein -Tag ist kaputt, irgendwie ist dein ganzer Beitrag fettgeschrieben.
Zuletzt geändert von niemand am 07.01.2017 06:55:21, insgesamt 1-mal geändert.
Du möchtest schnell und unkompliziert auf meine Ignore-Liste? Schreibe einfach „Gesendet von meinem … mit Tapatalk“ unter deinen Beitrag, oder poste Textausgaben als Bild
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

dufty2
Beiträge: 1337
Registriert: 22.12.2013 16:41:16

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von dufty2 » 07.01.2017 06:55:05

Meillo hat geschrieben: Moment mal ... auf dem gleichen System die gleiche Executable wird einmal als statisch und einmal als dynamisch gelinkt angezeigt?
Denke, dass dem user 'winfried' einige grundlegende Rechte fehlen und/oder von wemauchimmer eingeschränkt werden,
so daß dieses "das Programm ist nicht dynamisch gelinkt" nur ein Folgefehler ist.

scheisssystemd

Re: awk klappt nur als root (Debian 8.6 armhf)

Beitrag von scheisssystemd » 07.01.2017 08:22:24

niemand hat geschrieben:Die Hashes und die Ausgaben von strace hast du leider vergessen – könntest du die noch nachliefern?
ich denke das ist die systemd usermanager zu tun. habe aber nicht mal im Ansatz Ahnung was das Teil diesbez macht.
Was systemd damit zu tun hat, ist schnell erklärt: gar nichts.

*g* asoo ....

OT: Dein -Tag ist kaputt, irgendwie ist dein ganzer Beitrag fettgeschrieben.


Wenn das bei Dir so angezeigt wird ...

ich glaube das das mich nicht wirklich weiter bringt, Trotzdem Danke

Antworten